If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Test Java Console 6.0.X uninstaller extensions

VERIFIED FIXED in 5.6

Status

addons.mozilla.org Graveyard
Compatibility Tools
P2
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: osunick, Assigned: osunick)

Tracking

(Depends on: 1 bug)

unspecified
Dependency tree / graph

Details

(Whiteboard: [qa-])

Attachments

(6 attachments, 12 obsolete attachments)

37.07 KB, image/png
Details
36.47 KB, image/png
Details
17.21 KB, application/x-zip-compressed
Details
17.19 KB, application/x-zip-compressed
Details
25.78 KB, application/x-zip-compressed
Details
25.37 KB, application/x-zip-compressed
Details
(Assignee)

Description

8 years ago
Jorge will add context:
(Assignee)

Comment 1

8 years ago
We should add a dialog that says the following:

"The Java Console extension is no longer supported and will be automatically removed the next time you restart Firefox.  This will not affect any Java applications or websites in any way."
The Java Console add-on is no longer supported by Sun, and it is so widely installed that it skews our compatibility stats. Sun has agreed to push an uninstaller for their Java Console add-ons.

The relevant add-ons are:
Java Console 6.0.00 (https://addons.mozilla.org/en-US/firefox/addon/5577)
Java Console 6.0.01 (https://addons.mozilla.org/en-US/firefox/addon/5661)
Java Console 6.0.02 (https://addons.mozilla.org/en-US/firefox/addon/5403)

The idea is to push updates to these 3 add-ons, which will contain code that uninstalls the add-on in most cases.

The min version of the updates is 3.6a1pre, so this update will only be pushed and installed in versions of Firefox since the 3.6 alphas. The maxVersion is 3.7a1pre, covering even current the nightlies.

The updates contain the code of their corresponding previous version, plus the uninstall code. The uninstall code will run *unless* the JRE version matches the Java Console version. So, if the JRE is 1.6.X and the add-on installed is Java Console 6.0.0X, the add-on will continue to work normally. This case is very unlikely considering how old these JREs are.

The add-on can be installed on any platform, but it's mostly useless in platforms other than Windows. The uninstaller works are expected in all platforms.

Mario is the engineer in charge of the project, he'll upload the latest versions of the add-ons for QA to review, and add any details I may be missing.
Forgot version 5.0.12 (https://addons.mozilla.org/en-US/firefox/addon/5578)
(In reply to comment #1)
> We should add a dialog that says the following:
> 
> "The Java Console extension is no longer supported and will be automatically
> removed the next time you restart Firefox.  This will not affect any Java
> applications or websites in any way."

Won't this dialog confuse users, most of which don't even know they have the add-on installed? Perhaps being stealthy will be less problematic...

Comment 5

8 years ago
cc'ing anthony to help with testing.  Anthony, as mentioned above, the AMO team would like some QA help with installing older versions of the java console (via amo or through jre package), and testing each of the new extensions in comment 2 will find the update and install itself over the old java console toolbar.  This extension, will in turn UNINSTALL the older toolbar, and should theoretically clean up all traces of the old extension.

I am told this will only work for 3.6a1pre and above builds.   So in addition to testing on 3.6b4; we will also test major updated builds with the java console extension preinstalled on 3.0.x and 3.5.x and then updated to 3.6b4.   (use channel "minortest").   

Jorge, nick, we will focus on Windows XP for now, unless you think there are other platforms that should get priority testing.
(Assignee)

Comment 6

8 years ago
Then I'd suggest suppressing the Add-ons manager on restart so that people don't get freaked out.  Is that possible?

(In reply to comment #4)
> (In reply to comment #1)
> > We should add a dialog that says the following:
> > 
> > "The Java Console extension is no longer supported and will be automatically
> > removed the next time you restart Firefox.  This will not affect any Java
> > applications or websites in any way."
> 
> Won't this dialog confuse users, most of which don't even know they have the
> add-on installed? Perhaps being stealthy will be less problematic...
It's possible, but not pretty. It's going to open because of the default behavior, and then mysteriously disappear. In some cases it may be just a flicker, but it's still going to look weird.

On the other hand, the expected behavior after an upgrade is to see the Add-ons Manager with a message saying that the upgrades were applied successfully. In this case the message will be "Restart to apply changes" instead. I think most users won't notice the difference and just think the updates were applied. Perhaps we can leave it at that...

The dialog is the most transparent approach. I just think this is going to be a big annoyance considering the large install base.
(Assignee)

Comment 8

8 years ago
I seem to remember it saying "this add-on will be uninstalled" in the add-ons manager on restart which seems like it would trigger quite a few questions.  Tony & Anthony, once you start testing can you let us know your opinion?
I've done some preliminary testing and am quite confused by upgrade paths and test scenarios for complete coverage.

1. I'm assuming we should have JRE 1.6u17 installed prior to running these tests
2. I've flagged the following builds for testing: 3.1, 3.1b3, 3.5, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.6b1, 3.6b2, 3.6b3, 3.6b4
3. "minortest" channel does not provide updates for all these builds
   a) Example, 3.0 I have to update on "release" up to 3.5.5 before "minortest" gives me 3.6b4
   b) Example, 3.1b3 gives me 3.6 on "beta" and nothing on "minortest"

I think identifying which builds are expected to have updates on "minortest" would go a long way to solving my confusion.

Also, are there other channels we should be testing on?  Does it matter the channel or is it the build which is important?

Thanks!
Priority: -- → P2
Target Milestone: --- → 5.5
Sorry, i was not clear.   Let me elaborate.

First and foremost, we should install and test the JRE and Java Console update
on Fx3.6beta4.  This should work there just fine.  

Next, we move on toward major updates.   We should be fine with only testing
Fx3.0.15 and Fx3.5.6 for major updates, since "minortest" channel only applies
to the latest released builds.    Can you confirm you see the update window on
these builds?

for JRE 1.6u0, that package will have the old toolbar.  Apply the Java Console
6.0.0.0 extension for the fix there.  Same goes for JRE 1.6u1 => Java Console
6.0.0.1, and JRE 1.6u2 => Java Console 6.0.0.2.   Archived JRE files are found
at: http://java.sun.com/products/archive/

The "minortest" channel will work with released firefox builds, but you can
also use a nightly channel of 3.0.15 or 3.5.6; which i believe should also
provide major updates.   

Does that help?  Dont hesitate to ask for more clarification.
Created attachment 416693 [details]
Java Console 5.0.12
Created attachment 416694 [details]
Java Console 6.0.00
Created attachment 416695 [details]
Java Console 6.0.01
Created attachment 416696 [details]
Java Console 6.0.02
    Nick, Jorge, can you point us on how we can test the fixed xpi when checking
    for updates?  We obviously can't test it against production AMO, so we'll need
    to check preview.addons i assume.   I think you mentioned changing where the
    hostfile is pointed to right?
for comment 11-14, just to be clear, these should be the new fixed xpis that should be deleting the existing java consoles.   Correct?
Hi.
I attached the zip files that contain the fixes for the Java Console add-ons,
in case someone doesn't have them.
Inside every zip file you will find the source code for the project and the xpi
file to install the fixing add-on (that will uninstall the Java Console) and to do the tests.
By the way, these fixes do not show the dialog window. These zip files were the
latest versions coded before this bug was created.
(In reply to comment #8)
> I seem to remember it saying "this add-on will be uninstalled" in the add-ons
> manager on restart which seems like it would trigger quite a few questions. 
> Tony & Anthony, once you start testing can you let us know your opinion?

Using Fx3.6b4, just tried downloading the java console 6.0.0.1 from AMO.  Then copied the fixed java console 6.0.0.1 xpi from here, and dropped it into the browser.  Observations:
1) Fx3.6b4 restarted with new xpi, and the Addons Manager window popped up after restart.
2) The addons manager shows Two instances of Java Console (old and new).  i think this is confusing to the user, because the one that says it will be "uninstalled when firefox is restarted," isn't the one we want them to remove!
3) Clicked Restart.
4) After restarting, the Addons Manager window did NOT come back.  I had to open Addons manager manually
5) Verify the Java Console is still shown.  It did not go away as expected.

See screenshots.  Given what i see, it doesnt look fixed.
Created attachment 416709 [details]
Java Console shows two instances in Addons Manager

This screenshot is after restarting with the "fixed" java console 6.0.0.1 xpi applied over the older java console 6.0.0.1.   Two instances are shown.
Created attachment 416710 [details]
Java Console after restart

This screenshot shows the java console after restarting with the "fixed" xpi.  It's still there.  I expected it to have dissapeared.
Hi Tony.
What is happening is this:
You have JRE 6.0 installed and you installed the fix for Java Console 6.0.00. The add-on for Java Console 6.0.00 will now be called Java Console 6.0_01. This add-on stays installed because you have the matching JRE 6.0 and Java Console 6.0.00 versions.

You don't have JRE 6.0u01 installed and you installed the fix for Java Console 6.0.01. The add-on for Java Console 6.0.01 will now be called Java Console 6.0.01_02. This add-on will be uninstalled next time you restart Firefox because you don't have the matching JRE 6.0u01 and Java Console 6.0.01 versions.
So, after restart, you won't see Java Console 6.0.01_02 anymore.

I hope this clarifies your testing scenario.
What about expected results with no JRE installed? Is this even a valid test scenario?
Well, this could be a valid test scenario if the user doesn't have a JRE 6.0uXX version installed on his computer. If he goes to the extensions site and decides to install the Java Console 6.00.XX fix, then:
- The extension fix will be installed for the first time (as any other extension would be)
- Firefox is restarted in order to complete the install process
- On the next Firefox load, the fix "knows" that Java Console 6.0.XX should be uninstalled and proceeds with the uninstall (because it didn't find any matching JRE 6.0uXX)
- Firefox is restarted for the second time in order to complete the uninstall process

The final result is that there should not be a Java Console 6.00.XX listed in the add-ons manager.
I've successfully gone through a single test run with Firefox 3.6b4 using Java Console 5.0.12 Add-on under three scenarios:

1. No JRE
2. JRE 1.5u12 installed
3. JRE 1.6u17 installed

You can see my results here: https://wiki.mozilla.org/User:Ashughes/QA/JavaConsole

Can someone please review those results to ensure both the results and my testing methods are accurate enough for this bug?  If so, I will continue testing the other scenarios in the Test Matrix on that page.

Thanks.
I checked your results and everything is fine.
You are using the correct testing methods and all the results behaved as expected :).
(In reply to comment #25)
> I checked your results and everything is fine.
> You are using the correct testing methods and all the results behaved as
> expected :).

Excellent!  You won't hear from me again until I've filled up that cute little matrix of mine.

Cheers!
Looks to be an all clear on 3.6b4.  I'm not moving onto Major Update builds.

In case you lost the URL of my results, here it is:
https://wiki.mozilla.org/User:Ashughes/QA/JavaConsole
"...I'm not moving..." should be
"...I'm now moving..."

Sorry :P
I've come across a potential bug.  I need someone to attempt reproduction:

1. Install Firefox 3.5.5
2. Change update channel to "minortest"
3. Update to Firefox 3.6b4
4. Install JRE 1.6u17
5. Start Firefox - should have JC 6.0.17
6. Uninstall JRE 1.6u17
7. Restart Firefox
8. Tools > Addons - should be prompted to remove JC 6.0.17
9. Restart Firefox
10. Keep repeating step 8 and 9 as it loops...
This is not considered a bug.
There is no fix for Java Console 6.0.17 because there is no official Java Console 6.0.17 available for install on the extensions site.
So, if you have Java Console 6.0.17 installed and you uninstall JRE 1.6u17, Java Console 6.0.17 should still remain installed because "no one" has told the extension that it should be uninstalled (no fix applied because there is no fix for that specific version).

I hope this clarifies your doubt. Otherwise, don't hesitate to post your questions.
Granted, but should the addon manager keep prompting to restart so it can uninstall JC 6.0.17?

If it's not being told to uninstall then I shouldn't be seeing the notification in the addon manager to "restart so firefox can uninstall" the addon.
(Assignee)

Comment 32

8 years ago
That sounds like a weird bug, can you attach the java console 6.0.17 extension or give us the ID for the extension?  Historically sun has created unique id's for every version of their java console.  Sounds like there may be a bug when the id matches what's expected but the version number is different.
Created attachment 417536 [details]
Java Console 5.0.12 V2.0

Added an alert window that tells the user the Java Console add-on will be uninstalled next time Firefox is restarted
Created attachment 417537 [details]
Java Console 6.0.00 V2.0

Added an alert window that tells the user the Java Console add-on will be uninstalled next time Firefox is restarted
Created attachment 417539 [details]
Java Console 6.0.01 V2.0

Added an alert window that tells the user the Java Console add-on will be uninstalled next time Firefox is restarted
Created attachment 417540 [details]
Java Console 6.0.02 V2.0

Added an alert window that tells the user the Java Console add-on will be uninstalled next time Firefox is restarted
Hi.
I uploaded new versions of the Java Console fix.
This new version of the add-on displays an alert message to the user after applying the fix, telling that the Java Console add-on will be uninstalled next time Firefox is restarted.

Please test these fixes and let us know what you think.
I just tried the 6.0.0.2 patch, and applying the xpi after restart says 
"The Java Console extension is no longer supported and will be automatically removed the next time you restart Firefox.  This will not affect any Java applications or websites in any way."

Sure enough, restarting removes the previous java 6.0.0.2 extension.   I'll give it a try with the other versions now.

The alert message makes it a lot more clearer now to the user.  Thanks Mario.
Okay i've tested the 2nd versions of java console 6.0.0.0, 6.0.0.1, and 6.0.0.2, to all successfully update a Fx3.5.5 user to Fx3.6b4.  After restart, the alert window instantly notifies the user of the no-support warning, and then uninstalls the older console after restart.   

I've only checked no JRE, and major updating Fx3.5.5 -> Fx3.6b4.  Also didnt test Fx3.0.17 scenario.

Anthony, i updated my results in your table.  There still the other cells in the matrix we should go through, but for now, i dont anticipate any problems with the patches.
Created attachment 417710 [details]
Java Console 5.0.12 V2.1

Fixing minVersion/maxVersion information on the add-on fix.
I left a 1.* to 3.* rdf information by mistake (that's the one I used for my tests)
Attachment #417536 - Attachment is obsolete: true
Created attachment 417711 [details]
Java Console 6.0.00 V2.1

Fixing minVersion/maxVersion information on the add-on fix.
I left a 1.* to 3.* rdf information by mistake (that's the one I used for my tests)
Attachment #417537 - Attachment is obsolete: true
Created attachment 417712 [details]
Java Console 6.0.01 V2.1

Fixing minVersion/maxVersion information on the add-on fix.
I left a 1.* to 3.* rdf information by mistake (that's the one I used for my tests)
Attachment #417539 - Attachment is obsolete: true
Created attachment 417713 [details]
Java Console 6.0.02 V2.1

Fixing minVersion/maxVersion information on the add-on fix.
I left a 1.* to 3.* rdf information by mistake (that's the one I used for my tests)
Attachment #417540 - Attachment is obsolete: true
I'm sorry for all the SPAM comments.
I uploaded by mistake my testing files, which had a 
        <em:minVersion>1.*</em:minVersion>
        <em:maxVersion>3.*</em:maxVersion>
in the install.rdf file

I corrected all the install.rdf files to
        <em:minVersion>3.6a1pre</em:minVersion>
        <em:maxVersion>3.7a1pre</em:maxVersion>

That's the only differencies between V2.0 and V2.1 of the add-on fixes.
I'm not 100% sure about the idea of an alert notification.  When I install the addon (no JRE installed) and restart, the addon manager appears by default (since I just installed an addon).  This dialog warns me that the addon is going to be uninstalled when I restart.

I like the idea of being told WHY I need to restart (ie. addon is no longer supported).  However, I don't like having to click OK then having to go over to the add-ons manager to restart Firefox.

Would it be possible to change the alert to have two buttons:
"Restart Now", "Restart Later"
Another suggestion...

Perhaps we should be showing the Addon Manager after uninstalling this addon to show that it was safely removed...
As per the results posted at the following link, everything looks good so far.  The only thing remaining to test is 3.0.x -> 3.5b4.  Currently, I can't seem to get updates via minortest for 3.0.x.  JuanB is looking into this issue.

Once we have a chance to test a single 3.0.x-3.6b4 build, QA signs off.

https://wiki.mozilla.org/User:Ashughes/QA/JavaConsole
Any updates here?
(In reply to comment #45) 
> Would it be possible to change the alert to have two buttons:
> "Restart Now", "Restart Later"

Yes, that's possible. Do you want us to do this?

(In reply to comment #46) 
> Perhaps we should be showing the Addon Manager after uninstalling this addon to
> show that it was safely removed...

This, we can't do. Once the add-on is uninstalled, there's nothing we can do to change the default behavior of Firefox.
(In reply to comment #49)
> (In reply to comment #45) 
> > Would it be possible to change the alert to have two buttons:
> > "Restart Now", "Restart Later"
> 
> Yes, that's possible. Do you want us to do this?
> 
As an advocate of the user, this would be a much better user experience.

> (In reply to comment #46) 
> > Perhaps we should be showing the Addon Manager after uninstalling this addon to
> > show that it was safely removed...
> 
> This, we can't do. Once the add-on is uninstalled, there's nothing we can do to
> change the default behavior of Firefox.

Correct.

Anthony, i believe the update channel for 3.0.15 -> 3.6b4 is "majortest".   This i just found out.  "minortest is for 3.5.5 -> 3.6b4.   Can you try it there?
Created attachment 419093 [details]
Java Console 5.0.12 V2.2

Adding question "Do you want to restart Firefox now?" and buttons "Restart now" and "Restart later" to the user message.
Attachment #416693 - Attachment is obsolete: true
Attachment #417710 - Attachment is obsolete: true
Created attachment 419094 [details]
Java Console 6.0.00 V2.2

Adding question "Do you want to restart Firefox now?" and buttons "Restart now" and "Restart later" to the user message.
Attachment #416694 - Attachment is obsolete: true
Attachment #417711 - Attachment is obsolete: true
Created attachment 419095 [details]
Java Console 6.0.01 V2.2

Adding question "Do you want to restart Firefox now?" and buttons "Restart now" and "Restart later" to the user message.
Attachment #416695 - Attachment is obsolete: true
Attachment #417712 - Attachment is obsolete: true
Created attachment 419096 [details]
Java Console 6.0.02 V2.2

Adding question "Do you want to restart Firefox now?" and buttons "Restart now" and "Restart later" to the user message.
Attachment #416696 - Attachment is obsolete: true
Attachment #417713 - Attachment is obsolete: true
(In reply to comment #50)
> (In reply to comment #49)
> > (In reply to comment #45) 
> > > Would it be possible to change the alert to have two buttons:
> > > "Restart Now", "Restart Later"
> > 
> > Yes, that's possible. Do you want us to do this?
> > 
> As an advocate of the user, this would be a much better user experience.

Done :)
Now the informative message for the user will have the "Restart now" and "Restart later" buttons. 

This informative message will be displayed one second after the add-ons window is displayed. 
I had to do it this way so the add-ons window is closed when the restart button is hit.
If I showed the informative message before the add-ons window is displayed and hit the restart button, the add-ons window stays opened and the Firefox restart is not executed
QA: can you check this?
(In reply to comment #56)
> QA: can you check this?

I can check this when I get home tonight.  I'm at work right now and cannot check this until then.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5

I just tested all four versions using RESTART NOW and RESTART LATER scenarios.  All looks good on my end.  I find the user experience to be better with the new buttons, thanks.  I'll let tchung make the final QA call.
Assignee: nobody → tchung
The changes to the messaging looks great.  QA signs off the extensions.  They're ready for push to updates when you're good to go.  Thanks for all the hard work folks!
Assignee: tchung → nnguyen
(Assignee)

Comment 60

8 years ago
this is on me to upload
Target Milestone: 5.5 → 5.6
(Assignee)

Comment 61

8 years ago
Uploaded 2 weeks ago.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
its there.  https://addons.mozilla.org/en-US/firefox/search?q=java+console+&cat=all&advancedsearch=1&as=1&appid=1&lver=any&atype=0&pp=20&pid=3&sort=&lup=
Status: RESOLVED → VERIFIED

Updated

7 years ago
Depends on: 575004

Updated

7 years ago
Depends on: 622412
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.