Closed Bug 533780 Opened 10 years ago Closed 9 years ago

Add repack-on-change builders for Fennec Win32

Categories

(Release Engineering :: General, defect, P4)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 650822

People

(Reporter: armenzg, Assigned: armenzg)

Details

(Whiteboard: [l10n][fennec][oldbugs])

Attachments

(1 file)

We currently have Fennec OSX Desktop L10n builds off since the builds are not being generated localized (bug 531498).

For win32, even though we have the builders. We need to add to l10nbuilds2.ini the Win32 builder to it. This should be an easy fix.
Assignee: armenzg → nobody
Component: Release Engineering: Future → Release Engineering
Priority: -- → P2
Assignee: nobody → armenzg
This worked on staging.
I am not adding OSX since we have them disabled (waiting on bug 531498).
Attachment #422404 - Flags: review?(ccooper)
Attachment #422404 - Flags: review?(ccooper) → review+
Comment on attachment 422404 [details] [diff] [review]
[buildbot-configs] add Win32 Fennec repack-on-change

http://hg.mozilla.org/build/buildbot-configs/rev/8d4222ba4839
Attachment #422404 - Flags: checked-in+
This bug is fixed for Win32 Fennec Desktop builds but for Mac builds we will have to wait on bug 531498.

Putting into the future and marking as unassigned until the other bug gets fixed.
Assignee: armenzg → nobody
Component: Release Engineering → Release Engineering: Future
Priority: P2 → --
Whiteboard: [l10n]
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
Assignee: nobody → armenzg
Status: NEW → ASSIGNED
Priority: P3 → P4
In general I don't see any repackages on change for Fennec and I have not seen or heard a huge push for this. This is the only bug I aware and I believe that nightly repackages should be good enough for testing. Is this OK?

(In reply to comment #3)
> This bug is fixed for Win32 Fennec Desktop builds but for Mac builds we will
> have to wait on bug 531498.
> 
> Putting into the future and marking as unassigned until the other bug gets
> fixed.

I see repacks for Win32 happening every night.

I see that bug 531498 has not had any activity and I doubt will be picked up anytime soon.

I would like to close this bug as WORKSFORME and file another one once we have localized OSX Fennec builds.

sounds OK?
Whiteboard: [l10n] → [l10n][fennec]
There hasn't been a huge push for l10n repacks on push because I had no idea there weren't any. We sure should do them.
I am removing OSX Fennec desktop builds as nobody has pushed for having localized OSX Fennec desktop builds on bug 531498. We can file a new bug later on if one day we actually have them localized.

Is this bug just for the sake of parity? Do we have any localizers that would want this?
No longer depends on: 531498
Summary: Add repack-on-change builders for Fennec Win32 & OS X desktop L10n → Add repack-on-change builders for Fennec Win32
Whiteboard: [l10n][fennec] → [l10n][fennec][oldbugs]
Priority: P4 → P3
Priority: P3 → P4
Priority: P4 → P5
@triagefollowup

I won't be able to get this.

We would like to have repackages on change for Fennec on Win32 as we currently only have nightly builds.

The current builders are on pm02:8010 (the mobile master) running on 0.7.x.

IMHO localizers should have enough with the nightly repackages but that is just my opinion.
Whiteboard: [l10n][fennec][oldbugs] → [l10n][fennec][oldbugs][triagefollowup]
Priority: P5 → P4
I am going to keep 2 of my oldbugs.
Whiteboard: [l10n][fennec][oldbugs][triagefollowup] → [l10n][fennec][oldbugs]
Armen: can you check with Aki to see where this falls relative to other mobile priorities?
We probably don't need actual repacks on change anymore for mobile.
We have nightlies for the mobile desktop platforms; xpis will be the way forward.

Filed bug 650822 to track those.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650822
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.