for sending patches inline, would like option to totally disable wrapping and format=flowed

RESOLVED DUPLICATE of bug 86607

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 86607
9 years ago
8 years ago

People

(Reporter: chris.friesen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090922 Fedora/3.0-2.7.b4.fc11 Thunderbird/3.0b4

When sending patches to open-source projects such as glibc or the linux kernel, the standard is to include the patch inline with the comments.

Since many core developers use custom scripts to handle incoming patches, and there are quite a few possible gotchas when mixing patches and format=flowed the expected behaviour is to NOT flow the text or wrap lines for these emails.

It is convenient to support flowed text for other communication, so it would be nice to have an option to disable wrapping and format=flowed on the fly when composing a message.  Ideally it would be nice if this applied to both text and HTML composition.

To obtain the desired behaviour currently requires entering the configuration editor and adjusting the format=flowed options, as well as either using the preformat option or setting "wrap" to 0.  This is tedious and shouldn't be necessary.

Reproducible: Always

Steps to Reproduce:
1.create a message with a line longer than the wrap length
2.send the message to yourself
3.observe the raw source using ctrl-u and see that it was wrapped and/or flowed


Expected Results:  
I'd like to be able to select "raw" or "really preformatted" or something when creating the message to completely disable all adjustment of the text and send it *exactly* as entered.

Updated

8 years ago
OS: Linux → All
Hardware: x86 → All

Updated

8 years ago
Duplicate of this bug: 537467
(Reporter)

Comment 2

8 years ago
Arguably 534068 is not a dupe of this bug, although they're related.  That one is about displaying the received message, while this one is about not flowing/wrapping when sending a message.

Comment 3

8 years ago
This is a dupe, or a superset, of bug 86607.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 86607

Comment 5

8 years ago
about:config (Prefs|Advanced|Config Editor...),
mailnews.send_plaintext_flowed = false
You need to log in before you can comment on or make changes to this bug.