Check previous version's status to determine beta vs. public in updates

VERIFIED FIXED in 5.5

Status

defect
P2
normal
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: jbalogh, Assigned: jbalogh)

Tracking

unspecified
Dependency tree / graph
Bug Flags:
in-litmus +

Details

Attachments

(1 attachment)

Assignee

Description

10 years ago
Weave users can't upgrade to 1.0b3 (admin'd to Public) since the update script thinks of 1.0b2 as a Beta version.
Comment on attachment 417573 [details] [diff] [review]
considering the previous version's status for beta updates

I thought we were going to run it through the beta regex first.
Attachment #417573 - Flags: review?(clouserw) → review+
Assignee

Comment 3

10 years ago
The query is only run under the $want_beta branch, and $want_beta is determined using the regex.
Assignee

Comment 4

10 years ago
r57921
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Priority: -- → P2
Resolution: --- → FIXED
Assignee

Comment 6

10 years ago
1. Install Weave 1.0b2 from amo.
2. Download 1.0b3 from amo, upload it to preview (so you have something to upgrade to).
3. Change extensions.update.url to preview.
4. Try to upgrade.
5. Profit!
Verified FIXED; worked with Jeff on the steps above.

(Jeff also landed a fix in r58082, to help us test, and safeguard against an edge-case.)
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 535588

Updated

10 years ago
Depends on: 526077
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.