Message header pane says "to You" but search filters says "To Me"

RESOLVED FIXED in Thunderbird 8.0

Status

defect
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: u142003, Assigned: squib)

Tracking

(Blocks 1 bug, {polish})

Trunk
Thunderbird 8.0
Dependency tree / graph
Bug Flags:
wanted-thunderbird +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

If you open an email message sent to you, the message header pane says "to You". But if you do a search, the filters say "From Me" and "To Me". There seems to be some confusion between the personal pronouns. 

Reproducible: Always




This bug is somewhat related to bug 478466.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3.1?
Keywords: polish
Agreed that this is weird, but I don't think we'd hold for it if it were the last bug standing, so blocking-.  That said, it should be really easy fix, and avoiding cognitive dissonance will make the product feel nicer to users, so wanted+.
Flags: blocking-thunderbird3.1? → wanted-thunderbird+
this issue may span components, but I don't think that's good reason for keeping things in General. we can just pick one -> Search
Component: General → Search
QA Contact: general → search
Version: unspecified → 3.0
Per bug 478466 comment #89, it should make more sense to change the message headers from "You" to "Me". In this way, the conflict of "You" versus "You"
with different levels of politeness in various locales would be mitigated.
Version: 3.0 → Trunk
Blocks: me-header
:bwinton, what do you think about switching the "You" in the header to "Me"? I think this is generally more consistent with other places in Thunderbird and in computers in general (e.g. "My Computer"). For what it's worth, Gmail also uses "me".
How many localizers are already using "Me" instead of "You"?


Here are the forces I see at play:

- "To Me" sounds to me (heh) like the email was sent to Thunderbird, or to the user's computer, not to the user.

- But it is inconsistent to use "You" in some places and "Me" in others.

- But they are two different contexts, one is passive (the user is receiving email sent to them), the other is active (the user is saying "I want to search for email sent to me.").

- But that's for English only, which is a weird language.

- And Conversations uses "Me" everywhere and it's not too bad.

- Finally, email sent from you makes more sense as "from Me", since that's active again (the user sent the email).


So, to sum up, I think consistency beats English here, and we should make the change.

Thanks,
Blake.
> - "To Me" sounds to me (heh) like the email was sent to Thunderbird,
> or to the user's computer, not to the user.

That depends on viewpoint. "You" means Thunderbird is speaking to me like a human does. "Me" means that Thunderbird stands for me (User-Agent). Thunderbird and me are one (lovely, no?).

Both are fine for me, but "You" is more impersonal, official, while "Me" feels more personal, intimate.
(In other words, are Thunderbird and the user 2 parties opposite of each other, or are they the same party? Matter of viewpoint.)
Not too much to say here. The patch just updates some strings and some test code.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #546472 - Flags: review?(bwinton)
Comment on attachment 546472 [details] [diff] [review]
"Me" is the new "You"

Review of attachment 546472 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, and thanks for updating the tests, too!

r=me!

Later,
Blake.
Attachment #546472 - Flags: review?(bwinton) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/9443b6a6b7e3
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
You need to log in before you can comment on or make changes to this bug.