Reply font size changes during compose

RESOLVED DUPLICATE of bug 203810

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 203810
8 years ago
8 years ago

People

(Reporter: moustaka@sjsu.edu, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0

In the middle of my response to or forwarding of a message, the font size, the "bold" format, and the line spacing change all of a sudden, forcing me to fix them every time (except for the line spacing) as I continue writing my message,  This problem started after I updated to Thunderbird 3.0

Reproducible: Didn't try

Steps to Reproduce:
1.Reply to a message
2.Choose "larger font size", Tahoma
3.Compose a 3-4 lineresponse
Actual Results:  
In the middle of my response, the "larger font size" disappeared, all of a sudden.  Trying to write the next words with the "larger font size" would fix them, though, not the subsequent words.

Expected Results:  
It should continue producing a "larger font size" text.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Why was this marked FIXED? There were no patches checked into the tree. Mozving back to UNCO
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 2

8 years ago
Do you still see this in version 3.0.1?
Does this happen with every message you reply to?

I can't reproduce with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100108 Shredder/3.0.1pre
Component: General → Message Compose Window
QA Contact: general → message-compose
Summary: Response Problem → Reply font size changes during compose
Version: unspecified → 3.0

Comment 3

8 years ago
I am also having this problem and I'm using 3.0.3. It does indeed seem to only happen during a reply but it is consistent. Backspacing through the most recent character with the correct font size, then continuing seems to temporarily remedy the problem but it reoccurs throughout the reply. It always increases the font to the next size up. Highlighting all text then increasing/decreasing font size only causes the larger font to decrease/increase along with the smaller font. My composition settings are as follows:
forward messages: inline
add extension to file name: checked
auto save every: 5 minutes, checked
confirm when using keyboard shortcut to send messages: checked
check for missing attachments: checked
Html font: Helvetica, Arial
size: small

and my signature is a simple html file.

I hope this helps.

Comment 4

8 years ago
I've managed to reliably reproduce the problem. No matter if it is a reply or a new composition, hitting the "end" button to move to the end of the line switches the font to "variable width" and increases its size by one level. More specifically, when the font size under "composition" is set to "small", the first character entered (including space) causes the email message to shift a slight bit. If at some point after this you move to the very end of the line using the "end" key or by clicking past the end of the line, the font style changes to "variable width," again shifting the entire message. Characters typed after that point will be at the larger font size. Switching to the "medium" font size in the "composition" options dialog seems to fix the annoying size shifting problem but not the problem with the font style changing. I hope this helps.
(Reporter)

Comment 5

8 years ago
Another, possibly, useful observation.  Initially, after typing a couple of words in response to a message below the text of my response, if I go back to make a correction and then attempt to continue my response, the fonts automatically change.  I've done it several times with both English and Greek with exactly the same outcome.  Hopefully, the repeatability of the glitch in this case might lead to the discovery and eventual correction of its cause.

Comment 6

8 years ago
Eventual correction of its cause? This is a ridiculous problem and should be fixed immediately. Also, why can't we set a font size when composing emails? Smaller and larger? What are we, in second grade?
This looks quite a bit like bug 250539 (especially see bug 250539 comment #63) -- Evan (reporter), does that seem correct?

(In reply to comment #6)
If you want to vent a bit of spleen, have fun looking at bug 250539, where there should be enough frustration for nearly anyone. But do take a look at bug 250539 comment 89 first.

Comment 8

8 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6)
> Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
> Build Identifier: Thunderbird 3.0
> 
> In the middle of my response to or forwarding of a message, the font size, the
> "bold" format, and the line spacing change all of a sudden, forcing me to fix
> them every time (except for the line spacing) as I continue writing my message,
>  This problem started after I updated to Thunderbird 3.0
> 
> Reproducible: Didn't try
> 
> Steps to Reproduce:
> 1.Reply to a message
> 2.Choose "larger font size", Tahoma
> 3.Compose a 3-4 lineresponse
> Actual Results:  
> In the middle of my response, the "larger font size" disappeared, all of a
> sudden.  Trying to write the next words with the "larger font size" would fix
> them, though, not the subsequent words.
> 
> Expected Results:  
> It should continue producing a "larger font size" text.

We're having the same issue on a Win XP Pro (SP3) running Thunderbird 3.0.4. It's only occurring on this one computer in the office.

Comment 9

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
OS: Windows 7
Steps to reproduce:
1) Reply to a message
2) start typing the text of the reply
3) press the "end" key
4) resume typing, notice that font size has gotten smaller
WFM with Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100517 Shredder/3.2a1pre. Try safe mode perhaps

Comment 11

8 years ago
This problem is driving me crazy using 3.1.
Even when I finally am able to get the correct sizes and fonts into the message I cannot depend on it to be sent that way.
I have two  copies of the same (as best I can tell) message. One will display  fonts sizes differently than the other copy. I have compared the sources and they look identical.
I've been using TB since the version .4 but am considering jumping ship due to this.

Comment 12

8 years ago
Can we assume this is Windows only? I don't recall seeing it on a Mac.

Comment 13

8 years ago
I'm using fedora 13

Comment 14

8 years ago
Is it only Linux and Windows which are affected by this?

Comment 15

8 years ago
(In reply to comment #12)
> Can we assume this is Windows only? I don't recall seeing it on a Mac.

I'm using Thunderbird 3.0.5 on an iMac, OS X 10.5.8, and it happens to me, too - in my case, the font suddenly gets smaller.  I tried switching back to Thunderbird 2.0.0.24, and at first all seemed OK; then it happened with that version of TB also.

Comment 16

8 years ago
Thanks for the iMac comment.

I have used several versions of TB (all POP only) on several Macs and don't recall seeing this. I now use TB 3.1 mainly on a G4 with OS X 10.5.8.

Updated

8 years ago
Whiteboard: [gs]

Comment 17

8 years ago
3.1.2 Vista Home Premium.  Confirm this bug.  And it is driving me crazy--am almost to the point of having to give up Thunderbird.  It is frequent...you are just typing along and suddenly you have a reduced font size. THIS IS A MAJOR BUG AND NEEDS TO BE ADDRESSED IMMEDIATELY.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514265

Comment 19

8 years ago
(In reply to comment #18)
> *** This bug has been marked as a duplicate of bug 514265 ***

WHAT ?!?  

Bug 514265's description regards the changing of the font itself (user-selected default to "Variable").  This bug describes the changing of the font size.  Unless you know what part of the code is broken, and know that these two bugs have the same cause, this is not a duplicate of Bug 514265.

Comment 20

8 years ago
Is this an HTML problem only? I seldom compose with HTML and don't have this
issue with TB 3.1.2 on a G4 with OS X 10.5.8.

However, I did have a difficult to track down font issue with an identical G4.
I eventually discovered that most of the considerable fonts in
/Applications/Thunderbird.app/Contents/MacOS/greprefs/all.js were set to zero
size. I removed many unwanted fonts and set all the others to reasonable sizes.
This cured my problems with this G4.

The other identical G4 has not had the problem - on checking I see that all its
font sizes in greprefs are reasonable. Although the G4s are identical their TB
update histories may be different ie fresh installs vs updates may have varied
from time to time.

Comment 21

8 years ago
(In reply to comment #19)
> (In reply to comment #18)
> > *** This bug has been marked as a duplicate of bug 514265 ***
> 
> WHAT ?!?  
> 
> Bug 514265's description regards the changing of the font itself (user-selected
> default to "Variable").  This bug describes the changing of the font size. 
> Unless you know what part of the code is broken, and know that these two bugs
> have the same cause, this is not a duplicate of Bug 514265.

I agree completely with Comment #19 - Bug 536613 has to do with changes in font _size_, not changes in the font itself.  They're two different problems.

Comment 22

8 years ago
After private discussions with :Usul, we agree that this bug is not a DUP of 514265; I am, therefore, setting it back to UNCONFIRMED.  For those watching, note that UNCONFIRMED means that we need repeatable steps that others can use to cause the problem to occur; this may be difficult, but for those who have this problem, please pay close attention to ALL your mouse clicks, keystrokes, etc., so that when you see the font change, you can note what you did just before that change occurred.  Please ensure that the problem you recreate is actually the one in the description (font size changing in middle of text).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 23

8 years ago
Here's exactly when it happens to me:

1. You receive an email and click on the Reply button.
2. You start typing the reply
3. You stop typing
4. You click ANYWHERE within the Reply screen with the mouse (part of your reply, the subject line, etc.)
5. You then click back at the point where you left off typing and start typing again and the font changes to the default Thunderbird font.

If you click the backspace button and start typing again it returns to your font.

Comment 24

8 years ago
(In reply to comment #23)
> Here's exactly when it happens to me:
> [steps deleted]

This is the problem reported in Bug 273622, which was DUP'd to Bug 203810.  I'm looking for the steps to re-create the "Actual results" noted in the description, which is that the font size changes while typing the text itself.

It may be that even the reporter was performing the actions described in Comment #23; if so, then this bug should be DUP'd to bug 203810 (if the correction for Bug 203810 will fix the problem described in Bug 273622).

Comment 25

8 years ago
There are no steps to recreate the actual results;  it happens at random, unpredictable, but all too frequent times.  

AND the previous comments about this bug relating to font SIZE changing and other bugs being about font TYPE changing are exactly right.  They may be related in some way, but they are two different manifestations.

Comment 26

8 years ago
I know this is not going to make many (if any) of you happy, but I received an email from the person who reported this problem, and he described the "steps to reproduce" the problem -- and they were the same ones that Bill described in Comment #23.  He agreed that:
1) His [original] "Steps to reproduce" omitted the act of repositioning the cursor; and,
2) He agrees that the description in Bug 273622 describes the problem he wants fixed.
[that was the exact text, except I modified the above to read "His" and "He" instead of "You"]

For those, like fm_mozbugs, that have a different problem (i.e., random text size changes or random font size changes), I can only suggest you search Bugzilla for a bug that accurately describes your symptoms, READ the bug report's comments to ensure it will address your problem, then vote for that bug. 

If you cannot find a bug that matches your symptoms, file a new bug report.  Be aware that unless your problem can be re-created by others in a consistent manner, it will be impossible for a developer to identify where and what the problem is -- and fix it.  This is why the STR (Steps to Reproduce) are important.

Finally, I know there are more bugs in the HTML editor; if we can get at least ONE well-defined problem (like Bug 273622) fixed, we'll be better off, and it will help the developers to then focus on the remaining problems.

DUPing to Bug 203810.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 203810
You need to log in before you can comment on or make changes to this bug.