Inadequate Interface and Controls for Managing Profiles. Issues when drive letters change

RESOLVED DUPLICATE of bug 382080

Status

Thunderbird
Migration
RESOLVED DUPLICATE of bug 382080
8 years ago
8 years ago

People

(Reporter: Matt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

I was using a beta version of thunderbird 3 on drive c: and installed a new operating system on drive d:,  which gets remapped to drive c: and the old drive to drive d: etc.  I installed thunderbird 3 on the new drive and I then wanted to import the old profile.  Oddly enough there is no way to do it directly from the main thunderbird program.  You actually can not manage your profile unless you start thunderbird on the command line with some arcane Profile text argument.  Such a concept is foreign to windows.  If it has to be a separate program,   then one should have an install and icon for launching the 'Profile Manager'.   I see no reason to make this separate however.

What's worse is that it proved to be impossible to edit an existing profile to read my existing saved mail,  despite pointing the folder options to the new location with my new drive letters.  (My driver letters changed upon installing the new operating system.)  There is still some internal setting that chooses the location of the folder that is actually read and this was stuck on the old drive letter.  Eventually  I had to copy the profile directory contents to a new location and create a new profile that pointed to the copy before it magically started reading my old mail.   Thus this fancy new supposedly easy to use mail client can not really import mail from it's own format under certain situations and it certainly makes it very difficult for an unsophisticated user.

Reproducible: Always

Steps to Reproduce:
1. Install windows on a different hard drive from c:
2. Install thunderbird 3
3. Try to import your old profile and gain access to old archived e-mail.  Good Luck!
Actual Results:  
You spend hours scratching your head and wondering why you are that stupid,  while you can't seem to get your old mail files into your inbox and local folder archives.

Expected Results:  
A simple menu selection that allows you to import a profile from anywhere on any accessible hard drive and which allows drive letters to be remapped appropriately. I believe the profile manager needs to expose more system settings, in particular folder options to the user than it currently does.  

I think this fix should be easy to accomplish and would make life quite a bit easier,  when upgrading and importing mail folders.
(In reply to comment #0)
> Such a concept is foreign to windows.

"xxx.exe -A bbb" like program invocation is standard of MS Win. "Shortcut" is for this kind of program invocation, and is displayed as icon, and double-click of icon invokes program. 

> If it has to be a separate program, then one should have an install and icon for launching the 'Profile Manager'. I see no reason to make this separate however.

As developers of browser/brand managers of browser eager to hide profile manager, no shortcut for 'Profile Manager'(.exe -ProfileManager or .exe -P) is createg upon installation. Currently, Tb creates "xxx.exe", "xxx.exe -safe-mode" only, as standard installer does so.
I guess that it's mainly to avoid user's confusion by casual profile creation/deletion/renaming, and unwanted problems on user and unwanted/useless bug open due to casual profile creation.  

> Eventually  I had to copy the profile directory contents to a
> new location and create a new profile that pointed to the copy before it
> magically started reading my old mail.

Profile directory can be placed anywere. 
  Create new profile, and "Choose Folder..."
  ("new profile" is required, because profiles.ini location can't be changed)
There is no need to import(copy) profile directory to new C: drive in your case.

> Actual Results:  
> You spend hours scratching your head and wondering why you are that stupid, ...

Mozilla/Mozilla App Suite had good Help Document in package, and Seamonkey inherits it. But Fx(and Tb) had stopped to provide packaged Help Document.
As profile concept is simple, and as profile definition work/mail directory setting work itself is simple and easy as you know, I think good documentation(manual for user) will help you very much.
Fx started to provide Web documents although it's still not sufficient. Web documents for Tb is still poor, and there is no way to read them by Tb only.
(Reporter)

Comment 2

8 years ago
If there is a danger somehow of casual profile creation,  then by all means have a separate mode for doing so as you do now,  but at least provide a .bat file or some other shortcut that is installed into the thunderbird menu.  the mailProfile.bat file I created for example has this single line:
"C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"  -ProfileManager

There is a way to hide the cmd.exe window as well if so desired.

The danger of 'profile creation'  might not be as bad if
the Profile Manager weren't so very confusing as it now stands. It is confusing because it's not obvious that you always must create a new profile,  even if all you want to do is reuse an existing profile, within a directory somewhere on your computer.   Moreover the very real bug of changing drive letters has not been addressed.  So if you want to use an existing profile on your system,  when you create a new profile you can not choose the directory that has your old profile,  if your drive letters have been remapped.  (I believe that's a bug).  You can copy the entire directory to another folder and then choose it and then you can access your old e-mail messages, but only if you go to the trouble of going into the account settings and setting the server settings to the correct directories.

Actually this process still has some issues for me, as apparently thunderbird is not saving e-mails into a draft folder automatically.  I'm not sure if this is a separate issue.  Ultimately I believe this process should be transparent to the user and automated via some simple menu dialogs.  On windows many users are rather unsophisticated and most wouldn't even know how to copy a folder and probably wouldn't be able to find the profile directory and e-mail message directories on their hard drive.

I spent some time looking for an import profile command in one of the menus,  but never found it,  nor am I sure that this functionality is properly understood.  This is because there are two issues,  importing the profile and then accessing old mail folders.  Both of these operations should be menu commands somewhere within thunderbird  IMHO.  Something like,  import profile,  and then import or reuse mail folders etc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382080
You need to log in before you can comment on or make changes to this bug.