Toolbar in compose window and addressbook is no longer unified in 3.2a1pre

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Nomis101, Assigned: mstange)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 419923 [details]
Screenshot of the problem

The appearance of the toolbar in the compose window and the addressbook looks not as it should. It looks OK in 3.1, see screenshot. I've only tested on Mac OS X.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20100104 Shredder/3.2a1pre
(Reporter)

Updated

9 years ago
Blocks: 470184
No longer blocks: 470184
(Reporter)

Comment 1

9 years ago
regression window:

20091230 trunk build --> OK
20091231 trunk build --> broken
With that range, gotta be bug 534170, but I sure don't see why.
Summary: Appearance of toolbar in compose window and addressbook is broken in 3.2a1pre → Toolbar in compose window and addressbook is no longer unified in 3.2a1pre
(Assignee)

Comment 3

9 years ago
Bug 534170 removed ".toolbar-primary { -moz-appearance: -moz-mac-unified-toolbar; }" which was overriding "toolbar, toolbox { -moz-appearance: none; }" in messengercompose.css because of higher specificity.
(Reporter)

Comment 4

9 years ago
Hm yes, its Bug 534170. If I revert it, than the trunk build is back to normal.
Blocks: 534170
(Reporter)

Comment 5

9 years ago
(In reply to comment #3)
> Bug 534170 removed ".toolbar-primary { -moz-appearance:
> -moz-mac-unified-toolbar; }" which was overriding "toolbar, toolbox {
> -moz-appearance: none; }" in messengercompose.css because of higher
> specificity.


Yes, thats it, I was able to fix it for the addressbook with

 toolbar {
-  -moz-appearance: none;
+  -moz-appearance: toolbar;
   background-color: transparent;
   background-image: none;
 }

in addressbook.css. But if I do the same for messengercompose.css, than the toolbar looks OK, but the rest looks strange.

I've also found an -moz-mac-unified-toolbar in preferences.css. Is this OK if it isn't used anymore on trunk?
(Assignee)

Comment 6

9 years ago
Created attachment 420912 [details] [diff] [review]
v1

This works on trunk, but I'm not sure if it doesn't break in combination with 1.9.2.
Attachment #420912 - Flags: review?(philringnalda)
Doesn't seem to break with 1.9.2 - any feeling about what would break if it did?
(Assignee)

Comment 8

9 years ago
The two failure cases I have in mind are
 1. a toolbar that should be unified isn't, and
 2. a toolbar that should be transparent has become dark gray (because of the
    removal of -moz-appearance: none).

If that doesn't seem to be the case in a quick test then I think we're good. :)
Comment on attachment 420912 [details] [diff] [review]
v1

Tried again, and if it breaks or even bends anything in 1.9.2, it's too subtle for my eyes to see. Thanks for fixing us up!
Attachment #420912 - Flags: review?(philringnalda) → review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/comm-central/rev/bdd17664ca99
Assignee: nobody → mstange
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.