Last Comment Bug 538189 - Touchpad/trackpoint scrolling does not work with some versions of Synaptics drivers in Thunderbird 5
: Touchpad/trackpoint scrolling does not work with some versions of Synaptics d...
Status: RESOLVED FIXED
[gs]
: regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: 5 Branch
: x86_64 Windows 7
: -- normal with 2 votes (vote)
: mozilla8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 554578 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 09:05 PST by textured
Modified: 2012-01-27 04:34 PST (History)
15 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
tweak conditions for enabling the Synaptics hack (2.75 KB, patch)
2011-08-14 22:49 PDT, Cameron McCormack (:heycam)
jmathies: review+
blizzard: approval‑mozilla‑beta+
Details | Diff | Review

Description textured 2010-01-06 09:05:41 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Working fine everywhere but Thunderbird, including the newest stable and beta versions of Firefox. Thinkpads have a dedicated scroll button.

Reproducible: Always
Comment 1 Ludovic Hirlimann [:Usul] 2010-01-09 04:37:12 PST
Does it work if you start Thunderbird in -safe-mode (http://kb.mozillazine.org/Safe_mode) ?
Comment 2 textured 2010-01-09 13:11:59 PST
nope.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-01-24 19:26:04 PST
If you change the preference ui.trackpoint_hack.enabled to 1 does it work?
Comment 4 textured 2010-01-24 19:37:28 PST
Nope. I added the string and restarted TB. No noticeable change. I tried it as an integer, boolean and 'string' and none seemed to work. I hope I did it right..
Comment 5 Wayne Mery (:wsmwk, use Needinfo for questions) 2010-02-06 05:40:36 PST
textured, did it work in v2?

anything here relevant?

bug 539672 Page scrolling with ThinkPad does not work
bug 225846 IBM Thinkpad Web Navigation buttons not fully supported in Mozilla	bug 507222 Thinkpad Trackpoint middle button mouse scroll does not scroll window up and down [Minefield]
Comment 6 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-02-06 06:02:14 PST
(In reply to comment #5)
> textured, did it work in v2?
> 
> anything here relevant?
> 
> bug 539672 Page scrolling with ThinkPad does not work
> bug 225846 IBM Thinkpad Web Navigation buttons not fully supported in Mozilla  
>  bug 507222 Thinkpad Trackpoint middle button mouse scroll does not scroll
> window up and down [Minefield]

It shouldn't be related to Bug 507222 and it's potential descendants such as Bug 539672 because those were caused by code introduced in 1.9.2
Comment 7 mark 2010-03-18 01:59:20 PDT
Hi, I have this problem on my thinkpad X31 with Win XP. Recently I upgraded my Firefox to 3.6 and the scrolling stopped working with the trackpoint. I googled and found a suggestion to upgrade the TP drivers which I did and that fixed the problem. Now I just upgraded Thunderbird to 3.0.3 and the scrolling stopped working in TB. If I set the TP to smooth scrolling in control panel, scrolling works in Thunderbird, but NOT in Firefox. With scrolling set to "normal", it works in Firefox but NOT in Thunderbird.
Comment 8 zug_treno 2010-03-25 15:55:04 PDT
*** Bug 554578 has been marked as a duplicate of this bug. ***
Comment 9 ashvin.gandhi 2010-04-21 10:17:41 PDT
Any update on this?? I've been browsing this site for a while and have yet to find a conclusive fix :-(
Comment 10 Ludovic Hirlimann [:Usul] 2010-04-22 03:04:20 PDT
does this work on firefox 3.0.x ?
Comment 11 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-06-20 19:19:59 PDT
This is definitely a bug.  Gecko 1.9.2 contains a hack in widget/src/windows to make this work but for some reason that doesn't seem to get triggered in Tbird.
Comment 12 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-06-20 19:30:33 PDT
Doh, Thunderbird 3 is 1.9.1 (I seem to have known that above.)  FWIW, Trackpoint scrolling works in Thunderbird 3.1 with the hacks I've put into the platform, so we can probably close this.
Comment 13 Sami Lappalainen / ZAS DATA 2011-07-15 01:28:39 PDT
Is this a duplicate of  605357 ?

I have a Thinkpad T61 which is very similar to X200 mentioned here.
Scrolling works fine in all Firefox versions, worked fine in Thunderbird before update to 5.0 but now is gone. :I
Comment 14 Ludovic Hirlimann [:Usul] 2011-07-21 04:56:51 PDT
(In reply to comment #13)
> Is this a duplicate of  605357 ?

Difficult to say.
Comment 15 ashvin.gandhi 2011-07-21 10:53:32 PDT
I am having this problem, too (Thinkpad x200) since the most recent update.
Comment 16 Doron Shikmoni 2011-07-26 16:27:07 PDT
I'm having the same problem (Thinkpad scroll button does not scroll in TB). Some more input about my case:

1. It started just now, when I upgraded *from* 3.1.11 into 5.0. Worked well in 3.1 (I use it a lot).

2. The special icon for the scroll button does appear when I press it. Just doesn't scroll when I move the trackpoint.
Comment 17 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-26 16:41:02 PDT
Hi Doron,

Could you test the build from https://bugzilla.mozilla.org/show_bug.cgi?id=673815#c3 and report whether or not it fixes your problem?

Thanks!
Comment 18 Sami Lappalainen / ZAS DATA 2011-07-27 01:26:12 PDT
That is for Firefox. However, I tried http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-earlybird/thunderbird-7.0a2.en-US.win32.installer.exe

on my Thinkpad T61 and it doesn't work on that. Even the 'special scrolling icon' doesn't appear. External mouse works fine for scrolling.

Scrolling on my T61 works in Firefox 5.0 and worked in Thunderbird 3.1 .
Comment 19 Doron Shikmoni 2011-07-27 02:11:57 PDT
(In reply to comment #17)
>
> Could you test the build from
> https://bugzilla.mozilla.org/show_bug.cgi?id=673815#c3 and report whether or
> not it fixes your problem?
> 

Hi - as mentioned, that one is a FF build so not my case.
However I just noticed the ui.trackpoint_hack.enabled thingie, twas default -1, I set it to 1 and it Works For Me now -- trackpont scrolls nicely.

Thanks!
Doron
Comment 20 ashvin.gandhi 2011-07-27 10:22:35 PDT
Where can I find and modify ui.trackpoint_hack.enabled?  Thanks!
Comment 21 Doron Shikmoni 2011-07-27 15:13:23 PDT
(In reply to comment #20)
> Where can I find and modify ui.trackpoint_hack.enabled?  Thanks!

Tools -> Options -> Advanced -> Config Editor
Find it using the filter, then set it to 1. Restart TB.
Comment 22 ashvin.gandhi 2011-07-27 15:29:00 PDT
Thank you, Doron.  I tried this and it, unfortunately, does NOT solve the problem for me :(.
Comment 23 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-27 15:41:35 PDT
Cameron, see comment 22.
Comment 24 Cameron McCormack (:heycam) 2011-07-27 15:57:37 PDT
I will test on my Thinkpad when I get back into the office next week.
Comment 25 Steve Leibson 2011-07-28 19:27:48 PDT
This fix worked for me on my Lenovo T61 running Win 7 and Thunderbird 5.0.



(In reply to comment #21)
> (In reply to comment #20)
> Where can I find and modify
> ui.trackpoint_hack.enabled?  Thanks!

Tools -> Options -> Advanced -> Config
> Editor
Find it using the filter, then set it to 1. Restart TB.
Comment 26 Cameron McCormack (:heycam) 2011-08-01 19:09:53 PDT
For those of you who find setting the pref fixes the scrolling problem, I suspect the root cause is bug 673815, and once the Nightly Thunderbird build has the fix for this (in a day or two) it would be good to know if that does indeed resolve your problem without having to have the pref set.

Ashvin, in a couple of days can you also try a Thunderbird nightly build?
Comment 27 ashvin.gandhi 2011-08-01 19:43:45 PDT
Cameron, I'm not quite sure what a "nightly build" is, let alone how to try it.
Comment 28 Cameron McCormack (:heycam) 2011-08-01 20:14:44 PDT
Ashvin, no problem.  I will post a link to a Thunderbird download you can try once it is available.  (A nightly build is one that is built from the very latest code, once per day (usually in the middle of the night).)
Comment 29 Sami Lappalainen / ZAS DATA 2011-08-02 00:22:23 PDT
ui.trackpoint_hack.enabled fix worked for me too on my Lenovo T61 running Win 7 and Thunderbird 5.0.

I can try the nightly as well if you would care to post the link.
Comment 30 Cameron McCormack (:heycam) 2011-08-02 17:20:03 PDT
Here is the latest Windows nightly build of Thunderbird, in which the fix I think should resolve the scrolling problems exists:

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/thunderbird-8.0a1.en-US.win32.zip

Since there is always a slight risk of running a nightly build corrupting your profile, I suggest doing the following:

  1. Open your current Thunderbird.
  2. Tell it to work offline (File > Offline > Work Offline, or some similar
     menu item).
  3. In the menu, choose Help > Troubleshooting information, and click the
     button that opens your profile directory.
  4. Copy the selected profile directory somewhere to back it up.
  5. Close Thunderbird.
  6. Download the zip file above and extract it.
  7. Run the thunderbird.exe from the extracted folder.
  8. Check to see if touchpad scrolling is working, and report back here in
     the bug.
  9. Close that nightly Thunderbird.
 10. Delete the downloaded nightly Thunderbird folder.
 11. Open your original Thunderbird, just to verify that nothing was broken
     by the testing.
 12. Tell it to work online again.

You may want to keep your profile directory backup around for a couple of weeks just in case.  Let me know if any of the above is unclear.
Comment 31 Sami Lappalainen / ZAS DATA 2011-08-03 00:34:32 PDT
With the hack leaved enabled the scrolling works on the trackpoint.
If I disable the hack (to default -1, ie. vanilla condition) it doesn't work.
External mouse scroll wheel works all the time.

That is, no change to trackpoint scrolling issue from 5.0 on this nightly. :I
Comment 32 Cameron McCormack (:heycam) 2011-08-08 16:10:44 PDT
Thanks for checking Sami.  Are you able to tell me what version of the UltraNav or Synaptics driver you are using on your T61?
Comment 33 Sami Lappalainen / ZAS DATA 2011-08-09 01:37:02 PDT
You're welcome. Thinkpad Ultranav Pointing Device Properties say:

Synaptics 22.4.2010
Driver version: 15.0.18.0
Signed by MS Windows Hardware Compatibility Publisher
Comment 34 Cameron McCormack (:heycam) 2011-08-09 20:24:55 PDT
I installed that version of the Ultranav driver, and verified that scrolling with the trackpoint (or the edges of the trackpad) does not work with nightly Thunderbirds, regardless of the trackpoint hack pref setting.

This bug was originally filed for Thunderbird 3, which probably had a different root cause for scrolling not working.  I'm going to repurpose this one for the Thunderbird 5 scrolling issue.

Given that forcing the trackpoint hack on does resolve the issue for some people, it's likely that different Synaptics driver versions are using different heuristics for scrolling.
Comment 35 Cameron McCormack (:heycam) 2011-08-10 15:35:54 PDT
I think I was wrong: testing here on a T60 with the 15.0.18.0 driver and the trackpoint hack pref set to 1 does allow scrolling to work.  With it set to -1, it isn't enabling the hack because it's a version 15 driver.  (That's the current heuristic we use.)

So the driver must detect Firefox and Thunderbird differently, since scrolling does work in Firefox with this driver version.  In fact, if I rename thunderbird.exe to firefox.exe then even without the hack scrolling works. :)
Comment 36 Cameron McCormack (:heycam) 2011-08-10 16:46:50 PDT
Without setting the pref, scrolling also doesn't work with 15.0.24.0 but does work with 15.1.19.0.  I couldn't find any Ultranav driver versions between those two.  I'll work under the assumption then that Thunderbird needs the hack for any 15.0.y.z driver.
Comment 37 Cameron McCormack (:heycam) 2011-08-14 22:49:36 PDT
Created attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

This tweaks the Synaptics scrolling hack so that it is enabled for driver version v15.1.x.  Strictly this is only needed for Thunderbird and not Firefox, but it doesn't hurt to enable it for Firefox too.

It also changes the registry lookup functions so that it checks both the 64-bit and 32-bit views of the registry for trackpad driver version numbers.  Otherwise, on 64-bit Windows, with a 32-bit Thunderbird and a 64-bit trackpad driver, it will not find the right registry keys.
Comment 38 Cameron McCormack (:heycam) 2011-08-14 22:52:33 PDT
Enabled for v15.0.x, I meant to say.
Comment 39 Cameron McCormack (:heycam) 2011-08-15 14:21:13 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/42c54c7cb4a3
Comment 40 Cameron McCormack (:heycam) 2011-08-15 14:25:12 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

Requesting approval for Aurora so this can land for Thunderbird 7 (hopefully I'm not too late for that).  This may fix scrolling for some Thinkpad Firefox users if they have the right combination of 32-bit and 64-bit drivers/OS/app, too, but I haven't had any confirmed reports that the bit-ness is the cause of the remaining Synaptics scrolling issues on Thinkpads.

If it is approved, I may not be awake before the merge happens to push it.
Comment 41 Cameron McCormack (:heycam) 2011-08-15 23:54:26 PDT
Probably I'm overoptimistic about the timeframe here.  If it doesn't land for Aurora in this cycle, can it be considered in the next Beta triage meeting for approval there in the next cycle?  Thanks.
Comment 42 Asa Dotzler [:asa] 2011-08-16 00:40:58 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

Aurora [7] window has closed. Moving approval request to Beta.
Comment 43 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-16 04:02:36 PDT
http://hg.mozilla.org/mozilla-central/rev/42c54c7cb4a3

Asa, did you mean to set approval-beta+ instead of approval-beta?
Comment 44 Cameron McCormack (:heycam) 2011-08-16 15:26:00 PDT
Asa ^
Comment 45 Asa Dotzler [:asa] 2011-08-16 15:28:29 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

Oops, meant to move the nomination, not bless it. Sorry 'bout that.
Comment 46 christian 2011-08-22 14:25:34 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

We aren't going to approve for Beta at this time. If this is a major TB and the fix has been verified please renominate and we'll look at it again.
Comment 47 David :Bienvenu 2011-08-23 07:30:02 PDT
(In reply to Christian Legnitto [:LegNeato] from comment #46)
> Comment on attachment 553112 [details] [diff] [review]
> tweak conditions for enabling the Synaptics hack
> 
> We aren't going to approve for Beta at this time. If this is a major TB and
> the fix has been verified please renominate and we'll look at it again.

Has anyone verified the fix? TB would like to have this fix (it sucks to have scrolling broken), but none of us have Thinkpads, afaik.
Comment 48 David :Bienvenu 2011-08-23 07:52:52 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

I have some verification from a QA contributor that this works in 9.0a1 and not in 6.0 on a Thinkpad, so I'll renominate. Thinkpads are much more common out in the real world than they are in Mozilla.
Comment 49 Wayne Mery (:wsmwk, use Needinfo for questions) 2011-08-23 09:59:41 PDT
I put the number of reports of this on getsatisfaction at 30-40 users. That is a significant number of users when ranked against other problems reports.

searching only on trackpoint: http://getsatisfaction.com/mozilla_messaging/admin/topics?sort=&direction=&raw_query=trackpoint+&participating_users=&created_at_start=09%2F21%2F2007&created_at_end=08%2F23%2F2011&user_defined_code=&style=&status=&emotion=&product=&commit=Apply

(Thinkpads rule)
Comment 50 Christopher Blizzard (:blizzard) 2011-08-29 14:31:28 PDT
Comment on attachment 553112 [details] [diff] [review]
tweak conditions for enabling the Synaptics hack

Approved for Beta (Update 7).  Please land as soon as possible.
Comment 51 Cameron McCormack (:heycam) 2011-08-29 14:55:57 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/1d02edaa92bc
Comment 52 David :Bienvenu 2011-08-29 16:00:12 PDT
Thx, Cameron, on behalf of Thunderbird users.
Comment 53 ashvin.gandhi 2011-09-07 19:41:39 PDT
I just got the most recent update.  Still doesn't work.  It sounds like someone might have come up with a solution (I assume that is what Attachment #5553112 is); however, I'm not quite sure how to implement this fix.  Does anyone know?
Comment 54 Cameron McCormack (:heycam) 2011-09-08 04:13:37 PDT
Ashvin, are you trying the current Thunderbird release the Beta?  The fix is in Beta, but it won't be in the release until version 7 comes out in three weeks.
Comment 55 ashvin.gandhi 2011-10-31 23:08:22 PDT
I have tried the new Thunderbird 7 version.  It still does not work :-(.
Comment 56 Matthew Atkinson 2011-12-09 11:48:37 PST
I'm using Thunderbird 9 Beta on Windows Vista on a Thinkpad R61i, and this is still broken. I'm wondering why it's marked as fixed? 

I've tried the Config hack mentioned above, and this makes no difference,
Comment 57 Matthew Atkinson 2012-01-27 04:34:18 PST
I found the solution, though I don't know why. 

In C:\Program Files\Apoint2K there is a file called tp4table.dat. Put these lines into it:-

; Mozilla Thunderbird
*,*,thunderbird.exe,*,*,MozillaWindowClass,WheelVkey,0,9

And thunderbird will work. I put it just below the existing line for Firefox. 

I don't know why this works, but it does.

Note You need to log in before you can comment on or make changes to this bug.