Note: There are a few cases of duplicates in user autocompletion which are being worked on.

trackpad scrolling fails in Nightly, works in Firefox 5.0

VERIFIED FIXED in Firefox 6

Status

()

Core
Widget: Win32
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Jo Hermans, Assigned: heycam)

Tracking

({regression})

Trunk
mozilla8
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(firefox6 fixed, firefox7 fixed)

Details

(Whiteboard: [inbound])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Today I noticed that the nightly version doesn't do the auto-detect anymore (forcing ui.trackpoint_hack.enabled to 1 helps), while Firefox 5.0 works correctly.

I'm using an old driver, Synaptics version 11.1.21.0, on a UltraNavPS2 device.

I think that the reason is that the call to IsObsoleteSynapticsDriver was removed (which I was relying on) and replaced with a check for the Elan Tech driver.

http://hg.mozilla.org/mozilla-central/diff/1d90c5f569a2/widget/src/windows/nsWindow.cpp

This seems to be a different issue than bug 622410.
(Reporter)

Comment 1

6 years ago
The change came from bug 640587, which is now on its way to Firefox 6.0
(Assignee)

Comment 2

6 years ago
Yeah, the call to IsObsoleteSynapticsDriver should not have been removed as part of the bug 640587 fix.
Assignee: nobody → cam
Status: NEW → ASSIGNED
(Assignee)

Comment 3

6 years ago
Jo, can you test this tryserver build that has the IsObsoleteSyntapicsDriver call restored?  Please try it without the ui.trackpoint_hack.enabled pref set.

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/cmccormack@mozilla.com-21c6e9f2c908/try-win32/firefox-8.0a1.en-US.win32.zip
(Reporter)

Comment 4

6 years ago
Yes, this solves the problem for me.
(Reporter)

Updated

6 years ago
Keywords: regression
(Assignee)

Comment 5

6 years ago
Great.  So I want to wait til I'm back in the office next week and verify I haven't broken the other scrolling hacks before requesting review.
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=538189 for similar problems in Thunderbird 5.0 and latest-earlybird 7.0a2 .
(Assignee)

Comment 7

6 years ago
Created attachment 549924 [details] [diff] [review]
Fix Synaptics touchpad scrolling hack requirement detection

Verified that this doesn't cause the Elantech hack detection to break.
Attachment #549924 - Flags: review?(jmathies)

Updated

6 years ago
Attachment #549924 - Flags: review?(jmathies) → review+
(Assignee)

Comment 8

6 years ago
Comment on attachment 549924 [details] [diff] [review]
Fix Synaptics touchpad scrolling hack requirement detection

The regression causes touchpad scrolling not to work for users on Thinkpads (and perhaps other machines with Synaptics-based touchpads) using drivers that aren't up to date.
Attachment #549924 - Flags: approval-mozilla-beta?
Attachment #549924 - Flags: approval-mozilla-aurora?
Comment on attachment 549924 [details] [diff] [review]
Fix Synaptics touchpad scrolling hack requirement detection

Approved for beta (6) and aurora (7).
Attachment #549924 - Flags: approval-mozilla-beta?
Attachment #549924 - Flags: approval-mozilla-beta+
Attachment #549924 - Flags: approval-mozilla-aurora?
Attachment #549924 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 10

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/8837999bdd8c
Whiteboard: [inbound]
(Assignee)

Comment 11

6 years ago
http://hg.mozilla.org/releases/mozilla-beta/rev/2f8c75dcbe0b
http://hg.mozilla.org/releases/mozilla-aurora/rev/ff77eadd9142
Target Milestone: --- → mozilla6
(Assignee)

Updated

6 years ago
status-firefox6: --- → fixed
status-firefox7: --- → fixed
http://hg.mozilla.org/mozilla-central/rev/8837999bdd8c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: mozilla6 → mozilla8
(Reporter)

Comment 13

6 years ago
verfied as fixed in :
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110803 Firefox/8.0a1
Mozilla/5.0 (Windows NT 5.1; rv:7.0a2) Gecko/20110803 Firefox/7.0a2

there's no update for 6.0 beta available yet, so that couldn't be verified

Comment 14

6 years ago
 Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0 - beta 5

Jo, can you also please check on the latest beta and modify the status if everything is in order?

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/6.0b5-candidates/
(Reporter)

Comment 15

6 years ago
Yes, that works.

Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

The User-Agent doesn't tell me the version of course, but browser.startup.homepage_override.buildID was set to 20110804030150
Status: RESOLVED → VERIFIED
(Assignee)

Comment 16

6 years ago
Thanks for verifying, Jo!
(Assignee)

Updated

6 years ago
Duplicate of this bug: 677354
You need to log in before you can comment on or make changes to this bug.