Remove ALL modal dialog boxes from MacOSX version of Thunderbird, use Growl instead

RESOLVED WONTFIX

Status

Thunderbird
General
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: Graham Leggett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 GTB6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

After installing thunderbird 3.0, thunderbird goes into what seems to be an very long loop, "compacting folders" over and over and over again on a large IMAP mailbox with many large IMAP folders.

Every time thunderbird hits a folder that used to exist but no longer does, thunderbird pops up a modal dialog box complaining that the mailbox does not exist.

Thunderbird refuses point blank to do anything further until the user stops what they are doing, switches to thunderbird, clicks OK on the modal dialog box, and then context switches back to what they were doing, over and over and over and over and over again.

On a MacOSX system where Growl is present (and apparently supported by thunderbird), there is absolutely no reason whatsoever why thunderbird should *ever* use a modal dialog box for any kind of notification.

Forcing the end user to click OK constantly on pointless and meaningless messages that the end user can do nothing about drives end users insane.

Please please please stop with the modal dialog boxes.


Reproducible: Always

Steps to Reproduce:
xxx
(Reporter)

Comment 1

8 years ago
And please please can you get thunderbird not NOT steal focus every time a pointless modal dialog box pops up!

I completely and utterly don't care what the dialog box has to say, it is of no importance whatsoever. And yet my train of thought is constantly broken as the focus is stolen, and I am forced to context switch to acknowledge a pointless dialog box.
Whiteboard: dupme
Duplicate of this bug: 564751

Updated

7 years ago
Whiteboard: dupme → dupeme

Comment 3

6 years ago
I agree with Graham. Thunderbird complains with useless modal alerts and breaks my thinking for 10 years now. But the team doesn't want to fix these 4 or 5 alerts or to offer a functional alternative. They prefer to see us suffer and have our brain destroyed by these useless complains. This bugzilla and the Internet is full of requests about this problem. After all these years, it's obvious these modal screams are a choice. As it really deserves Thunderbird, I start to ask myself if it is not an underway to help MS and OE.

Even the prompts.tab_modal.enabled is not available ion my Ubuntu thunderbird 10. There's no addon and when we come at 10 or 20 to ask in a ticket, everything we have is only a poor code source patch we cannot use in a repository version.

Comment 4

6 years ago
Yes, modal dialog boxes (especially with no "Don't show this again" for this type of problem are obsolete. If not using growl, an OS/independent technique might display a non-modal notification pane instead. This has become popular for web browsers that used to suffer from similar problems with popup dialogs for security warnings.

Comment 5

6 years ago
Sorry, Growl support has been removed from the current versions.

Mass bug change. Please reopen if you disagree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 792793
Resolution: --- → WONTFIX

Updated

4 years ago
Whiteboard: dupeme
Is there actually someone somewhere who thinks that modal dialogs are a good idea or even remotely acceptable UI practice?  The use of modal dialogs is amazingly frustrating.  They're completely inappropriate massive time wasting stupidity in almost every case.

There is one class of usage where they are appropriate: when the user has a real choice to make between two or more possible actions that block any further background operation.  I can't think of an example other than perhaps "are you sure you want execute "rm -r *"."

Please, please, please remove all the modal dialogs.  I had always assumed it was just lazy, obsolete coding that nobody bothered to fix as most of the work- and function-interrupting dialogs are utterly useless and might as well read simply "for reasons you couldn't possibly care about, Thunderbird is wasting time doing nothing until you click OK, OK?"

Comment 7

4 years ago
I agree, and this same complaint (but for all systems, not just Mac) is what I tried to do when I wrote bug 288896.  All these error messages ought to be Activity Manager messages rather than dialogs at all.  But Bugzilla (or maybe it's the community using it) doesn't seem to be able to conceive that modal dialogs *as a class* are a problem that needs to go away, so my bug got narrowed to one instance of the problem, and yours got WONTFIXed.
You need to log in before you can comment on or make changes to this bug.