Make L10n nightly updates work

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Build Config
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

SeaMonkey 2.0 Branch
seamonkey2.1a1
Dependency tree / graph

Firefox Tracking Flags

(status1.9.2 .2-fixed)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Assignee)

Description

8 years ago
At least on trunk, I'd like to get L10n nightly updates working, which I needed to turn off after bug 539780 / bug 537329 work because we have a slight bug in our locales/Makefile which I need to fix first.
(Assignee)

Comment 1

8 years ago
Created attachment 421839 [details] [diff] [review]
[comm-central] switch from "build_id" to "buildid" in "make ident"

This fixes our "make ident" to match what's expected and used for L10n nightly builds: http://hg.mozilla.org/build/buildbotcustom/file/b616aa1ece20/process/factory.py#l1808 et al. expect "buildid" and the Firefox version in http://hg.mozilla.org/mozilla-central/file/2a1ef305a435/browser/locales/Makefile.in#l289 (same for the mobile version) deliver it like that, but back when I added it on our side, this was not 100% set in stone yet and before trying to enable L10n nightly updates, we only used the two other properties defined there, and not this one yet.
Attachment #421839 - Flags: review?(bugspam.Callek)
Attachment #421839 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 2

8 years ago
Pushed as http://hg.mozilla.org/comm-central/rev/75bcb1a6fc57 - keeping the bug open until I actually turn on nightly updates and see all steps succeed.
(Assignee)

Comment 3

8 years ago
Turned L10n nightly updates back on again for trunk SeaMonkey with http://hg.mozilla.org/build/buildbot-configs/rev/3ee21afaae2b - if builds with this are green with tomorrow's nightlies, this bug can be considered fixed.
(Assignee)

Comment 4

8 years ago
sh -c make generate-snippet-es-AR
 in dir /builds/slave/comm-central-trunk-linux-l10n-nightly/build/comm-central-trunk/suite/locales (timeout 1200 secs)

make: *** No rule to make target `generate-snippet-es-AR'.  Stop.


That means there is more work to be done, I need to look into that.
(Assignee)

Updated

8 years ago
Depends on: 496196, 449828
(Assignee)

Comment 5

8 years ago
Created attachment 422087 [details] [diff] [review]
[comm-central] add generate-snippet-% target

This additional patch applies attachment 383917 [details] [diff] [review] to SeaMonkey (the additional make call has later been moved into buildbot) but actually by copying http://hg.mozilla.org/comm-central/file/180c22a0e1b1/mail/locales/Makefile.in#l344 as they have the $(MOZILLA_SRCDIR) reference we need as well ;-)
Attachment #422087 - Flags: review?(bugspam.Callek)
Attachment #422087 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 6

8 years ago
Hrm, http://hg.mozilla.org/mozilla-central/file/c63b24afe2c0/tools/update-packaging/generatesnippet.py#l119 makes an assumption that doesn't hold true for us, as we're uploading to a *-comm-central-trunk-l10n  directory and not *-comm-central-l10n. gozer cheated that for Thunderbird and just changed the upload directory so that it isn't "the same as en-US but with -l10n appended" any more, but not sure if that solution is ideal.

gozer, armenzg, what do you think?

Comment 7

8 years ago
(In reply to comment #6)
> Hrm,
> http://hg.mozilla.org/mozilla-central/file/c63b24afe2c0/tools/update-packaging/generatesnippet.py#l119
> makes an assumption that doesn't hold true for us, as we're uploading to a
> *-comm-central-trunk-l10n  directory and not *-comm-central-l10n. gozer cheated
> that for Thunderbird and just changed the upload directory so that it isn't
> "the same as en-US but with -l10n appended" any more, but not sure if that
> solution is ideal.
> 
> gozer, armenzg, what do you think?
>
I would say to add a new option called "--branch" and use that instead when used.
(Assignee)

Comment 8

8 years ago
Created attachment 422228 [details] [diff] [review]
[mozilla-central] make generatesnippet.py accept a branch argument

I'm not very good at python, but I hope I did get this one right - Armen, is that patch doing things as you expected?
Attachment #422228 - Flags: review?(armenzg)
(Assignee)

Comment 9

8 years ago
Created attachment 422229 [details] [diff] [review]
[comm-central] add branch argument to generate-snippet-% target
Attachment #422229 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

8 years ago
Attachment #422229 - Attachment description: add branch argument to ge → add branch argument to generate-snippet-% target
(Assignee)

Comment 10

8 years ago
Created attachment 422233 [details] [diff] [review]
[buildbotcustom] set env var for branch

This patch for buildbotcustom makes us set that branch env var - it's resulting in no difference for  Firefox etc. because branch equals the repo name there - and it doesn't have any effect as long as the Makefile doesn't hand it over to the script.
Attachment #422233 - Flags: review?(armenzg)
(Assignee)

Updated

8 years ago
Attachment #422229 - Attachment description: add branch argument to generate-snippet-% target → [comm-central] add branch argument to generate-snippet-% target
(Assignee)

Updated

8 years ago
Attachment #422087 - Attachment description: add generate-snippet-% target → [comm-central] add generate-snippet-% target
(Assignee)

Updated

8 years ago
Attachment #421839 - Attachment description: switch from "build_id" to "buildid" in "make ident" → [comm-central] switch from "build_id" to "buildid" in "make ident"
(Assignee)

Updated

8 years ago
Attachment #422228 - Attachment description: make generatesnippet.py accept a branch argument → [mozilla-central] make generatesnippet.py accept a branch argument

Comment 11

8 years ago
Comment on attachment 422228 [details] [diff] [review]
[mozilla-central] make generatesnippet.py accept a branch argument

Kairo it looks good.
Did it work as expected?

When landing could you land it first on mozilla-central to see that we don't cause any unexpected regression.
Attachment #422228 - Flags: review?(armenzg) → review+

Updated

8 years ago
Attachment #422233 - Flags: review?(armenzg) → review+
(Assignee)

Comment 12

8 years ago
(In reply to comment #11)
> (From update of attachment 422228 [details] [diff] [review])
> Kairo it looks good.
> Did it work as expected?

It did in local tests with and without the --branch argument in the suite target (i.e. without it did still produce the old, wrong-for-us path and with it I did get the correct one.

> When landing could you land it first on mozilla-central to see that we don't
> cause any unexpected regression.

That's my plan, yes.
Comment on attachment 422229 [details] [diff] [review]
[comm-central] add branch argument to generate-snippet-% target

r+ assuming generatesnippet.py should fail out if FILE_BRANCH is not defined in environ prior to this running.

Automation in other patch does indeed ensure it should be in environ [in that case].
Attachment #422229 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 14

8 years ago
Comment on attachment 422228 [details] [diff] [review]
[mozilla-central] make generatesnippet.py accept a branch argument

Pushed as http://hg.mozilla.org/mozilla-central/rev/96557e1413a1 - waiting for FF to cycle before checkin in any other parts
(Assignee)

Comment 15

8 years ago
Comment on attachment 422233 [details] [diff] [review]
[buildbotcustom] set env var for branch

Pushed as http://hg.mozilla.org/build/buildbotcustom/rev/f3925d17cec9
(Assignee)

Comment 16

8 years ago
(In reply to comment #15)
> (From update of attachment 422233 [details] [diff] [review])
> Pushed as http://hg.mozilla.org/build/buildbotcustom/rev/f3925d17cec9

And backed out again as this assignment was unfortunately done before self.branchName is being defined in the __init__ call below. Need to figure out what way to go best from here.
(Assignee)

Comment 17

8 years ago
Created attachment 422572 [details] [diff] [review]
[buildbotcustom] set env var for branch, v2

This new version of the buildbotcustom patch is currently even running on the SeaMonkey master and has proven to correctly set the env var (even though it doesn't actually make things work yet as the comm-central patch hasn't landed yet).
Attachment #422233 - Attachment is obsolete: true
Attachment #422572 - Flags: review?(armenzg)
(Assignee)

Comment 18

8 years ago
Created attachment 422584 [details] [diff] [review]
[buildbotcustom] set env var for branch, v2

Oops, I attached the wrong patch, this is the right one.
Attachment #422572 - Attachment is obsolete: true
Attachment #422584 - Flags: review?(armenzg)
Attachment #422572 - Flags: review?(armenzg)
(Assignee)

Comment 19

8 years ago
Comment on attachment 422229 [details] [diff] [review]
[comm-central] add branch argument to generate-snippet-% target

Pushed as http://hg.mozilla.org/comm-central/rev/d48a8dbd8fcc - together with the local application of the buildbotcustom patch things should actually turn to work with tomorrow's nightlies.
(Assignee)

Comment 20

8 years ago
OK, things are now working fine for SeaMonkey with attachment 422584 [details] [diff] [review] applied locally on the buildmaster.
Just waiting for review and checkin of that patch before closing the bug :)

Comment 21

8 years ago
Comment on attachment 422584 [details] [diff] [review]
[buildbotcustom] set env var for branch, v2

Now it is on the right place and I was able to checkconfig positively.
Attachment #422584 - Flags: review?(armenzg) → review+
(Assignee)

Comment 22

8 years ago
Comment on attachment 422584 [details] [diff] [review]
[buildbotcustom] set env var for branch, v2

Pushed as http://hg.mozilla.org/build/buildbotcustom/rev/8bb13060629c
(Assignee)

Comment 23

8 years ago
Everything is pushed, L10n nightly updates are working for SeaMonkey users, so let's call this a success!
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: --- → seamonkey2.1a1
(Assignee)

Comment 24

8 years ago
Comment on attachment 422228 [details] [diff] [review]
[mozilla-central] make generatesnippet.py accept a branch argument

Standard8 says that Thunderbird needs this in 1.9.2 for their L10n builds.
Attachment #422228 - Flags: approval1.9.2.2?
Blocks: 538132
(In reply to comment #24)
> (From update of attachment 422228 [details] [diff] [review])
> Standard8 says that Thunderbird needs this in 1.9.2 for their L10n builds.

Just to elaborate on this, its a low-risk fix that affects l10n update packaging only. Has been on trunk for a while. We need it so we can correctly generate l10n updates for our Lanikai branch.
Comment on attachment 422228 [details] [diff] [review]
[mozilla-central] make generatesnippet.py accept a branch argument

Approved for 1.9.2.2, a=dveditz for release-drivers
Attachment #422228 - Flags: approval1.9.2.2? → approval1.9.2.2+
(In reply to comment #26)
> (From update of attachment 422228 [details] [diff] [review])
> Approved for 1.9.2.2, a=dveditz for release-drivers

Checked into 1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/05bca8fcc15c

For QA purposes, check that nightly updates for l10n builds are still working correctly.
status1.9.2: --- → .2-fixed
Blocks: 547518
Blocks: 554950
No longer blocks: 547518
You need to log in before you can comment on or make changes to this bug.