Closed Bug 542187 Opened 10 years ago Closed 10 years ago

Failed to build Firefox trunk code on OpenSolaris

Categories

(Firefox Build System :: General, defect)

x86
Solaris
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.3a2

People

(Reporter: eagle.lu, Assigned: eagle.lu)

References

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

When I built Firefox trunk code, I got following error:
ar -o libhostmar.a host_mar_create.o host_mar_extract.o host_mar_read.o
ar: bad option `o'
usage: ar -d[-vV] archive file ...
       ar -m[-abivV] [posname] archive file ...
       ar -p[-vV][-s] archive [file ...] 
       ar -q[-cuvV] [-abi] [posname] [file ...] 
       ar -r[-cuvV] [-abi] [posname] [file ...] 
       ar -t[-vV][-s] archive [file ...] 
       ar -x[-vV][-sCT] archive [file ...] 
gmake[5]: *** [libhostmar.a] Error 1
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → brian.lu
Attachment #423498 - Flags: review?(wtc)
Possible regression from bug 536440?
Product: Firefox → Core
QA Contact: build.config → build-config
Comment on attachment 423498 [details] [diff] [review]
patch

Brian,

Your patch doesn't seem to be the right fix because it
isn't fixing the root cause.  Please work with mwu and
Ted on the right fix.  Thanks.
Attachment #423498 - Flags: review?(wtc) → review-
Ted, this seems like a double quote vs. single quote issue.
It seems that the default value for HOST_AR for the non-cross-compile
case should use single quotes instead:

417     if test -z "$HOST_AR"; then
418        HOST_AR='$AR'
419     fi

This allows a platform to override just AR later in configure.in.

Alternatively, do you think each platform that overrides
AR should also be responsible for overriding HOST_AR,
as Brian Lu's patch (attachment 423498 [details] [diff] [review]) does?
(In reply to comment #4)
> Ted, this seems like a double quote vs. single quote issue.
> It seems that the default value for HOST_AR for the non-cross-compile
> case should use single quotes instead:
> 
That seems fairly reasonable to me, though I would want to convert all of the HOST_* defaults in the non-cross compile case to single quotes for consistency. Overriding HOST_* variables in this part of configure seems wrong to me since it should be configuring the target build settings, not the host. (but wince/winmo/windows does it anyway..)
Depends on: 536440
Keywords: regression
Attachment #423498 - Attachment is obsolete: true
Attachment #423754 - Flags: review?
Attachment #423754 - Flags: review? → review?(mwu)
Attachment #423754 - Flags: review?(mwu) → review?(ted.mielczarek)
The patch works for me, please also apply the patch to js/src/configure.in
Status: NEW → ASSIGNED
Attachment #423754 - Attachment is obsolete: true
Attachment #423969 - Flags: review?
Attachment #423754 - Flags: review?(ted.mielczarek)
Attachment #423969 - Flags: review? → review?(mwu)
Attachment #423969 - Flags: review?(mwu) → review?(ted.mielczarek)
Duplicate of this bug: 543372
Just a heads up - the patch for bug 538269 has just been committed, bitrotting this patch.
Comment on attachment 423969 [details] [diff] [review]
new patch contains js/src/configure.in

This looks fine.
Attachment #423969 - Flags: review?(ted.mielczarek) → review+
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #427277 - Flags: review?(kairo)
Depends on: 541248
Attachment #427277 - Flags: review?(kairo) → review+
Comment on attachment 427277 [details] [diff] [review]
comm-central part

I usually like it better if we do our own bugs for ports of buildsystrem stuff. creating bugs is cheap.
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a2
Comment on attachment 427277 [details] [diff] [review]
comm-central part

>     if test -z "$HOST_AR"; then
>-       HOST_AR="$AR"
>+       HOST_AR='$AR'

Not your fault, but while there, could you add the missing 4th space indentation?

Also, could m-c and c-c be (kept) synchronized with/without '()'?
(I have no idea which one is the better.)
(In reply to comment #16)
> Not your fault, but while there, could you add the missing 4th space
> indentation?

Bug 544172 will do that and port the missing HOST_AR_FLAGS too...
Depends on: 544172
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.