Location to save opened attachments is difficult to set

RESOLVED DUPLICATE of bug 238789

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 238789
8 years ago
4 months ago

People

(Reporter: bugzilla1, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

When I choose to open an attachment instead of saving it, it would normally go into my dowloads folder with Thunderbird 2 (~/Downloads).  On TB3, the default appears to be on the desktop (~/Desktop).  This is extremely annoying because it clutters my desktop with things I specifically didn't want to save. That's what the downloads folder is for.

I though there was no way to change this, but it turns out that there is.  In Preferences->Attachments, the box next to "Save files to" tells TB where to save files if it isn't set to ask where to save files, but it also sets where files are saved when Open is selected from the open/save attachment dialog.  This is confusing because the box to change the location is grayed out if always ask is selected.

This might actually be two problems
1. The default download location for opening files should be ~/Downloads
2. Make it more obvious how to change the download location for opened files

Reproducible: Always
Component: General → Preferences
QA Contact: general → preferences

Comment 1

8 years ago
Thunderbird Extension: Attachment Extractor
https://addons.mozilla.org/fr/thunderbird/addon/556

This extension gives more options for attachment management
Duplicate of bug 238789?

Updated

8 years ago
Blocks: 579473

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575875

Comment 4

7 years ago
Hm, actually, I think it makes more sense to reverse the dupe, since this is more general than bug 575875, which would be covered by this bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

7 years ago
Duplicate of this bug: 575875

Updated

4 months ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238789
You need to log in before you can comment on or make changes to this bug.