Opening attachments should not also save copy to desktop (as a temporary location) [Mac]

REOPENED
Unassigned

Status

--
minor
REOPENED
15 years ago
8 days ago

People

(Reporter: bugzilla, Unassigned)

Tracking

(Depends on: 1 bug)

unspecified
All
macOS
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 -
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
When I open an attachment in Thunderbird, a copy is also saved to my desktop. 
If I wanted a copy saved to desktop, I would have simply had the attachment
saved to the desktop rather than opening it.   If Thunderbird needs a folder to
save attachments to when the user opens attachments, it should be a temp folder
or equivalent rather than the user's desktop.

Comment 1

15 years ago
opening attachments causes the attachment to get saved into the temporary
directory that we get from the OS. Is the desktop set to be your temporary
directory? What happens when you open an external helper app in Firefox? We
share the same code and they should go in the same location.
(Reporter)

Comment 2

15 years ago
Not sure how to check what the Mac temporary directory is.  Any suggestions?

Comment 3

15 years ago
191385 is a similar bug marked WONTFIX, but filed for Browser.  Perhaps it 
provides some insight into the current design.  It seems to me that if a user 
wants to save a file to their desktop they'll do exactly that.  If they want 
to view a file in a helper app, the file should be opened, as transparently as 
possible, in a helper app.  This is what Mail.app does.  In Mail.app, if I 
double click on a file named filename.ext attached to an email with the 
Subject: emailsubject it opens from ~/Library/Mail/IMAP-
user@server/FOLDER.imapmbox/emailsubject.mimeattach/filename.ext.  The file is 
deleted when I quit Mail.app.
http://bugzilla.mozilla.org/show_bug.cgi?id=191385

Comment 4

15 years ago
The temporary directory for OS X is /tmp (a symlink to /private/tmp). I believe that would be the 
appropriate place for these temporary attachment files.
(Reporter)

Comment 5

15 years ago
The bug is then that Thunderbird ignores the /private/tmp temporary directory and instead saves to 
the desktop.   Any workarounds in TB Preferences or does this need to be fixed?

Comment 6

15 years ago
from the forums:

Mozilla Thunderbird downloads files to the folder specified by your Internet
Config preference. In Mac OS 10.0-10.2, this preference is available in System
Preferences > Internet > Web. In Mac OS 10.3, Apple (mis)places this preference
in Safari > Preferences... > General.

http://forums.mozillazine.org/viewtopic.php?p=501582#501582
(Reporter)

Comment 7

15 years ago
When files are downloaded in Safari, they should go to the desktop since that is a convenient place for 
the user to take action.   Attachments opened in Thunderbird only clutter the user's desktop since they 
aren't supposed to be saved, or the user would have chosen "save" rather than "open".    The Safari 
preference can be changed to put downloaded files in a temp folder, fixing the issue with attachments, 
but files downloaded from the internet that need to be installed/unzipped shouldn't go to a temp folder 
unless they will open themselves and install.

Comment 8

15 years ago
OK, so here's a stupid question. When I go to Safari > Preferences > General,
there's a setting for "Save downloaded files to:". When I select the "Other..."
choice, the Finder shows up for me to choose the directory. But /tmp is
invisible from the Finder. So how do I specify /tmp?

Updated

15 years ago
Flags: blocking-aviary1.0mac?

Comment 9

15 years ago
The problem is as the original posted stated.  The bottom line is that on the PC
version and with other mac mail programs, files that are opened with helper apps
save to a temp location, open the file, close the file, delete the temp version.

Thunderbird is saving the attachment to the desktop (or specified download dir)
and leaving it.  

Huge pain for those who get a lot of mail with attachments.

Updated

15 years ago
Flags: blocking-aviary1.0mac?

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 10

14 years ago
To add to this, if you open an attachment from a compose window, it will
correctly place the file in the temp directory and not the desktop.  I also want
to point out the fact that attachments do not have the correct system
application associations that they should.  A good way to check is by looking at
the attachment's icon when reading a message.  All the attachments usually have
a generic icon.

However, when composing / forwarding a message (inline, which brings up a
compose window), the attachments in the attachment window *do* have the correct
icons and program associations and they also open without saving a copy to the
desktop.  It seems that the code that handles attachments for the compose window
is quite different, or is reading its system variables from a different location
than the code for reading messages.

Comment 11

14 years ago
bump-bump ... confirming this behavior on Mac OS X(10.3.9)/Thunderbird 1.0.2. 
This is causing much bleeding-of-the-temples for a group of 58-74 year-old men
whom I have recently converted from Windoze to Mac.  As they receive many
attachments daily for business, They are confounded by this behavior of masses
of attachments remaining on the desktop.  Please Fix !! Thank you!

Comment 12

14 years ago
As a follow up:  Thunderbird appears to be getting it's default save-to folder
(which is what it uses for it's temp folder as well) from whatever system
variable Safari uses to save its default save-to folder as well.  If you change
the default in Safari, Thunderbird will put its files there.  So, as a temp fix,
change Safari to wherever you want Thunderbird to put its files.

Comment 13

14 years ago
*** Bug 292234 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Updated

13 years ago
Flags: blocking-thunderbird2?

Comment 14

13 years ago
First of All, I confirm this bug in version 1.5 updated (20051201)
FYI : MacOS 10.3.9 - IMAP account on Exchange Server

I have read all your comments.
I think most of the people here are missing the point.
The problem is not to get the right application to open the attachment with,
or to figure out in which folder the attachment should be placed... 
The problem is clear. Like Edward Drewery says,  when you want to just view an attachment, what should happen is : extracting this attachment as a temp file saved to a particular location (visible or not by the user), opening this local temp version, closing this local temp version, and deleting this local temp version. Periode.
That's what the users expect.
Then is it possible? is it east for programming? Does the dev team (thanks to them) have other priorities? ... anyway I vote for this bug.
Thanks

Updated

13 years ago
Keywords: helpwanted

Comment 15

13 years ago
This issue has been frustrating me for some time now. I'm very disappointed to see that this bug was first filed 2 1/2 years ago. To someone using Thunderbird for work purposes in a large corporate environment the current behaviour is incredibly frustrating.

There are many occasions when I do not want to save a copy of an attachment - just to view it. Saved copies of stuff I never wanted permenantly then clutter up my chosen save directory and I have to clean them out later. By this time I have forgotten what most of them are (if the filenames given any hint to begin with).

Thunderbird should definately save things to /tmp/ or it's platform equivalent when just double clicking/viewing an attachment. Whilst I'm not a coder by trade is this really a large change? It would make a big difference to my Thunderbird experience.

Comment 16

12 years ago
it doesn't look like any contributors have jumped in to look at this for tb2.
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Comment 17

12 years ago
BUMP!

This issue still exists in 2.x and 3.x betas/alphas.

As has been said before, in a crossplatform environment, it makes LESS sense to have this particular behavior defer to the MacOS standard internet download location, rather than using a mail-specific temporary file location. 

That said, most attachments I open by double-clicking try to save or save-as back to the same folder the attachment is downloaded to... So, while Desktop is a bad default, /tmp is also an issue, because if I save changes in an excel doc, that defaults to saving in /tmp, then I could lose all those changes when /tmp gets cleaned out. 

Still, for this single feature, having parity between linux/windows/mac is VERY important - in the same way that taking advantage of other features that are platform-specific (iCal/AddressBook/etc) is critical from a functionaliy perspective.
QA Contact: preferences

Comment 18

12 years ago
I believe there is a temp folder specifically for mail downloads which is located at ~/Library/Mail\ Downloads.  The pref for this is set in Mac Mail and the folder is cleaned by some system utils (like OnyX).  This is where files go when they are opened but not saved.

Comment 19

12 years ago
Another workaround that also appears to work is to add the "browser.helperApps.deleteTempFileOnExit" preference as described here: https://bugzilla.mozilla.org/show_bug.cgi?id=302433#c13

Here are instructions modified for TB:

1. Under Preferences, Advanced, General, and Config editor...

2. Right/Control-click anywhere in the page, and select “New” -
“Boolean” from the context menu.

3. In the dialog that pops up, type (eh, paste)
browser.helperApps.deleteTempFileOnExit for the pref name, and then choose true
for the value in the next dialog.

4. Enjoy seeing the litter cleaned up when you next quit Thunderbird

Comment 20

12 years ago
This is marvellous! Thanks for posting this solution. None of the other solutions suggested (e.g. changing the settings in Safari) worked for me on Mac OSX 10.4.11 with TB 2. Pity the setting is not publicised elsewhere, because the discussions about the bug are still raging on other forums.

Comment 21

11 years ago
A bit more solid info:

This is cross-product code, more precisely in uriloader/exthandler/nsExternalHelperAppService.cpp, first lines of nsExternalAppHandler::SetUpTempFile().

Some background is in the WONTFIX'ed bug 191385.

The bug implementing "browser.helperApps.deleteTempFileOnExit" is bug 302433.

A more recent bug 374184 regards the same thing.

Comment 22

11 years ago
(In reply to comment #19)
> Another workaround that also appears to work is to add the
> "browser.helperApps.deleteTempFileOnExit" preference as described here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=302433#c13
> 
> Here are instructions modified for TB:
> 
> 1. Under Preferences, Advanced, General, and Config editor...
> 
> 2. Right/Control-click anywhere in the page, and select “New” -
> “Boolean” from the context menu.
> 
> 3. In the dialog that pops up, type (eh, paste)
> browser.helperApps.deleteTempFileOnExit for the pref name, and then choose true
> for the value in the next dialog.
> 
> 4. Enjoy seeing the litter cleaned up when you next quit Thunderbird
> 
UNABLE TO GET ANYTHING WHEN ". Right/Control-click anywhere in the page, and select “New” -
> “Boolean” from the context menu." MAC 0SX TIGER

Comment 23

11 years ago
@John, adding browser.helperApps.deleteTempFileOnExit doesn't prevent the attachments from saving to Desktop, it only cleans up upon exiting Tunderbird completely. I rarely close Thunderbird so this is hardly anywhere near a workaround, although combined with changing Safari's default download location to a less visible place it may be enough for some.

The issue remains that the Desktop is being used as a temporary directory when it clearly shouldn't.

Comment 24

11 years ago
I fully agree with what Fabian Rodriguez points out. Moreover, there may be other reasons than merely clutter to vote for this bug, e.g. a folder action interfering with temporary storage as used by ThunderBird while handling attachment files. The difficulties I encounter with basically any handling of attachments, which all get corrupted (cf. discussions under bug 286094 ).

Reading many comments I have found a workaraund, which was roughly described by others. In the following form I hope it should be doable by anyone without resorting to hacking. Here it is:

Workaround: How to make ThunderBird use for temporary storage hidden system folder '/tmp' (circumvents problems described here https://bugzilla.mozilla.org/show_bug.cgi?id=286094#c28 and the links to bug reports and forum contributions as described there):

1) Finder: Choose menu command "Go -> Go to Folder..."
2) Type into the displayed dialog: "/tmp" and press button "Go"
3) Launch MultiVersion Safari, e.g. Safari 2.0
4) Safari: Choose menu command "Safari 2.0 -> Preferences... -> General"
5) Choose in pop-up menu for preference "Save donwlaoded files to:" option "Other..."
6) Drag the icon for folder 'tmp' as shown in the title bar of the window resulting from step 2) and drop it into the dialog window resulting from step 5)
7) As the dialog window shows now as a selection the directory 'tmp' press button "Select"
8) Quit Safari 2.0 and discard it, e.g. by deleting it from your system.

ThunderBird should now be using the system folder /tmp for temporary storage. Any files stored there will be automatically deleted by the system at some proper time and you avoid any clutter on the desktop or whatever folder you were using as a download folder. Note, as of Safari 3.x the download folder used by Safari itself is not affected. However, some other programs, e.g. browser Camino, will be affected and are now also using the /tmp folder for downloading. If this bothers you, vote for this bug 238789. Thunderbird is the culprit! BTW, I just found out you can also use browser Camino (http://caminobrowser.org/) in step 3) to 5) and 7) to 8) to get the wanted effect.

You don't even need to quit and relaunch ThunderBird while doing steps 1) to 8).

All tested using:
Leopard OS X 10.5.4
ThunderBird 2.0.0.14 (20080421)
Safari 2.0 (Multi-Safari as downloaded from http://michelf.com/projects/multi-safari/)
Camino 1.6.1 (1.8.1.14 2008051211)

af, ETH Zurich / 15.Jul.2008

Assignee: mscott → nobody

Comment 25

10 years ago
I just made the switch from Eudora to Thunderbird.  I like everything so far but this bug is ridiculous.  Very nearly a deal killer for me.   Seems like a pretty easy to bug to fix - just have TB point directly to the temp system folder itself, instead of replying on whatever safari is set to.  Is that really hard? 
 
What is more worrisome is that the bug IS very annoying in terms of efficiency -- which is the entire point of using email --  and this bug was first reported over four (4) years ago.   Makes me worry there is other stupid stuff like this.   

I would appreciate it very much if one of you coding mavens would fix this. 

Thanks!

Comment 26

10 years ago
And in Thunderbird 3 beta 1, it isn't fixed. :-(
This is basically the same underlying issue as bug 311292. It's a core issue and not only Thunderbird related.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: helpwanted
Hardware: PowerPC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 311292
(changing to dependent)
Status: RESOLVED → REOPENED
Depends on: 311292
Resolution: DUPLICATE → ---

Comment 29

4 years ago
More than ten years down the road and this annoying bug is still there. 

When is this getting fixed?

Comment 30

4 years ago
Just found this after a quick search for the behavior. Just started happening to me. OS X 10.10.5. Macbook Air Mid 2013.

Comment 31

3 years ago
10+ years ... still very annoying Would a dev please spend a few minutes on this? Just change to ~/Downloads or $TMPDIR as a rapid patch.
The biggest reason why it's a problem, is because you don't know what's downloaded files that you want to keep, and what's temp files (that should be deleted) created by Thunderbird when you opened an attachment.

On Linux it doesn't dump stuff to the ~/Downloads folder; it dumps it to the /tmp folder, and then deletes it after it's finished with it.

On Windows, I'm guessing Thunderbird does something similar.  Why is Mac the odd man out?

Comment 33

3 years ago
+1 on this - it's infuriating for the reasons given by Daniel Bruce Lynes - that I can't differentiate between what I've deliberately saved to the desktop and what is just an attachment.. After 10+ years, a fix would be so welcome!

Comment 34

3 years ago
Couldn't believe this bug is still here (coming back to mac after 5 years away).

Found this workaround, which works for me, via a duplicate bug thread:
https://bugzilla.mozilla.org/show_bug.cgi?id=311292#c177

Comment 35

3 years ago
One can have the files saved in another location other than desktop on Mac OSX.
In Thunderbird: 

Open Preferences -> Attachments Tab -> Incoming Tab -> Save Files to: ( Select where you want files to go. )

If one wishes to point to the /tmp folder: In the finder window press (shift+command+G) and explicitly input “/tmp”.

Updated

2 years ago
Duplicate of this bug: 591322

Updated

2 years ago
Duplicate of this bug: 706189

Updated

2 years ago
Duplicate of this bug: 542694

Updated

6 months ago
Depends on: 1270405
Summary: Opening attachments should not also save copy to desktop → Opening attachments should not also save copy to desktop (as a temporary location) [Mac]
according to bug 311292 comment 184, Thunderbird needs to determine it's own fate for this issue
You need to log in before you can comment on or make changes to this bug.