Closed Bug 543365 Opened 14 years ago Closed 13 years ago

Escape key should close message displayed in tab

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: JohnCroweRockville, Unassigned)

References

()

Details

(Keywords: ux-consistency, Whiteboard: [workaround comment 16])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

My earlier version of TBird closed the message read window when I hit the escape key, current one bring up a tab but does not close when the escape key is hit.  I did not find a method to map the key.

Reproducible: Always

Steps to Reproduce:
1. bring up a message in a tab to read
2. Hit escape, Esc, key
3. Hit escape key again, again, again
Actual Results:  
nothing happens

Expected Results:  
Tab closes
Confirming this as a feature request. Moving tentatively to Toolbars and Tabs component.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Message Reader UI → Toolbars and Tabs
Ever confirmed: true
OS: Windows XP → All
QA Contact: message-reader → toolbars-tabs
Hardware: x86 → All
Version: unspecified → 3.0
I have this problem too, and would very much like to see message tabs closed by pressing escape, in the same way as message windows do and always have.
I agree - this also seems more like a bug than an enhancement to me.  The behaviour of closing a window should be consistent whether it was open in a tab or its own window.  Ctrl-W does close the tab, but tapping Esc is simpler and more natural.
Whiteboard: [gs]
As mentioned in previous comments like comment 3, this can be regarded as a regression because we always offered closing open messages with ESC after reading (when they still opened in a separate window each). We have changed the default behaviour for messages to open in tabs, but there is no reason we should abolish the shortcut because of that. On the contrary, we should make it as easy and comfortable as possible for users to migrate to using tabs.
Severity: enhancement → normal
Keywords: regression
Yes, would love to see this in the product
I like the tabs, but won't use them if it means giving up the ESC key for closing emails.
There were several gs reports about this which I merged into 

http://gsfn.us/t/nr9t

which is currently tagged canonical and has 33 votes in gs.

We also have http://gsfn.us/t/1b01e (3 votes) with a sceptical comment from Mark Banner:
> I doubt we would use escape, as it is
> [1] used for other things and is
> [2] non-standard for closing tabs

ESC currently works for closing stand-alone message reading windows, and apperently it works for a lot of people who have come to appreciate that shortcut.

Looking at the counter-arguments more closely

> [1] ESC is used for other things

That doesn't mean it can't be used for closing the tab. The sharing of ESC is a standard behaviour that's works flawlessly and intuitively, e.g. in the standalone message window:
- open a msg in a new window
- click on a dropdown button of your choice, like Write, Tags, or Combined-Reply button
- first ESC will close the dropdown menu (or cancel anything else that currently has focus)
- pressing ESC again will then close the message window (same for tabs, after implementing this bug)
No magic, and no problem here. Just comfort!

[2] non-standard for closing tabs

- well, maybe, strictly speaking, but does it hurt?
- many users want this (!!!), as they have come to appreciate the comfort from TB2 (and TB3, for standalone message windows)
- some of our users love this so much they even want ESC shortcut for closing *Composition* windows/tabs (related bug 242636), and guess what, the idea dates back to 2004...
- we still keep Ctrl+W (and Ctrl+F4, Bug 511375) to be standard-conform
- ESC for closing tabs is supremely easy to use and memorize, adding ultimate speed and efficiency to this command
  - single key, avoids having to stretch your fingers to reach a double key combo, while carefully trying not to miss it
  - safe and easy target in upper-right corner of keyboard
  - intuitive (known from other programs, including Outlook, IrfanView, MetaPad,
WinMerge...; maybe not be intuitive for everyone, but it'll be most beneficial for those who need it most: keyboard users)

Conclusion: No pain, much gain!
Perhaps rather than votes for this "bug", the developers refer to the download count of the "Close tab on ESC" add-on at: https://addons.mozilla.org/en-US/thunderbird/addon/161748/

Currently 2,455.

Cheers,
Nick.
Keywords: ux-consistency
Summary: Escape key should close message read tab → Escape key should close message displayed in tab
Whiteboard: [gs] → [gs][SAmessage-parity]
So, is the expectation that Esc closes *any* tab, any tab but the initial 3-pane, just message tabs, ...?
clarkbw, please provide UX input for this request.  Given our use of "Esc" for the quick-filter, this obviously can't happen for those tab types, but it's feasible for message tabs.  I would personally lean towards wontfix for muscle memory consistency but have no strong opinion.

Note that per comment 8 there is an extension that provides this functionality.
(In reply to comment #9)
> So, is the expectation that Esc closes *any* tab, any tab but the initial
> 3-pane, just message tabs, ...?

My expectation is that Esc should close the currently open message tab, if there is one. If there is no currently open message tab, or if the currently open tab is the initial tab (the "Inbox"), it should do nothing.
(In reply to comment #10)
> clarkbw, please provide UX input for this request.  Given our use of "Esc" for
> the quick-filter, this obviously can't happen for those tab types, but it's
> feasible for message tabs.  I would personally lean towards wontfix for muscle
> memory consistency but have no strong opinion.
> 
> Note that per comment 8 there is an extension that provides this functionality.

there is/was also the example of overloading of escape key use for cancelling download operations. ref bug 579576 comment 8 and bug 579576 comment 14.

for a sense of other bugs which mention escape key - https://bugzilla.mozilla.org/buglist.cgi?chfieldto=Now&query_format=advanced&chfieldfrom=2010-1-01&short_desc=esc%20escape%20stop&short_desc_type=anywords&longdesc=esc%20escape&type0-0-0=nowords&value0-0-0=count%20counts&resolution=---&resolution=FIXED&resolution=INVALID&resolution=WONTFIX&resolution=DUPLICATE&longdesc_type=anywords&product=MailNews%20Core&product=Thunderbird
clarkbw, devs, pls consider the popularity of this feature (at least for closing message tabs), looking at the development of the download count for the "Close tab on ESC" addon:
 
(In reply to comment #8)
> download count of the "Close tab on ESC" add-on at:
> https://addons.mozilla.org/en-US/thunderbird/addon/161748/
> Currently 2,455.
Only 4 months later, the download count is up to
4,311 (almost double). Clearly, there is a trend here that should be respected.

(In reply to comment #10)
> clarkbw, please provide UX input for this request.  Given our use of "Esc" for
> the quick-filter, this obviously can't happen for those tab types,

Can someone report how the addon handles this case, if it's a tab which has a quickfilter with a word and/or criteria filter applied?

Imho, there is no real problem about using ESC for closing such tabs that have a quickfilter (if that should be default behaviour is another question):
- first ESC clears the word filter of the filter bar (as it does now)
- another ESC clears criteria filter of the filter bar (as it does now)
- another ESC clears the filter bar away (as it does now)
- another ESC closes the tab
It may not be perfect for your muscle memory (as the number of ESC required to close the window may differ), but it works anyway, as it does in other applications like IrfanView if you have any dialogues open, and people seem to like it. Think about it: It doesn't really hurt even if you just accidentally close a search window...
Otherwise, this could be a preference which is off by default.

> but it's feasible for message tabs.

And very much so. given thunderbirds waste of screen real estate, users may open hundreds of messages a day, where just hitting ESC to close them will just make our life so much easier!!!

We could even implement this for message tabs only and discuss other tabs later. My suspicion is most users want this primarily for message tabs as when messages still opened in windows, this was an existing shortcut in tb2.

> I would personally lean towards wontfix for muscle
> memory consistency but have no strong opinion.

devs, if you don't have a strong opinion, pls consider that more than 4300 users already do.

> Note that per comment 8 there is an extension that provides this
> functionality.

Yes, and don't forget the millions of users who have no idea what an extension is, let alone would they be willing or able to install one, yet they might very much appreciate a simpler way of closing read messages (other tabs might still need more consideration for the questions raised in comment 9 and comment 10).
(In reply to comment #10)
> clarkbw, please provide UX input for this request.  Given our use of "Esc" for
> the quick-filter, this obviously can't happen for those tab types, but it's
> feasible for message tabs.  I would personally lean towards wontfix for muscle
> memory consistency but have no strong opinion.

There is a slight ux-consistency with windows closing on ESC even though most HIGs defined that for popup type windows and not really for larger message reading type windows.  However closing a tab with ESC doesn't have any consistency with Firefox or other tabbing applications.  

I'm inclined to say no because I don't see a ux-consistency issue here other than both things were showing messages which isn't quite the same.  We'll also be creating new inconsistencies in other tabs which won't close when you press escape.  I would need to look into this more.

> Note that per comment 8 there is an extension that provides this functionality.

We could certainly promote this add-on so more people can find and make use of it.  I'll look into making a post in the mozilla labs messaging site.
The way I see it is that I can close a message that I'm viewing with Esc if I set the option to view mail in a new window, but I can't if I'm viewing in tabs.  From that point of view, it's inconsistent.  If the options panel that allows me to choose to view mail in tabs also had a checkbox saying "close window with Esc", then we'd have no need for addons to do this.  I'm using the addon from comment 8 and loving it.  Let the default be not to do so, but allow users to choose.

> However closing a tab with ESC doesn't have any consistency with Firefox or other tabbing applications.
Lotus Notes lets me close a tabbed email window with Esc.  Comparing to Firefox isn't quite applicable since that's not a mail program - it's a browser.  With mail you can just open the mail again to get back - the inbox is holding the original.  A browser is different because you could lose data (form data, query results, etc) by accidentally closing a tab.
I'm marking this WONTFIX as sub-module owner and per the UX feedback from clarkbw.  Please consider debate closed on the issue.

I recognize that neither clarkbw nor I are stating a visceral opposition to the keybinding.  But the threshold for adding additional complexity to the product, be it program logic or keybindings, is that there needs to be a good reason to do so, not that we would fight to the death to stop it from going in.

For those who only scroll to the bottom of the bug, don't miss out on the add-on that already provides what this bug requests!
https://addons.mozilla.org/en-US/thunderbird/addon/161748/

(And I would like to emphasize that the purpose of add-ons is not just as a means of testing potential new features for Thunderbird.  Add-ons make sense for small features and tweaks just as much as they make sense for huge ones.  Also, AMO makes it easy for people to curate sets of (potentially related) add-on collections to make it easier for other users to find extensions they might like without having to trawl the entire collection!)
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WONTFIX
I see exactly the same need for this "user interface".
The tab behaviour should and need not be the same as in firefox, because we are not talking in thunderbird as a browser but for an email client..

The usage of such an email client is completly different!
the difference is that a lot of email can be read just be seeing the small preview window and a view of the emails are a lot too big and need a full page.. 
therefore the return / double click is used to open it in full.. read it . and close it.. 
the close it does not work with the usual look and feel for keyboard users.. 
I would expect the ESC Key working here.
I've been asked by Standard8, on behalf of Karlo, to look into re-opening this bug as part of bug 669753.

I've spent a few days thinking about it, and I have come to the conclusion that the WONTFIX should remain.  (To be fair, it's really the sub-module owner's decision, but in this case I agree with him.)

I understand that there is a workflow that involved opening messages in new windows and then using escape to close them, but escape never worked to close the Compose or Address Book windows or tabs of any sort, whereas Ctrl-W works to close all of them.

And the various things that escape does lead me to not want to extend it to do more things.  (I can easily imagine a scenario where a user has hit escape to close the find-in-message box, but the computer doesn't react fast enough, so they hit it again, and then their whole tab disappears.)

There is an add-on collection at https://addons.mozilla.org/en-US/thunderbird/collections/matthew_atkinson/a/ that you might propose to add https://addons.mozilla.org/en-US/thunderbird/addon/161748/ to, since it seems like it solves a similar problem (supporting workflows from previous versions of Thunderbird).

Finally, on a more forward-looking note, as we work to merge the various window types into a single type of window containing multiple tab types, we'll likely drop support for closing message windows with the escape key, since message windows will be the same as any other window, and you'll be able to drag and drop message tabs between any Thunderbird window.  I can totally understand if that plan goes counter to the way you would like to use Thunderbird, but I believe it will be the future, so if you can make the switch to using Ctrl-W to close your messages now, you'll be much happier when it lands.  (And if it makes you feel any better, I'll be trying to cope with the reversed scroll direction in the next version of Mac OS X real soon now, and I expect that to be much harder to overcome. ;)

Thank you,
Blake.
Hello Blake

I fully understand you thoughts about this issue.. especially that esc is used in various ways and double clicking on esc would close more then expected.

For me and i guess a lot of other people it is more the way we work in an email programm. We read emails.. in most cases the preview window is not big enough.. that means.. 
1) pressing return
2) read message in the new tab
3) pressing esc to close this email and go to the next one.

If you have more then 100 email a day this one of the best ways to read through the window.
One important point is that a lot of users will work on the keyboard with a 10 finger system. CTRL+W is not possible to be used in this system.
ergonomic this does not fit and therefore the user is forced to leave this typing position with the left hand and has to type in a strange crtl-w or even have to use two hand fingers to press ctrl-w.

This is very very unnatural and is one of the points which leads to the frustration in respect that in thunderbird the esc key is not longer working to close the tabs.. 

furthermore a tab is not the same as in a browser as it is only the content of one email (and it should be seen in such a way only) which can be opened again and again without any problems

I guess the idea of a tab in a email program is a bit unclear and this is more an adoption from a browser rather then a new idea.

My argument and my intention was to have the usability and ergonomics in the backgroud and i still see this as a gap / bug.
If you're trying to maximize the efficiency of reading multiple messages in tabs or windows, then I'd suggest adding the "Next" and "Previous" toolbar buttons to the main toolbar. Clicking those will let you move between unread messages until you've read them all. You can also hit "n" and "p" on the keyboard to do the same thing (or "f" and "b" for forward/back to move between all messages, not just unread ones).
Hello

what is the problem with user expectations and user behaviour i ask myself.
workaround is just patchwork.

Ergonomic is a science and not a discussion in the corridor
and should be one of the main driver in development a tool like an email reader.
You should at least take into the consideration that you might have 3 user groups in respect of ergonomics (the mouse users / the two finger typing user / the 10 finger (never want to leave this position of the finger on the keyboard - user). Every group has a different way to use a tool like an email programm.
Therefore the request are sometimes different.

I really cannot understand your recommendation (adding icon, using backword, forward)

I never would like to go through my emails with forward/backward.
First i see 100 new emails in the morning and i will pick up these i would like to read first.. 
pressing "return".. reading .. pressing "ESC"

This works fine in outlook!
Even in facebook communication windows can be closed with esc.
(In reply to comment #26)
> You can also hit "n" and "p" on the
> keyboard to do the same thing (or "f" and "b" for forward/back to move
> between all messages, not just unread ones).

Changing habits can be very hard - things have changed in Fx that I didn't like, but I eventually adapted. So I can sympathize with wanting to be able to use escape in Thunderbird. 

However, with regard to message reading workflow there are multiple, great alternatives, like the the keyboard items of comment 26 - I've used them for years, and frankly I'd want to avoid multiple closings of windows or tabs during navigation which adds steps and consumes time. Suggest you check out the choices in the "Go" menu and the addons mentioned below, and try an alternative process for a month - http://www.lifehack.org/articles/lifestyle/breaking-bad-habits-in-28-days.html (ignore the word "bad" in this context).

I was curious, so I searched to see what message navigation addons might be available. I was surprised to find almost none (at least easily found), which to me indicates that Thunderbird's native message navigation via keyboard must be pretty good. Anyway, I was pleased at what I found, and they mostly work even in Thunderbird trunk. I especially liked Maximize Message Pane - it has tons of choices.
- https://addons.mozilla.org/en-US/thunderbird/addon/maximize-message-pane/
-- Doc: http://hogi.sakura.ne.jp/en/mmp/mmp.rhtml
- https://addons.mozilla.org/en-US/thunderbird/addon/navigation-shortcuts/
- https://addons.mozilla.org/en-US/thunderbird/addon/realprevnextbuttons/
- https://addons.mozilla.org/en-US/thunderbird/addon/nostalgy/ had L to hide folder pane and something else which I didn't take time to find
Status: RESOLVED → VERIFIED
Hello

i really appreciate your work in finding out addons and how to change habits..
and next you might answer with something like rtfm i guess.
To keep things not emotional, i will try to calm down and answer.

Your approach is..why change a programm in the way the user wants to have it
if it is possible to force them how you wanted them to use it.
Using addons is not a streamlined ergonomic approach and rather a bad, and a very bad patchwork.
I personally have setup the addon for esc. That is not the problem!

The problem is that in respect of a proper usability approach in respect of users (!, yes they exist) this is and remains a bug.

This discussion is ab out ergonomics and i wonder why did you / or you as a team ignore the fact that this is nothing of a personal perference nor an addon patchwork, but needs a proper concept and framework.

As i mentioned in my answer above you should split the users in 3 groups with different behaviour (maybe 4 groups if you add programmers who does not use email programms and just discuss)
these groups need a different ergonomic approach, which might overlapp in most cases.
Proposing a shortcut like ctrl+w which could not be typed in a proper 10 finger system way is definitly never a good solution. all other keystrokes are more or less unknown or in an old-fashioned emacs style.

smart complexity it simplicity & nice usage
The Esc key should close a message (exactly like Ctrl-W)

Escape key does not work. 

Please stop wasting everyone's time trying to explain why it doesn't work and just fix it already.

Massive waste of time and energy for a 5 minute fix. Seriously guys.
(In reply to acturbo from comment #30)
> The Esc key should close a message (exactly like Ctrl-W)
> 
> Please stop wasting everyone's time trying to explain why it doesn't work
> and just fix it already.
> 
> Massive waste of time and energy for a 5 minute fix. Seriously guys.

A 5 minute fix!  Awesome!  When will you be posting your patch?
My days of coding are behind me, but if it takes more than 5 minutes to fix this issue, then you guys have bigger problems.
So, you don't actually have any experience fixing bugs in Thunderbird, but still feel like you're able to estimate how long this fix should take?  Huh.  Interesting.

On a brighter note, Happy New Year!  :D
(In reply to Thomas D. from comment #13)
> clarkbw, devs, pls consider the popularity of this feature (at least for
> closing message tabs), looking at the development of the download count for
> the "Close tab on ESC" addon:
>  
> (In reply to comment #8)
> > download count of the "Close tab on ESC" add-on at:
> > https://addons.mozilla.org/en-US/thunderbird/addon/161748/
> > Currently 2,455.
> Only 4 months later, the download count is up to
> 4,311 (almost double). Clearly, there is a trend here that should be
> respected.

This currently isn't in the top 300 most popular addons
Keywords: regression
Whiteboard: [gs][SAmessage-parity] → [workaround comment 16]
To be perfectly honest, the reason this bug hasn't been implemented isn't because of how long it will take; it's because Thunderbird drivers have made the decision that this isn't a feature they would like to see in Thunderbird, *even if* someone provided the patch.

For those of you who feel that this disrupts your workflow, then an add-on has already been linked[1] that should solve the problem for you. However, it's important to remember that just because something helps *your* workflow doesn't mean that it's something that would help the majority of users. From my perspective, I would actively fight against having Esc close message tabs, since I think it would be too easy to accidentally close them (e.g. if I accidentally double-tap escape after searching for text with Ctrl+F). I'd rather some people have to take the extra time to hit Ctrl+W (which is still very quick for me) than for other people to unintentionally lose what they were doing.

If you'd like more background on the reasoning for this decision, I recommend reading comment 14, comment 16, and comment 24.

[1] https://addons.mozilla.org/en-US/thunderbird/addon/close-tab-on-esc/
Thanks but please just try testing/using it first since your comment does not accurately describe what really happens. Ctrl-W works exactly like the Escape key should work .... if you have made no changes to the message, the message window will close nicely. Perfect. If you have made changes to the message, you are prompted with "Message has not been sent. Do you want to save the message in your drafts folder (Drafts)?", which again, is perfect. 

All i'm saying is to add "Esc" to the logic that checks for "Ctrl-W" .... that's it. The Esc key does nothing right now.
(In reply to acturbo from comment #36)
> Thanks but please just try testing/using it first since your comment does
> not accurately describe what really happens. Ctrl-W works exactly like the
> Escape key should work .... if you have made no changes to the message, the
> message window will close nicely. Perfect. If you have made changes to the
> message, you are prompted with "Message has not been sent. Do you want to
> save the message in your drafts folder (Drafts)?", which again, is perfect. 

What you're describing is different from this bug. This bug is about allowing the escape key to close an incoming message that's been opened in a tab. You seem to be talking about using the escape key to close the new message that you're composing.

I suggest you head over to bug 242636.
...and i wish everyone a happy and healthy new year!
yes, that's what i need. i'll check out the link you provided, thanks!
This issue was closed suggesting an add-on to implement-it (https://addons.mozilla.org/en-US/thunderbird/addon/close-tab-on-esc/).  The add-on does not work with the current version of Thunderbird.
Complementing previous comment: the suggested add-on is not signed, and cannot be installed in Thunderbird 45.
(In reply to Alexandre Folle de Menezes from comment #41)
> Complementing previous comment: the suggested add-on is not signed, and
> cannot be installed in Thunderbird 45.

Thunderbird does not require addons to be signed.

There are multiple reviews of the addon from a year ago at https://addons.mozilla.org/en-US/thunderbird/addon/close-tab-on-esc/#reviews which means it worked in version 38, and no negative reviews since then. I'd be surprised if it stopped working in 45. If it doesn't work, there is a "Support E-mail" link listed to contact the author
Yes, but it says "Works with Thunderbird 3.0 - 31.*".  Anyway, I tried again, and Thuderbird did not complain this time.  I don't know if I was doing something wrong before or if it was fixed.

Thanks, and sorry for the noise.

As the addon "Close tab on ESC" is not compatible with current TB 78.10.0 (Windows, 64-bit), this topic become relevant again.
Can this bug report be reopened? Should I start a new one?

From my point of view the Escape key (ESC) should close an opened message no matter where it was opened in (tab, window, whatever will come in the future).

Is there a reason Thunderbird is not considering this request? It would definitely be a good User Accessibility feature though.

You need to log in before you can comment on or make changes to this bug.