dirty region of view not updated properly when scrolling

RESOLVED FIXED in mozilla1.9.3a1

Status

()

RESOLVED FIXED
9 years ago
21 days ago

People

(Reporter: tnikkel, Assigned: tnikkel)

Tracking

Trunk
mozilla1.9.3a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
I noticed this on an ebay page that does essentially what reftest does in the upcoming patch.

Specifically if we do something that causes invalidation in js, and then synchronously cause a scroll (by setting window.location.href = "#someAnchorThatWillCauseScroll") the dirty rects of the previous invalidation aren't updated as they used to be nsViewManager::WillBitBlit.
(Assignee)

Comment 1

9 years ago
Created attachment 424745 [details] [diff] [review]
patch

Unfortunately the reftest doesn't fail for the same reason as bug 540247.
Assignee: nobody → tnikkel
Attachment #424745 - Flags: review?(roc)
Is this a duplicate of or will this fix bug 541144?
(Assignee)

Comment 3

9 years ago
It could fix bug 541144, but I can't reproduce bug 541144 so I don't know.

Updated

9 years ago
Blocks: 541144
Comment on attachment 424745 [details] [diff] [review]
patch

Thanks! This might fix bugs 540161, 540294 and 541144...
Attachment #424745 - Flags: review?(roc) → review+

Comment 5

9 years ago
and 544085?
(Assignee)

Comment 6

9 years ago
http://hg.mozilla.org/mozilla-central/rev/aac72ffed29f
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
(Assignee)

Updated

9 years ago
Blocks: 544085
(Assignee)

Updated

9 years ago
Blocks: 540161
(Assignee)

Updated

9 years ago
Blocks: 540294
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.