[shipping] support many and none appversion in the query url

RESOLVED FIXED in 3.2

Status

P3
normal
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: stas, Assigned: stas)

Tracking

Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
A spin-off of bug 543504

We should support:

?av=fx3.6&av=fx3.5&av=fennec1.0
?status=pending
?status=pending&av=fx3.6&av=fx3.5&av=fennec1.0
(Assignee)

Comment 1

9 years ago
Created attachment 426669 [details] [diff] [review]
Patch A.1

I was about to attach a WIP patch, but I made a couple of edits and I think this works pretty OK.

This makes Shipping's dashboard support:

/shipping/dashboard
/shipping/dashboard?av=fx3.6
/shipping/dashboard?av=fx3.6&av=tb3.1
Assignee: nobody → stas
Attachment #426669 - Flags: review?(l10n)
(Assignee)

Comment 2

9 years ago
Created attachment 426672 [details] [diff] [review]
Patch A.2 A nicer-looking loop in shipping.views.dashboard

This loops over av's once, not three times.
Attachment #426669 - Attachment is obsolete: true
Attachment #426672 - Flags: review?(l10n)
Attachment #426669 - Flags: review?(l10n)

Comment 3

9 years ago
Comment on attachment 426672 [details] [diff] [review]
Patch A.2 A nicer-looking loop in shipping.views.dashboard

r=me with nits.

I don't like getting the appvers or milestones still, I anticipate us changing that code once or twice again. Still, this should fix the problem for now.

My main culprit with my other approach is the subtitles, for which I need the str(appversion) and that needs more thought in my head.

Nits: A few lines should get a select_related.

for mstone in mstones.select_related("appver__tree"):

for appver in appvers.select_related("tree"):

av_or_m_list should also end up with appver__tree, which need a third layer if you're in ms.
Attachment #426672 - Flags: review?(l10n) → review+

Updated

8 years ago
Assignee: stas → nobody
Component: Infrastructure → Elmo
Product: Mozilla Localizations → Webtools
QA Contact: infrastructure → elmo
Summary: [dashboard][shipping] support many and none appversion in the query url → [shipping] support many and none appversion in the query url
Version: unspecified → 1.0

Updated

8 years ago
Duplicate of this bug: 603276
(Assignee)

Updated

8 years ago
Assignee: nobody → stas
Target Milestone: --- → 1.2

Updated

7 years ago
Target Milestone: 1.2 → ---

Comment 5

7 years ago
Comment on attachment 426672 [details] [diff] [review]
Patch A.2 A nicer-looking loop in shipping.views.dashboard

Review of attachment 426672 [details] [diff] [review]:
-----------------------------------------------------------------

Did a triage pass through our bugs with patches that have an r+.

Moving this over to an r-, as this patch doesn't apply anymore. It's not that it couldn't be resurrected along the same lines though.

Do we still want this?
Attachment #426672 - Flags: review+ → review-

Comment 6

6 years ago
Yes, we still want this, but stas isn't going to work on this any time soon, unassigning.
Assignee: stas → nobody
Assignee: nobody → peterbe
(Assignee)

Comment 7

5 years ago
Created attachment 751625 [details] [diff] [review]
2013 patch

After 1192 days, here's a new patch :)
Attachment #426672 - Attachment is obsolete: true
Attachment #751625 - Flags: review?(l10n)

Comment 8

5 years ago
Comment on attachment 751625 [details] [diff] [review]
2013 patch

Review of attachment 751625 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nits:

Please use a check-in comment that references the bug, and doesn't do [PATCH].

If you start the comment with "fixes bug XXXX - message", bots will close this bug on landing. Not that I like the message format.
Attachment #751625 - Flags: review?(l10n) → review+

Comment 9

5 years ago
Commit pushed to develop at https://github.com/mozilla/elmo

https://github.com/mozilla/elmo/commit/cd296aab9ee26c24317d678928debb191bbe860f
fixes bug 543940 - Allow more than one appversion in the dashboard's URL, r=Pike

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: peterbe → stas

Updated

5 years ago
Target Milestone: --- → 3.3

Updated

5 years ago
Target Milestone: 3.3 → 3.2
You need to log in before you can comment on or make changes to this bug.