Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Tree items in "Items for Offline Use" dialog have incorrect accessible name

RESOLVED FIXED in mozilla7

Status

()

Core
Disability Access APIs
RESOLVED FIXED
8 years ago
3 months ago

People

(Reporter: Jamie, Assigned: surkov)

Tracking

(Blocks: 1 bug, {access})

unspecified
mozilla7
x86
Windows 7
access
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100211 Minefield/3.7a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100214 Lanikai/3.1b1pre

In the Items for Offline Use dialog, the tree items (for each folder) inherit the accessible name of the tree instead of containing the name of the particular folder.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird.
2. Open the "Items for Offline Use" dialog: File menu -> Offline -> Download/Sync Now... -> Select... button.
3. Observe that the accessible name of the tree itself is "Choose mail folders and newsgroups for offline use.". This is determined from the associated label.
4. Examine the accessible name of one of the tree items.
5. Examine the first table cell (first child) beneath the same tree item.
Actual Results:  
The name of the tree item (step 4) is "Choose mail folders and newsgroups for offline use." The name of its first child (step 5) is the name of the folder represented by the tree item.

Expected Results:  
The name of the tree item (step 4) should be the name of the folder represented by the tree item; i.e. the same as the name of the first table cell (step 5).

This causes screen readers to report "Choose mail folders and newsgroups for offline use." for every tree item in this tree, which is not very useful.

The ID of this tree is "synchronizeTree".
(Reporter)

Updated

8 years ago
Keywords: access
(Assignee)

Updated

6 years ago
Blocks: 459353
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

6 years ago
Duplicate of this bug: 660330
(Assignee)

Comment 2

6 years ago
Created attachment 536264 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #536264 - Flags: review?(trev.saunders)
Comment on attachment 536264 [details] [diff] [review]
patch


>+  nsCOMPtr<nsITreeColumns> columns;
>+  mTree->GetColumns(getter_AddRefs(columns));
>+  nsCOMPtr<nsITreeColumn> primaryColumn;
>+  if (columns) {
>+    columns->GetPrimaryColumn(getter_AddRefs(primaryColumn));
>+    if (primaryColumn)
>+      GetCellName(primaryColumn, aName);

why not declare primaryColumn inside the first if?  since you only need it  if you have columns, and so you save the useless construction in some cases?

>+        var tree = {
>+          role: ROLE_OUTLINE,
>+          children: [
>+            {
>+              role: ROLE_LIST
>+            },
>+            {
>+              role: ROLE_OUTLINEITEM,
>+              children: [],
>+              name: "row1col"

what is this _col about? its a tree so there's only one "column" right?
Attachment #536264 - Flags: review?(trev.saunders) → review+
(Assignee)

Comment 4

6 years ago
(In reply to comment #3)

> why not declare primaryColumn inside the first if?  since you only need it 
> if you have columns, and so you save the useless construction in some cases?

thanks

> what is this _col about? its a tree so there's only one "column" right?

it's just autogenerated name
(Assignee)

Comment 5

6 years ago
landed http://hg.mozilla.org/mozilla-central/rev/78026ebff8b3
Assignee: surkov.alexander → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Component: General → Disability Access APIs
Flags: in-testsuite+
Product: Thunderbird → Core
QA Contact: general → accessibility-apis
Resolution: --- → FIXED
Target Milestone: --- → mozilla7

Comment 6

6 years ago
This causes a regression in about:config. The items there are no longer read by NVDA when up and down arrowing. Alex, do you need a separate bug for this?
(Assignee)

Comment 7

6 years ago
Marco, please file new bug for this.

Updated

6 years ago
Depends on: 664376

Comment 8

6 years ago
Filed bug 664376 for the regression.

Updated

3 months ago
Assignee: nobody → surkov.alexander
You need to log in before you can comment on or make changes to this bug.