Can't big images be resized to fit the screen?

RESOLVED DUPLICATE of bug 692616

Status

Thunderbird
Message Reader UI
--
enhancement
RESOLVED DUPLICATE of bug 692616
8 years ago
7 years ago

People

(Reporter: Johannes Falk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB6
Build Identifier: Version 2.0.0.23 (20090812)

When I receive an email with one or more large jpg attached, I can't view the picture completely.

Reproducible: Always

Steps to Reproduce:
1. receive an email with a large image
2. display this email

Actual Results:  
the picture does not fit the screen

Expected Results:  
big pictures should be shrinked to fit the display automatically.

would be nice to rescale the image manually too.
(Reporter)

Comment 1

8 years ago
THANKS:
Because of Bug 547139 I just installed Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

NICE:
Individual automatic downscaling of each big attached image to fit the window *is already implemented* in the current version.

VERY NICE:
By simply left-clicking I can toggle between full size and fit to window.

BUT:
But -sorry- the algorithm in tb301 is a bit less intelligent than the one that is currently implemented in ff. It does NOT zoom to the clicked position, but to the top/left corner. So I always have to scroll manually to the point of interest.

This aiming should be improved to be perfect.
Thx anyway!
Hanno

Comment 2

8 years ago
Well, in that case, this bug is probably invalid, and the algorithm you're talking about is bug 546910.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
YES
thx
(Reporter)

Comment 4

7 years ago
After updating to tb 6.0 the bug reoccurred and all big images are displayed huge again. They should fit to the screen initially as before.

Unzoom (Ctrl -) does not help either, it resizes the text only, not the pictures.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

7 years ago
Do you confirm that the problem is still there if you start Thunderbird in safe-mode?
(Reporter)

Comment 6

7 years ago
Yes, the size is wrong in safe-mode too. All big pictures are displayed unscaled and get scrollbars.

This oversize problem had been fixed already (on my demand?) in tb 3.0.1 in Feb 2010 - now it is back.

If the code got lost, this time it should be re-implemented exactly as realized in ff. That means: Initially all big pictures fit into the window and can be zoomed *centered to the mouse position* by a single left-click. (The previous tb fix erroneously always showed the upper/left after zoom, despite where you click.)

Updated

7 years ago
Whiteboard: [gs]

Comment 7

7 years ago
could you attach to this bug report a mail which has this problem (save it into *.eml file format)?
(Reporter)

Comment 8

7 years ago
This bug seems to be rare but is always reproducible with any email I tested, that has pictures that do not fit in the initial window, but the behavior is very strange:
It only happens with the very first email you open after starting tb that got big pictures! And BTW if it happens and you get those persistent scrollbars, there is no (-) or (+) at the mouse cursor.

Opening any other email with big pictures or even reopening the same email again (by shortly selecting some random email) cures the bug.
Restarting tb and opening some email w/o pictures before you go to an email with big pictures the very first time, helps only sometimes (some emails (like yours) cure, some do not).
Switching between two emails (with big images) that are stored in different folders and going back to the first folder w/o selecting anything, redisplays the first email again and still shows the bug, though the second email was already displayed correctly.

And finally resizing anything (the tb main window or any tb sub-window - even vertically) cures immediately.
(Reporter)

Comment 9

7 years ago
After the automatic update of tb tonight, only resizing cleared the bug - reopening the massage with the big images did not work any more.
(Reporter)

Comment 10

7 years ago
After the automatic update of tb tonight, only resizing cleared the bug - reopening the message with the big images did not work any more.
(Reporter)

Comment 11

7 years ago
In the current version of tb this bug is now persistent and easy to reproduce:
After opening or reopening any email all big pictures are always oversized and a horizontal scrollbar occurs again and again. Resizing the main window or any subwindow immediately displays all big pictures in the correct scale and then a (+) is attached to the mouse pointer.

BTW The zoom is still not centered to the mouse position at click.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 692616

Comment 13

7 years ago
mmhm, bug 692616 regressed after this was filed, no?

Comment 14

7 years ago
I suppose so, but bug 692616 tracks the current situation and has more info.
You need to log in before you can comment on or make changes to this bug.