Closed Bug 547915 Opened 10 years ago Closed 10 years ago

Update package-manifest.in based on package-compare output

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla3.7a2

People

(Reporter: philor, Assigned: philor)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached patch Cleanup, round 1Splinter Review
Things I'm sure about:

* .autoreg is dead - bug 511761
* @DLL_PREFIX@browserdirprovider@DLL_SUFFIX@ is dead - bug 507073
* contentprefs.xpt is dead - bug 536567
* arrow.gif and arrowd.gif are now jarred, not loose - bug 522649

Things I'm unsure about:

* Fx builds nsProgressDialog.js and nsProgressDialog.xul, jars up the .xul, but doesn't package the .js - it should either do both or neither, but I don't know which
* parentalcontrols.xpt is built on every platform, though it's only implemented on Windows, and it's not packaged on any platform - either packaged on every platform, or only built but also packaged on Windows, seems more right, but I don't know which one
* widget_cocoa.xpt probably shouldn't even exist, but I don't know how to phrase, determine, or remove it
* we build the "firefox" script and run-mozilla.sh on OS X, but don't ship them, and we should probably either ship them or stop building them
* we're actually missing the LICENSE file we try to package, on OS X, but I have high hopes for bug 547914 making all that badness go away
Attachment #428372 - Flags: review?(ted.mielczarek)
Comment on attachment 428372 [details] [diff] [review]
Cleanup, round 1

(In reply to comment #0)
> Things I'm unsure about:
> 
> * Fx builds nsProgressDialog.js and nsProgressDialog.xul, jars up the .xul, but
> doesn't package the .js - it should either do both or neither, but I don't know
> which

Clearly if we're not shipping the .js, it doesn't matter, so we should just stop shipping the .xul (and probably stop building either of them). AFAICT, that's the "download progress dialog", which Firefox doesn't use. File a bug on not building them? (You can just update your patch to stop shipping the .xul.)

> * parentalcontrols.xpt is built on every platform, though it's only implemented
> on Windows, and it's not packaged on any platform - either packaged on every
> platform, or only built but also packaged on Windows, seems more right, but I
> don't know which one

If we're building it everywhere, might as well package it everywhere. Extra interfaces are a pretty negligible cost.

> * widget_cocoa.xpt probably shouldn't even exist, but I don't know how to
> phrase, determine, or remove it

I guess package it on Mac for now, since it exists, but file a bug on deCOMing that interface (since it's not scriptable and not actually used as an XPCOM interface anywhere).

> * we build the "firefox" script and run-mozilla.sh on OS X, but don't ship
> them, and we should probably either ship them or stop building them

I intentionally stopped shipping them in bug 463605, since the "firefox" script would cause problems on 10.6 (with the whole sqlite thing), and it's not actually necessary on OS X, but now that we fixed bug 513747 it probably doesn't matter either way (and someone mentioned that we broke Dreamweaver by removing the "firefox" script, so maybe putting it back would be a good idea).

> * we're actually missing the LICENSE file we try to package, on OS X, but I
> have high hopes for bug 547914 making all that badness go away

Feel free to fix however you like.
Attachment #428372 - Flags: review?(ted.mielczarek) → review+
Depends on: 548071
Depends on: 548189
Can't actually stop the progress dialog xul, since it's jarred rather than loose, but I'll get it eventually. Added in parentalcontrols.xpt and widget_cocoa.xpt, and I'll get "firefox" and run-mozilla.sh separately.

http://hg.mozilla.org/mozilla-central/rev/fc606b04e33e
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a2
Depends on: 549246
No longer blocks: C192ConfSync
Duplicate of this bug: 528799
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3.7a2 → mozilla3.7a2
You need to log in before you can comment on or make changes to this bug.