[D2D] Autoscroll popup not visible anymore with direct2d rendering

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
gfx.font_rendering.directwrite.enabled  set to true.
mozilla.widget.render-mode set to 6(RENDER_DIRECT2D).

After that, I don't see any autoscroll popup anymore.
I guess transparent popups aren't working in general.
Confirmed. Can't see autoscroll popup too.

Comment 2

8 years ago
Transparency in general seems to be a problem. For example the various add-ons, that enable aero glass in the main window don't work with d2d enabled.
Summary: Autoscroll popup not visible anymore with direct2d rendering → [D2D] Autoscroll popup not visible anymore with direct2d rendering

Comment 3

8 years ago
No autoscroll popup on XP either.

Comment 4

8 years ago
OMG Bozz
If there is no autoscroll popup on XP that would be a separate bug because there is no D2D on XP. Please file it.

Comment 6

8 years ago
^^Done. Bug 571550 – Autoscroll popup not visible anymore with latest Minefield nightly on Windows XP

Comment 7

8 years ago
(In reply to comment #4)
> OMG Bozz

Hey! If what you are saying does not bring this bug further towards getting resolved, please don't create a new post. It is SPAM, and in this case it is, as I take it, directed as a "mean" comment against a person.
Blocks: 556193, 556180
I think should only be blocking 555133.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.