Larry and Bookmark <panel>s don't appear when D2D enabled

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Dolske, Assigned: bas)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [doorhanger])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Blizzard just noticed this, and I see the same on my Win7 box. Clicking the larry button or bookmark star shows a visual state change, but the associated <panel> is never displayed. (EG, the button looks depressed, and the star is filled in).

Tested on current trunk nightly.
The problem goes away now the backout for bug 555133 occurred.
(Reporter)

Comment 2

8 years ago
rob, possible that 555133 caused this?
(In reply to comment #2)
> rob, possible that 555133 caused this?

Yeah, it's possible.

Comment 4

8 years ago
Confirmed. Tested with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100412 Minefield/3.7a5pre
This is back with bug 555133 relanding last night with D2D/DW turned on.

Updated

8 years ago
Duplicate of this bug: 571892
Depends on: 548962
I noticed that the panel is definitely there when you click on Larry or the Star and transparent.

I noticed this by having something clickable like a bookmark bar with links on it, etc below where the panel would normally popup and those links are not clickable. 

However, right click context menus don't suffer from this issue when clicking on the exact same x,y coordinates.  Those menus appear.
Created attachment 452668 [details]
D2D/DW enabled, showing open the bookmarks folder selection in star panel under "edit bookmark"

Here is an example of the transparent panel, and the menu buttons are still functional.  This shows how I had clicked in the correct place (x,y) to open the folder selection menu inside the star panel.
(Assignee)

Updated

8 years ago
Assignee: nobody → bas.schouten
Blocks: 569166
Status: NEW → ASSIGNED
(Assignee)

Comment 9

8 years ago
This is indeed a direct consequence of bug 555133. If I return opaque for the broken widgets they work fine. For some reason they're considered transparent and then are incorrectly displayed.
(Assignee)

Comment 10

8 years ago
So the problem here is that the transparency mode for the panels is set to eTransparencyTransparent since the theme inference patch. Just like for example the middle-mouse button click scrolling image.

eTransparencyTransparent is not working with Direct2D. Since it uses WS_EX_LAYERED windows this will require some additional work to fix. There should be two things that need to be looked into:

1. Why is the panel considered a transparent window? It probably shouldn't be, WS_EX_LAYERED has some performance implications to we might want to know.

2. Make Direct2D play nice with completely transparent windows.

I will do two so we can get this bug out of the way. But 1 should probably be done as well.
(Assignee)

Updated

8 years ago
Depends on: 573507
(Assignee)

Updated

8 years ago
Duplicate of this bug: 573570
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 573236
Nice that this is fixed. Certainly would have blocked.
blocking2.0: ? → final+
Whiteboard: [doorhanger]
Verified fixed with Firefox 4.0b12pre 20110218.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.