[d2d] Tooltips no longer appear for anything (tabs, links, etc.)

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: u88484, Assigned: bas.schouten)

Tracking

(Blocks 1 bug, {regression})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

Attachments

(1 attachment)

161 bytes, text/html
Details
Reporter

Description

9 years ago
Posted file Testcase
Tooltips no longer appear for anything.  Hovering over tabs used to display a tooltip as well as links with title="blah" in the code
Assignee

Updated

9 years ago
Duplicate of this bug: 556197
Reporter

Comment 2

9 years ago
Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ad1c22bcdc27&tochange=a6e0b02521cd
Component: Plug-ins → Widget: Win32
QA Contact: plugins → win32

Comment 3

9 years ago
Works:
http://hg.mozilla.org/mozilla-central/rev/70698587d13f
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100329 Minefield/3.7a4pre ID:20100329114550

Fails:
http://hg.mozilla.org/mozilla-central/rev/26be64ca9977
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100329 Minefield/3.7a4pre ID:20100329165317

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=70698587d13f&tochange=26be64ca9977
Blocks: d2d
Backout of 555133 seems to have corrected the missing tool-tips. 

Tested using latest hourly with cset:
http://hg.mozilla.org/mozilla-central/rev/3776e9061c1d
Reporter

Comment 5

9 years ago
(In reply to comment #4)
> Backout of 555133 seems to have corrected the missing tool-tips. 
> 
> Tested using latest hourly with cset:
> http://hg.mozilla.org/mozilla-central/rev/3776e9061c1d

Confirmed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Please Reopen.  This is a problem again using with DW/D2D enabled.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100611 Minefield/3.7a6pre

Probably with the relanding of bug 555133.
Blocks: 555133
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Oddly, this only occurs if gfx.font_rendering.directwrite.enabled is true,  one would think this would be more likely impacted by the mozilla.widget.render-mode setting.
OK I guess this makes more sense. Resetting mozilla.widget.render-mode to the default value also fixes the issue.  Which makes one think that oddly although there are 2 separate settings here, setting either of them independently does nothing and you need to set both of them to make any difference at all, leading one to ask the question "Why are there 2 preferences here??????"
If you disable DirectWrite, Direct2D doesn't work. GDI fonts can't be drawn to
D2D.
Maybe Bas can look into this. It's probably something simple like Windows returning the wrong value for isThemeBackgroundPartiallyTransparent for tooltips.
blocking2.0: --- → beta1+
Actually Chris P might be able to help me debug this.
We're not going to hit D2D for Beta 1.
blocking2.0: beta1+ → beta2+
Depends on: 548962

Comment 13

9 years ago
The tooltips are actually working - they are just completely transparent if default background used. (For example - in facebook where the background is black - they works fine, in speed dial - hovering over a preview should show a tooltip - however - only the shadow is visible)

Comment 14

9 years ago
I use bookmarks as a side bar. Not a sign of tooltips if D2D is enabled.
Assignee

Updated

9 years ago
Assignee: nobody → bas.schouten
Blocks: 569166
Status: REOPENED → ASSIGNED
Assignee

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED

Comment 15

9 years ago
This seems to be broken again.
File a new bug please.

Comment 17

8 years ago
That seems to be filed as bug 617128.
There is also a newer report in bug 684852.

Updated

8 years ago
Blocks: 684852

Updated

8 years ago
Blocks: 617128
You need to log in before you can comment on or make changes to this bug.