Missing shortcut key for "Grouped by Sort"

RESOLVED WONTFIX

Status

Thunderbird
Preferences
--
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: peter, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); 

The hotkey "G" for toggling the "Grouped by Sort" feature has been removed from the latest build.

Please add it back.

Reproducible: Always

Steps to Reproduce:
1.Attempt to hit keyboard key "G" to group the emails.
2.
3.
Actual Results:  
nothing happens

Expected Results:  
toggle the grouped by sort feature.
Duplicate of this bug: 550165

Comment 2

7 years ago
I can confirm that the G shortcut is missing, very inconvenient. Please re-add asap.
Whiteboard: dupme
The "G" single-key shortcut for "group by sort" was intentionally removed by
Bug 275871 - View->Sort By->Grouped by Sort keyboard shortcut goes against interface guidelines (back out bug 263919)

The main reasons cited were afasik:
1 usability problem: if hit accidentally, there is no easy way to get out of "grouped by sort" mode
2 consistency problem: single-letter shortcuts are basically reserved for message-related actions (as opposed to view changing)
Both points are certainly arguable.

To re-add the shortcut, you can install the Threadkey addon
https://addons.mozilla.org/en-US/thunderbird/addon/threadkey/
which will add the following shortcuts:
- T for threaded
- U for unthreaded
- G for grouped by sort

In the long run, we may want an inbuilt solution for this, as requested by
Bug 263571 - Improve mode switching between Threaded, Unthreaded, and Grouped By Sort (column headers, unthread pref, G keyboard shortcut).
Sprite_screen
Blocks: 275871
No longer blocks: 275871
Blocks: 275871

Comment 4

5 years ago
As per comment 3, this is the expected behaviour, so marking it as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: dupme
Blocks: 713979
You need to log in before you can comment on or make changes to this bug.