Status

()

defect
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: icecold, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100306 Minefield/3.7a3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100306 Minefield/3.7a3pre

When I visit website sometimes page is not rendered the way it should.
It get's messed. This only happens when Direct2D is enabled.


Reproducible: Sometimes

Steps to Reproduce:
1.Go to any site.
2.If it doesn't show, keep on loading websites.
3.
Actual Results:  
Rendering page gets messy.
Screenshot: http://img96.imageshack.us/img96/6515/rendering.jpg

Expected Results:  
The page should render normaly.

Graphic card is GeForce 8400GS with latest drivers.
Direct2D is enabled.
This is probably caused by the broken fallback. This is landing on the tree soon!
Depends on: 550911
Reporter

Comment 2

9 years ago
Far as I can see, I'm getting no rendering problems with two last nightly updates.
What I thought it might be a driver problem. Could that be? Because I had 196.75 and when I switched back to 196.34 no problems. Also I'm getting no comments from friends who I suggested to test Direct2D (and they claim that Firefox is now faster than Opera 10.50 xD) So probably it's because of broken fallback.
Reporter

Comment 3

9 years ago
Now I'm getting this rendering mess: http://img717.imageshack.us/img717/3193/renderingmess.jpg
To reproduce this go to this page: http://www.subotica.com/clanovi/profil/icecold/
And mouse over the whole page, and you will see that some parts turn white and then go back to normal.
Another one happens with on this page: www.subotica.com, what I noticed is that only when you scroll up it happens, not when you scroll down.
And here is screenshot: http://yfrog.com/0urenderingmess2j
Also I made a video of rendering mess, so you can understand more what I'm talking about: http://www.mediafire.com/download.php?j0wmuycwozy (3MB)
I can confirm the corruption on http://www.subotica.com/clanovi/profil/icecold/

I have the fix for #550911 installed.


Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100309 Minefield/3.7a3pre - Build ID: 20100309041426
Just installed new nightly build and problem on the page I mentioned no longer happens.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100310 Minefield/3.7a3pre - Build ID: 20100310040439
Sorry, I forgot that I need to do a double restart after updating to a new nightly otherwise d2d/dw gets disabled.  After a second restart page in question still shows screen corruption.
Reporter

Comment 7

9 years ago
With latest nightly build it still shows the corruption. I figured out that on www.subotica.com corruption only happens when I'm logged in.
I don't know, but maybe chat bar (which opens when you log in) is causing that disappearing problem on page, like it's showed on first screenshot.
Perhaps this is due to problems with 551350, although I'm unsure how that bug would cause it. I'm looking into it.
Reporter

Comment 9

9 years ago
Can someone explain why does page scrolls slowly and freezes when im scrolling this page? : http://forum.subotica.com/viewtopic.php?p=688583#p688583
With Direct2D turned off it's good and fast, but when Direct2D is on it get's slow and freezes.
Reporter

Comment 10

9 years ago
All bugs fixed that I reported here.
Still one remains.
Online user status (Flash) get's black.
A screenshot with normal status
(disabled D2D): http://img709.imageshack.us/img709/6452/normaly.jpg
And black problem with flash when using D2D: http://img502.imageshack.us/img502/3193/renderingmess.jpg

Also note that similar bug happens on ImageShack when uploading image: http://img16.imageshack.us/img16/9788/imageshacknb.jpg

Using 3.7a4pre, it happens also on Developer Preview alpha 3.
Reporter

Comment 11

9 years ago
So can someone explain why is this happening? 
Is this because of my graphic card (8400GS) or it's just a problem with D2D?
I used latest build (3.7a5pre) and problems are still here.
Reporter

Comment 12

9 years ago
I found the solution to avoid rendering mess. And I think it's caused by default Firefox theme. When I use another theme (Strata40) I'm not getting rendering mess. But when I switch to original theme it gets buggy.

Updated

9 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Have you installed the latest WHQL drivers for your 8400GS? And is this still happening with the latest nightly build?
Reporter

Comment 14

9 years ago
Yes. I tried: 196.21, 197.13, 197.45 all WHQL. And on all those I'm getting problem. I also tried 196.34, 197.13, 197.25, 197.57 beta drivers and only 196.34 doesn't show any problems. Yes, I tried it yesterday and it was still happening. (with 197.45 and 197.57)
(In reply to comment #12)
> I found the solution to avoid rendering mess. And I think it's caused by
> default Firefox theme. When I use another theme (Strata40) I'm not getting
> rendering mess. But when I switch to original theme it gets buggy.

When using the strata theme you're disabling D2D automatically, so that would be why its fixed, see also bug 558708.
Duplicate of this bug: 558708
Are some people still seeing this?
Reporter

Comment 18

9 years ago
No problems with 257.21 drivers.

Comment 19

9 years ago
seeing this with Build identifier: Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre

I'm using an integrated Intel HD Graphics device on a DQ57TM mainboard.

I get render issues when scrolling, particularly when scrolling both horizontally and vertically.
Reporter

Comment 20

9 years ago
^ I think it's a problem with retained layers and Direct2D.
Reporter

Comment 21

9 years ago
Bas, should we get this bug as resolved fixed?
Haven't heard from anyone complaining any more about this problem.
Closed as WFM per Comment 21. Reopen if the problem is reproducible. There as not been a mention of this problem since Firefox 4.0 beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.