[OOPP] static flicker effect when playing silverlight

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: mozbugz, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre (.NET CLR 3.5.30729)

also http://www.windowsphone7series.com/

Reproducible: Always

Steps to Reproduce:
1. go URL move mouse over silverlight images or click on images to run js
2.
3.
Actual Results:  
Silverlight flickers while loading and running.

Expected Results:  
shouldn't flicker.

It happens with D2D enabled and OOPP enabled.
Reporter

Updated

9 years ago
See Also: → 549056
Version: unspecified → Trunk
Reporter

Comment 2

9 years ago
Problem goes away if I set ipc = false, but i have D2D enabled in both cases.
Blocks: OOPP
Summary: static flicker effect when playing silverlight → [OOPP] static flicker effect when playing silverlight
Did you test with the latest builds? I suspect this is bug 549056.
That looks like the distortion I was seeing back when we were doing alpha extraction in two passes over ipc. WFM though in a latest build post Bas's touchup fix  from today.
Reporter

Comment 5

9 years ago
Well, I tested it after I seen Flash was fixed in bug 549056 and bug 552052 was fixed. I thought it was the Flash bug too.  It looks the same, but Flash is fixed for me now, this is still there.

Testing Nvidia 7050 / 610i, Silverlight 3, Win7 RC.

 I just tested the latest hourly and I still see it on these URLs.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre (.NET CLR 3.5.30729) ID:20100312165328
http://hg.mozilla.org/mozilla-central/rev/60d6b5d65a94
Reporter

Comment 6

9 years ago
Note, besides loading silverlight, I see it while hovering the mouse over to make the silverlight run..   

It doesn't happen on all Silverlight instances.. just these for some reason.
Reporter

Comment 7

9 years ago
Posted image Windows Phone site
interact with the plugin by using the mouse to trigger events
Reporter

Comment 8

9 years ago
(In reply to comment #4)
> That looks like the distortion I was seeing back when we were doing alpha
> extraction in two passes over ipc. WFM though in a latest build post Bas's
> touchup fix  from today.

I just changed the mozilla.* rendermode to -1 and OOPP is still enabled.  And the problem goes away also using the latest hourly.
(In reply to comment #8)
> (In reply to comment #4)
> > That looks like the distortion I was seeing back when we were doing alpha
> > extraction in two passes over ipc. WFM though in a latest build post Bas's
> > touchup fix  from today.
> 
> I just changed the mozilla.* rendermode to -1 and OOPP is still enabled.  And
> the problem goes away also using the latest hourly.

Alpha extraction on GDI only occurs when you have a windowless plugin with some opacity set (0.5 for example). Could you verify with the latest nightlies it's working well?
Reporter

Comment 10

9 years ago
Nvidia 7050 / 610i hardware, latest drivers, latest Minefield nightly, Win 7 RC.

Under these scenarios..

image distortion:
OOPP [ipc] true, D2D render-mode = 6, DW = true

no distortion:
OOPP [ipc] true, D2D render-mode = -1, DW = true
OOPP [ipc] false, D2D render-mode = 6, DW = true

no distortion before DW/D2D:
OOPP [ipc] false, D2D render-mode = -1, DW = false
OOPP [ipc] true, D2D render-mode = -1, DW = false
(In reply to comment #10)
> Nvidia 7050 / 610i hardware, latest drivers, latest Minefield nightly, Win 7
> RC.
> 
> Under these scenarios..
> 
> image distortion:
> OOPP [ipc] true, D2D render-mode = 6, DW = true
> 
> no distortion:
> OOPP [ipc] true, D2D render-mode = -1, DW = true
> OOPP [ipc] false, D2D render-mode = 6, DW = true
> 
> no distortion before DW/D2D:
> OOPP [ipc] false, D2D render-mode = -1, DW = false
> OOPP [ipc] true, D2D render-mode = -1, DW = false

If possible, try the following:

OOPP [ipc] true, D2D render-mode -1, DW = false

But give the object opacity 0.5!
Reporter

Comment 12

9 years ago
(In reply to comment #11)
> If possible, try the following:
> OOPP [ipc] true, D2D render-mode -1, DW = false
> But give the object opacity 0.5!

I don't know how to do that.  Both Urls above are a bit complex for my lack of understanding to make a simplified testcase.  Nvidia tools also don't give me an option to change anything like this.
Reporter

Comment 13

9 years ago
(In reply to comment #10)
> OOPP [ipc] true, D2D render-mode = -1, DW = true

I got distortion under this scenario, I cannot believe I _didn't_ check that before.
Reporter

Comment 14

9 years ago
(In reply to comment #13)
> (In reply to comment #10)
> > OOPP [ipc] true, D2D render-mode = -1, DW = true
> 
> I got distortion under this scenario, I cannot believe I _didn't_ check that
> before.

opps, Scratch that.  

If I have the following below which wasn't listed in the list above, I get image distortion:

> OOPP [ipc] true, D2D render-mode = 6, DW = false
(In reply to comment #14)
> (In reply to comment #13)
> > (In reply to comment #10)
> > > OOPP [ipc] true, D2D render-mode = -1, DW = true
> > 
> > I got distortion under this scenario, I cannot believe I _didn't_ check that
> > before.
> 
> opps, Scratch that.  
> 
> If I have the following below which wasn't listed in the list above, I get
> image distortion:
> 
> > OOPP [ipc] true, D2D render-mode = 6, DW = false
That essentially means you got distortion without both D2D and DW (disabling DW disables D2D).
Reporter

Comment 16

9 years ago
Interesting, I guess this bug is for D2D, but using this setting that doesn't produce the same results as if D2D was actually set to -1.

Also, I just tested latest hourly and I can finally bring up the Silverlight context menu but there is nothing in the Silverlight config that allows me to be set the opacity.  So we're still would need a simple testcase and I seen some code on MSDN about setting the opacity but didn't give a clear enough example.

A word of caution though, if you try to bring up the context menu on Silverlight, I found another OOPP bug while doing so, it currently hangs the browser and doesn't go away and I got our famous aero peek progress circles also with Win 7.  I had to kill Mozilla-Runtime to get back the browser.
Reporter

Comment 17

9 years ago
(In reply to comment #16)
> A word of caution though, if you try to bring up the context menu on
> Silverlight, I found another OOPP bug while doing so, it currently hangs the
> browser and doesn't go away and I got our famous aero peek progress circles
> also with Win 7.  I had to kill Mozilla-Runtime to get back the browser.

Filed bug 554262
OOPP----D2D----DW----opacity----winless----result
true    6      true  1.0        true       distorts
true    6      false 1.0        true       ok
true    6      true  0.9        true       ok
false   6      true  1.0        true       ok
false   6      true  0.9        true       ok
true    -1     true  1.0        true       ok
true    -1     true  0.9        true       ok


The render path we chose for that top option must have the issue.
Also,

OOPP----D2D----DW----opacity----winless----result
false   6      true  1.0        true       ok
true    -1     true  1.0        true       ok


So, DW on, D2D on, OOPP on, div opacity 1.0 -> distortion
true    6      true  1.0        true       distorts
true    6      true  0.9        true       ok

Could these two actually be using different rendering paths somehow?? Wouldn't they both be using fallback rendering, how could opacity 0.9 fix the distortion? Because it renders into an intermediate image surface?
(In reply to comment #20)
> true    6      true  1.0        true       distorts
> true    6      true  0.9        true       ok
> 
> Could these two actually be using different rendering paths somehow?? Wouldn't
> they both be using fallback rendering, how could opacity 0.9 fix the
> distortion? Because it renders into an intermediate image surface?

Not sure how D2D and DW effect this, but with OOPP/opacity, an opacity of 0.9 would enable double pass, while opacity 1.0 would render directly to the gdi surface.

It's a truly strange mix of settings that produces this, I have to admit. Why would disabling direct write change things?

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 22

9 years ago
It seems if DW is disabled the rendering of the plugin and page scrolling are faster and more responsive than it being enabled with D2D. 

It seems like DW causes choppiness.
If you disable DirectWrite, Direct2D doesn't work. GDI fonts can't be drawn to D2D.
Reporter

Comment 24

9 years ago
This is still a problem using latest trunk with SL4.

Updated

9 years ago
Duplicate of this bug: 559755
Reporter

Updated

9 years ago
Blocks: d2d
Reporter

Comment 26

9 years ago
I just tested retained layers try build and I see this without D2D/DW.
Reporter

Comment 27

9 years ago
(In reply to comment #26)
> I just tested retained layers try build and I see this without D2D/DW.

Roc pulled in patches for bug 577200 there.

Comment 28

9 years ago
Works for me on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826
Minefield/4.0b5pre ID:20100826120500

Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1831e8e87545&tochange=ff1fdbad6e20
Joyous!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Reporter

Comment 30

9 years ago
Yeah, confirming also!
You need to log in before you can comment on or make changes to this bug.