If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Provide an option for immediate offline use (immediate AutoSync) as soon as new mails are available in IMAP folders

RESOLVED DUPLICATE of bug 436615

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 436615
8 years ago
8 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

An option should be offered in the User Inteface ("Tools -> Options") for:
Immediate offline use / immediate AutoSync as soon as new mails are available in IMAP folders.

Therefore this option must cover the following 3 items:
a) mail.server.default.autosync_offline_stores --> true
b) mail.check_all_imap_folders_for_new --> true
c) mail.imap.use_status_for_biff --> false


Background/Reasons:
- Otherwise when I exit Thunderbird, I will not have my mails available for offline use (unless I would have downloaded them before manually via File -> Offline -> Download/Sync Now - what I always forget - and what is unconvenient anyway, not at least because it takes too much time in that moment to downlaod all new mails at once, instead of downloading each single e-mail automatically and immediately after its availability, what would take just a very short moment).
- Almost all users who would want Thunderbird to behave this way will likely never discover these 3 necessary settings by their own.


Reproducible: Always

Comment 1

8 years ago
Duplicate of/related to bug 329229 comment 18 -> MailNews Core bug 436615?
(Reporter)

Comment 2

8 years ago
Right, my bug here requests the same settings as bug 329229 comment 18.
But cannot understand why bug 329229 has been marked as dup of bug 436615, because (as far as I understand) bug 436615 did not implement all requested features of bug 329229 comment 18.

So I would like to keep my bug here open.
Because users still have to set the following/above mentioned 2 settings manually for a real immediate download of IMAP messages for offline use:
b) mail.check_all_imap_folders_for_new --> true
c) mail.imap.use_status_for_biff --> false
(In reply to comment #2)
> Right, my bug here requests the same settings as bug 329229 comment 18.
> But cannot understand why bug 329229 has been marked as dup of bug 436615,
> because (as far as I understand) bug 436615 did not implement all requested
> features of bug 329229 comment 18.
> 
> So I would like to keep my bug here open.
> Because users still have to set the following/above mentioned 2 settings
> manually for a real immediate download of IMAP messages for offline use:
> b) mail.check_all_imap_folders_for_new --> true
> c) mail.imap.use_status_for_biff --> false

True going offline still takes time and if that's the purpose of this bug can you clearly state that (and open a new clean one).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436615
(Reporter)

Comment 4

8 years ago
Sorry if I was unclear; I try to explain again if you don't mind:

In fact my bug report does not affect the "work offline" feature or the "Download/Sync now" feature, which indeed would cause Thunderbird to download all messages. But these would be manual actions, which I want to avoid.

The purpose of my bug report was to download all messages (header + body + attachment) automatically and immediately as soon as they are available in the IMAP folder (on the mail server) without any user interaction - even without having to open the relevant mail folder in Thunderbird (what in fact would also start a download of all of its messages; but for this I first would have to open that folder manually, what I want to avoid).


Therefore the requested standard settings are
- automatically check for new messages (mail.check_all_imap_folders_for_new --> true)
- via the select command (mail.imap.use_status_for_biff --> false)
- and download these messages immediately (mail.server.default.autosync_offline_stores --> true ==> already implemented since TB 3)


Only then all messages would be downloaded immediately without any necessary user interaction (no "work offline"; no "Download/Sync now"; no manual opening of the relevant Thunderbird folder or whatever).
(Reporter)

Comment 5

8 years ago
Re comment 3:
I opened a clean bug: see Bug 565457.
Hope I have expressed myself comprehendible (the correct wording is always a problem for me...).
You need to log in before you can comment on or make changes to this bug.