Thunderbird 3.0.3 hangs shortly after launch

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
critical
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Chris Pepper, Unassigned)

Tracking

(Blocks: 1 bug, {hang})

x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs reporter v3.1 retest][has Apple's crash reporte])

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: 

I have been using Thunderbird 2, but installed 3.0.3 this morning.
I launched 3.0.3 while v2 was still running, got the error message, let 3.0.3 quit, and then tried to quit v2, but it was hung.
Strangely, the Dock icon lost its triangle but the windows did not go away.
3.0.3 would not run, complaining Thunderbird was still running.
I rebooted.

I launched 3.0.3.
I poked around a few tabs (interestingly I got 2 copies of the new-features enablement tab and one new-features description tab) and hid the preview pane.
3.0.3 hung -- SPoD, no response.
I force quit 3.0.3.

I relaunched 3.0.3 and opened a message. I clicked some inline links.
Thunderbird displayed the message, then hung and completely stopped responding.
At this point I can see the message, and "Downloading 7 of 250 in Trash", but it's been stuck there for at least a couple minutes without change.

Sample and crash reports will follow.

Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird.
2. Open windows & close tabs.
Actual Results:  
Thunderbird hangs.

Expected Results:  
No hang.

I use 3 IMAP accounts (Cyrus, Courier, & Exchange). Thunderbird is set to sync, rather than cache, for all accounts.
(Reporter)

Comment 1

8 years ago
Created attachment 434862 [details]
Sample from last hang, after clicking links.
(Reporter)

Comment 2

8 years ago
Created attachment 434863 [details]
First crash, not from clicking links.
(Reporter)

Comment 3

8 years ago
Created attachment 434864 [details]
Second crash, clicking links
(Reporter)

Comment 4

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3
Version: unspecified → 3.0
Does the crash reporter show up ?

Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)
Keywords: crash, hang
(Reporter)

Comment 6

8 years ago
Apple's crash reporter, not Mozilla's.
Attachment #434863 - Attachment mime type: application/octet-stream → text/plain
Keywords: crash
Whiteboard: [has logs]
(Reporter)

Comment 7

8 years ago
After switching from 3.0.3 back to v2, my Inbox was was briefly corrupted again. Sorry, no 3.x Safe Mode tests for now -- I'm going to stick with v2 for awhile longer.

Comment 8

8 years ago
(In reply to comment #7)
> After switching from 3.0.3 back to v2, my Inbox was was briefly corrupted

Chris will be filing a new bug report with screen shot for this. Suggest next test might be better if done with v3.1 - http://www.mozillamessaging.com/en-US/thunderbird/early_releases/ or ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.2/
Blocks: 482756

Updated

7 years ago
Whiteboard: [has logs] → [needs reporter v3.1 retest][has logs]

Comment 9

7 years ago
Soem eports seem similar, I dont know enough to tell.  Thay sound like different hardwares

Comment 10

7 years ago
please reop if you see this in version 3.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [needs reporter v3.1 retest][has logs] → [needs reporter v3.1 retest][has Apple's crash reporte]
You need to log in before you can comment on or make changes to this bug.