Closed Bug 555245 Opened 11 years ago Closed 7 years ago

Add cox.net, now that they have a unified config

Categories

(Webtools :: ISPDB Server, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rebron, Assigned: BenB)

References

(Depends on 1 open bug)

Details

(Whiteboard: [evangelism])

Attachments

(2 files, 1 obsolete file)

Cox.net is a top missing domain

http://support.cox.com/sdccommon/asp/contentredirect.asp?sprt_cid=fcb44db0-3835-491c-bca8-2d56ac32a574

Has location based settings, west vs east
> Has location based settings, west vs east

Perfect!

Is there a config which always works: west, east, outside of their network? We need that, otherwise we can't add them to the DB.
They'd have to support TB with an autoconfig server which resolves this based on the username.
Can somebody please get a high-level technical contact (not end-user hotline) at cox?
It seems that 

>You can receive your Cox.net e-mail messages by using Outlook from most places >with an Internet connection. However, to send e-mail messages, you must be >connected directly to the Cox.net service or use an alternate SMTP e-mail server >on the service you are using at that location

http://office.microsoft.com/en-us/outlook/ha010962641033.aspx

Probably can't add to DB.
Sorry for previous post format. I retry:

It seems that 

>You can receive your Cox.net e-mail messages by using Outlook from most places 
>with an Internet connection. However, to send e-mail messages, you must be 
>connected directly to the Cox.net service or use an alternate SMTP e-mail 
>server on the service you are using at that location

http://office.microsoft.com/en-us/outlook/ha010962641033.aspx

Probably can't add to DB.
Whiteboard: [evangelism]
OK, changing to advocacy bug.

They'd have to support TB with an autoconfig.cox.net server which resolves this based on the username.
That's fairly trivial to implement.
See <https://developer.mozilla.org/en/Thunderbird/Autoconfiguration_in_Thunderbird#Configurating_a_server_at_an_ISP> for preliminary documentation (draft, subject to be moved, too)
Summary: Add cox.net → [Advocacy] Make cox.net implement autoconfig server
No longer depends on: 554843
Blocks: 556267
Does the SMTP server refuse connections from other networks? Only then should it block bug 556267.
No longer blocks: 556267
See bug 564043 custom fields as an alternative solution.
Depends on: 564043
Unencrypted password fishing:
http://cslyon.net/2010/07/21/mozilla-summit-are-we-secure/
"Most seen server: pop.west.cox.net"
Blocks: 594665
Duplicate of this bug: 596430
Component: ispdb → ISPDB Server
Product: Mozilla Messaging → Webtools
Hi,

I manage the Cox.net e-mail platform for Cox's Residential customers. I thought we had submitted a config file for the ISPDB some time ago. Since 2010, we have switched to use "pop.cox.net", "smtp.cox.net" and "imap.cox.net" from geographically-based service names. I have a configuration file I can submit, but was wondering whether I should create a new ticket.

Thanks.

Kevin Serikstad
Please add it here.
Kevin,
I manage the ISP DB. I'm happy to hear from you, and that the config is now a lot easier. Thank you!

Yes, if you have a config file, please attach it. It's important for us that it uses SSL for all servers. Add both POP3 and IMAP servers, whereby IMAP should be listed first.
The config file entries will appear in the next comment.
<?xml version="1.0" encoding="UTF-8"?>


<clientConfig version="1.1">
 <emailProvider id="cox.net">
  <domain>cox.net</domain> 
  <displayName>Cox</displayName> 
  <displayShortName>Cox</displayShortName> 
  <incomingServer type="imap">
    <hostname>imap.cox.net</hostname> 
    <port>993</port> 
    <socketType>SSL</socketType> 
    <username>%EMAILLOCALPART%</username> 
    <authentication>password-cleartext</authentication> 
  </incomingServer>
  <incomingServer type="pop3">
    <hostname>pop.cox.net</hostname> 
    <port>995</port> 
    <socketType>SSL</socketType> 
    <username>%EMAILLOCALPART%</username> 
    <authentication>password-cleartext</authentication> 
    <pop3>
     <leaveMessagesOnServer>true</leaveMessagesOnServer> 
    </pop3>
  </incomingServer>
  <outgoingServer type="smtp">
   <hostname>smtp.cox.net</hostname> 
   <port>587</port> 
   <socketType>STARTTLS</socketType> 
   <username>%EMAILLOCALPART%</username> 
   <authentication>password-cleartext</authentication> 
   </outgoingServer>
 </emailProvider>
</clientConfig>
kevin can you attach the file please.
Attachment #767271 - Flags: review?(ben.bucksch)
Checking in on the status of this configuration change.

Thanks.

Kevin Serikstad
Comment on attachment 767271 [details]
Autoconfig file for Cox.net Mail Configuration

- <pop3> <leaveMessagesOnServer>true</leaveMessagesOnServer>  </pop3>
  Kevin, are you sure about this? This will get very slow.
- Formally, the config looks fine.
- I have not yet contacted the servers to verify. I'll be on a trip until Monday.
- Kevin, could you provide us a test account (preferably one that's active permanently) ? If not, that's OK, but it's better if we can test it.
- Blake, can you do the other review, please
Attachment #767271 - Flags: review?(bwinton)
Comment on attachment 767271 [details]
Autoconfig file for Cox.net Mail Configuration

I briefly tested the hosts and ports, and they seemed to work.
r=me.

Kevin: To make things a little easier for you if you wanted to make any changes in the future, is there any way you could host the file on a Cox.net server, as described here: https://developer.mozilla.org/en-US/docs/Thunderbird/Autoconfiguration#Configuration_server_at_ISP ?

Thanks,
Blake.
Attachment #767271 - Flags: review?(bwinton) → review+
Duplicate of this bug: 812188
Sorry for the long delay. I've been on vacation.

Review:
* Tested the hosts and ports. They worked and the cert names matched.
* I found that smtp.cox.net:465 with normal SSL also works. I added that, with preference over STARTTLS, based on our policy.
* I am removing the "leave on server", because that's really detrimental to speed over time, and I haven't gotten any justification for it why it should be enabled for cox.net specifically, e.g. that otherwise something would break at cox, e.g. IMAP gets emptied by POP3. (If it's general considerations: If we as Thunderbird project think that "leave on server forever" is better in general, we can change the default for all accounts.)
* I can't test the login, due to lack of test accounts.

Kevin, could you provide a test account? Do you have comments to any of the above?

Thanks for your help!
Attachment #767271 - Flags: review?(ben.bucksch) → review-
Attached file cox.net, v2 (obsolete) —
* Added SMTP normal SSL
* removed POP3 leaveonserver
* fixed whitespace
Assignee: nobody → ben.bucksch
Status: NEW → ASSIGNED
Attachment #804494 - Flags: review?(bwinton)
Attached file cox.net, v3
forgot to save before attaching, sorry.
Attachment #804494 - Attachment is obsolete: true
Attachment #804494 - Flags: review?(bwinton)
Attachment #804497 - Flags: review?(bwinton)
Comment on attachment 804497 [details]
cox.net, v3

Looks good to me, assuming Kevin is happy with it.
Attachment #804497 - Flags: review?(bwinton) → review+
Thanks. With bwinton's approval, I'll commit this now. If we need to make changes based on Kevin's feedback, we can still make another commit.

Commited as SVN Revision 119872
FIXED

Kevin, thanks a lot for designing the cox email servers so that there's only one config instead of geographical differences. It's very important for us to have one config that works in all cases and situations. Thanks a lot for that! And thanks for taking the time to contact us.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Summary: [Advocacy] Make cox.net implement autoconfig server → Add cox.net, now that they have a unified config
You need to log in before you can comment on or make changes to this bug.