duplicate copy of same email created in the inbox

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
2 years ago

People

(Reporter: evandc7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

Duplicate emails are being created in the inbox.  Happened after detaching an attachment from an email.  Happened on other occasions but can't remember what I did.

Reproducible: Sometimes

Steps to Reproduce:
1. open received email
2. detach file attachment
3 [review]. delete email?
Actual Results:  
Thunderbird makes a copy of the email in the inbox.

Expected Results:  
Thunderbird should not have made a duplicate of each email

Seems to happen after detaching a file, in my case a PDF file.  Has happened on other occasions.

Seems like TB is taking a lot of time processing each email when a file is attached.  It takes awhile for TB to switch between emails.
If the detachment didn't "take", then this looks like bug 518891; otherwise, it might be a regression from bug 286655.

If so, and if it's possible for you, it'd be good to get a log using the directions at https://wiki.mozilla.org/MailNews:Logging -- that would help narrow down what's going on here.

Comment 2

8 years ago
I have received a ton of duplicate emails in my box and each case the duplicate email has the same "X-UIDL:" header as the original email. None of my examples involve an attachements.

Comment 3

8 years ago
I am using Thunderbird 3.1 I am having the same problem from yousendit.com. Someone sent me file from yousendit.com 2 days ago and everytime I click Get Mail, and sometimes when I don't, in TB I get more of the same email. Hundreds of them. I have a POP server, I checked the message source of several emails and there is no number after X-UIDL in any of the messages. I have asked the person who sent the file to check with yousendit but they said it wasn't their problem, and it only happens in TB,not my webmail. When the same emails come in, there is the display message in R hand corner of desktop saying that I got a new message but it does not show at the top of my list of incoming messages, however when I look at email list and sort by sender or date I see tons of them. And it has it's original date, even though they just came in.
Can we get logs ?

Comment 5

8 years ago
Requested GS users do logging.  One user in that topic (mk46837?) reported that the offending email was able to be deleted in the "webmail" interface, and the problem went away; sounds like TB's DELE was not completing, but no there was no error indication.

Updated

7 years ago
Whiteboard: [gs] → [gs][dupeme?]

Updated

6 years ago
Component: General → Untriaged

Comment 6

5 years ago
this problem still exits in TB version 17.0.7

server type: pop mail server
server settings: leave messages on server (checked)

email with X-UIDL: <blank> will be repeatedly added to the inbox whenever email is donwloading from the pop mail server. This email is just one copy on the pop mail server, but TB seems cannot handle email with X-UIDL: <blank>.

The workaround to this problem, delete the problem email pop mail server via web interface!

Comment 7

3 years ago
As I understand it, this is often a problem caused by your mail server. Are you still seeing the issue?
Flags: needinfo?(skoo)
Flags: needinfo?(evandc7)
Whiteboard: [gs][dupeme?] → [closeme 2016-02-15][dupeme?]

Comment 8

2 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(skoo)
Flags: needinfo?(evandc7)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-02-15][dupeme?] → [dupeme?]
You need to log in before you can comment on or make changes to this bug.