Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Restore session in background while waiting for an answer to "Set as default browser?" during startup

RESOLVED FIXED

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: teoli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a4pre) Gecko/20100327 Minefield/3.7a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a4pre) Gecko/20100327 Minefield/3.7a4pre

When Firefox is not set as the default browser, but set to check for this, the previous session is not restored while waiting for an answer to the question.

To make startup faster, it could be loaded in the background: that way, once the choice is made by the user they can immediately start using the browser

Reproducible: Always

Steps to Reproduce:
1. Unset Firefox as default browser; be sure it is set to check it at start-up
2. Start Firefox: a modal dialog appears in front of a single blank tab
3. Click OK or Cancel on this modal dialog.

Actual Results:  
The session start being restored

Expected Results:  
The session should start its restoration at step 2, when the modal dialog appears.
Moving to ENHANCEMENT.  Current behaviour of loading a single about:blank tab until the modal dialog is acted upon is as designed.  What the reporter asks for is an enhancement above and beyond the current feature set.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Summary: Session not restored in background while waiting for an answer to "Set as default browser?" during startup. → Restore session in background while waiting for an answer to "Set as default browser?" during startup
This is something that I want. However, I looked into making it happen and when the dialog comes up, all of the restoration just pauses (I think that was the problem).

I agree that the desired behavior should be restoring behind that dialog, but it looks like it's not as easy as I'd hoped, so this will probably fall off the radar for a while. Especially since it's not something that should occur often :/

Updated

7 years ago
Duplicate of this bug: 634296

Comment 4

7 years ago
Still a bug in FF4b11.
As an answer to comment 2, it does not happen often for non-beta testers, however, I've been switching a lot between FF3.6 and FF4b and it was a bit annoying to open the browser, leave my computer, coming back and realizing that nothing had loaded.

It looks like the dialog is a JavaScript "prompt();" which is blocking. Probably that other prompt are in Firefox UI. It might be worth checking.

Should this bug be set as blocking Electrolysis (Bug 516518)?
Duplicate of this bug: 704914
this was fixed by bug 654388
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 654388
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.