Closed Bug 516518 (electrolysis) Opened 10 years ago Closed 7 years ago

Overall Electrolysis Tracking

Categories

(Core Graveyard :: Tracking, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: benjamin, Assigned: benjamin)

References

(Depends on 1 open bug)

Details

(Keywords: meta)

This bug is designed to collect the various Electrolysis projects. Please do not comment in it at all. To ask questions about Electrolysis use the mozilla.dev.tech.dom newsgroup.
Depends on: 516521
Alias: electrolysis
Depends on: 516714
Depends on: e10s
Depends on: 515436
Duplicate of this bug: 493422
Blocks: 515352
No longer blocks: 515352
Duplicate of this bug: 541942
Keywords: meta
OS: Windows NT → All
Hardware: x86 → All
Depends on: 646596
Duplicate of this bug: 392073
Duplicate of this bug: 392073
Duplicate of this bug: 392073
(In reply to comment #0)
> This bug is designed to collect the various Electrolysis projects. Please do
> not comment in it at all. To ask questions about Electrolysis use the
> mozilla.dev.tech.dom newsgroup.
1) Where is the Electrolysis project listed/defined?
2) how do I access the mozilla.dev.tech.dom newgroup.

I used to be able to access
both  news.mozilla.org
and news.mozdev.org, but now I get timeouts on both.

Is it located in one of those places?  Are they publicly connectible or how do I find / access that group?


Thanks!
(In reply to comment #6)
> 1) Where is the Electrolysis project listed/defined?
> 2) how do I access the mozilla.dev.tech.dom newgroup.
> 
> I used to be able to access
> both  news.mozilla.org
> and news.mozdev.org, but now I get timeouts on both.
> 
> Is it located in one of those places?  Are they publicly connectible or how
> do I find / access that group?
> 
> 
> Thanks!

1) https://wiki.mozilla.org/Electrolysis
2) http://groups.google.com/group/mozilla.dev.tech.dom/topics?pli=1
Blocks: 392073
Duplicate of this bug: 677090
Duplicate of this bug: 680038
Duplicate of this bug: 680728
Duplicate of this bug: 453430
Duplicate of this bug: 683701
Blocks: 557228
No longer blocks: 709217
Duplicate of this bug: 712541
Duplicate of this bug: 822481
Duplicate of this bug: 832377
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INCOMPLETE
Okay, so all further improvements were abandoned?
Perhaps under this label, I know that bug #392073, filed in 2006 had been dependent on this, but is now listed as re-opened.

It covered the problem of non-parallel execution of multiple threads which as some have pointed out is likely due to some 'big locks' being held to prevent parallel execution.  Is it 'known' howmany big locks are potential blockers?

Is there any code around the locks to track time spent waiting for each lock?

Instrumenting the code might be the first step to identifying where work needs to be done.
I don't see why we should close this bug now?
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Because we aren't tracking this project any more.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → INCOMPLETE
According to https://wiki.mozilla.org/Electrolysis, the project has been revived. Should this be reopened?
(In reply to replicator.snail from comment #20)
> According to https://wiki.mozilla.org/Electrolysis, the project has been
> revived. Should this be reopened?

I think they are tracking the progress of the Electrolysis project in two new bugs now:
https://bugzilla.mozilla.org/show_bug.cgi?id=fxe10s
https://bugzilla.mozilla.org/show_bug.cgi?id=core-e10s

So this bug should not be reopened.
No longer depends on: 646596
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.