Cannot subscribe to subfolders

RESOLVED DUPLICATE of bug 592633

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED DUPLICATE of bug 592633
8 years ago
7 years ago

People

(Reporter: markham breitbach, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol log])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

After a crash of TB3, some folders were renamed to the maildir directory names and over time some folders mysteriously disappeared from the subscription and others could not be unsubscribed.  After much messing around a fresh install of Thunderbird 3 was performed and all Library and Cache files were removed from old (TB1/TB2) installs.
Now, subfolders are not showing up in the subscribe menu at all.  However, creating a new subfolder causes the subfolders to appear and allow subscription.  This is the case for any folder with sub-folder, regardless of position in the hierarchy. 


Reproducible: Always

Steps to Reproduce:
1.  Install TB3.0.3
2.  Configure mail server and connect.
3.  Open "subscribe" window -- only shows top level folder under INBOX.
4.  Subscribe to a folder with subfolders.
5.  Create a new Subfolder.
6.  Open Subscribe window -- now shows subfolders

Actual Results:  
Subfolders appear under parent of newly created folder and folders can be subscribed.
Subfolders under other folders and sub-sub-folders do not appear.

Expected Results:  
All sub folders should appear in the subscription window.  (as an aside, it would be very useful to have a "select all" type control somewhere.

Server is dovecot 1.1.14 with maildir message store.
We'll need an imap log as described at https://wiki.mozilla.org/MailNews:Logging ?

Updated

8 years ago
Whiteboard: closeme 2010-05-25 [need protocol log]
Version: unspecified → 3.0
Same problem as one of next?
  bug 369964, bug 514106, bug 529244, bug 529618, bug 537298
Or different problem? If so, what is difference of your problem from above bugs?

Comment 3

8 years ago
I can confirm this:
try to subscribe to an rss feed, e.g. 
http://social.answers.microsoft.com/Forums/de-DE/officepptde/threads?outputAs=rss

I can add this ONLY to the root folder "Blogs & Neews-Feeds" and have to move it to the disired folder in the main pane.
This is OSX 10.6.3 and TB 3.0.4
It works as it should on Linux TB 3.1 PRE

Comment 4

7 years ago
I recorded a log and grepped the relevant lines. The regex matches the folder hierarchy that shows the problem in Thunderbird 3.0.5: only teach.dbp is shown but none of the folders under teach.dbp. E.g. 06s is not shown in the folder list in the subscription window even though it seems like the folder is transmitted by the server.

Here is the log snippet

user@host$ grep "teach\.dbp" /tmp/imap.log 
1499461392[7f50597ab590]: 597e4000:imap.example.com:A:CreateNewLineFromSocket: * LSUB () "." "teach.dbp"
1478444816[7f50597abf20]: 5962d800:imap.example.com:A:CreateNewLineFromSocket: * LSUB () "." "teach.dbp"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LSUB () "." "teach.dbp"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp.06s"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp.07s"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp.08s"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp.08w"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp.09w"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasNoChildren) "." "teach.dbp.mailto"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LSUB () "." "teach.dbp"
1429206800[7f50597ac030]: 55c5a800:imap.example.com:S-sys.cvs:CreateNewLineFromSocket: * LIST (\HasChildren) "." "teach.dbp"

Comment 5

7 years ago
are imap and rss subscription sufficiently similar for these to be the same bug?
Whiteboard: closeme 2010-05-25 [need protocol log] → [has protocol log]
(Reporter)

Comment 6

7 years ago
This issue appears to be resolved in 3.1.1
Problem with IMAP is being processed by bug 592633 and patch has been proposed. It may not resolve RSS case. Watch bug 592633, please.
Setting dependency to bug 592633 for ease of tracking and search.
Depends on: 592633

Comment 8

7 years ago
Here is how it works with 3.1.4 as shipped with Ubuntu 10.10:

Right-click on the folder pane, select "subscribe" from the pop-up menu.

Some folders appear.

When I descend into deeper levels of the hierarchy, some subfolders don't appear at first. Let's say, in a folder "X", there is a subfolder "Y" that actually has 10 subfolders itself. Only Y would show up. When I collaps the sub-tree of X and reopen it again, Y magically now has an arrow icon next to it, indicating it has subfolders. Opening it, the subfolders appear. But behold! One of the subfolders of Y (say "A") should have even more subfolders. But no arrow icon whatsoever. Play the same trick again: collaps Y and expand again: A has an arrow icon and shows its subfolders when expanded.


I just retested this with 3.0.8: it shows the same behavior. In other words: the same workaround works here, too. 

If you ask me, this is far from being fixed. The subfolders should appear without a workaround.

Comment 9

7 years ago
Addendum: it seems like the bug with the subfolders not displaying at first only occurs at IMAP folders of depth > 2. So if anybody tries to repro this, create a deep folder tree or else you probably won't find anything.

Comment 10

7 years ago
This is a dup of bug 592633. We have a fix, but it requires a chance to core gecko, and I have not been given permission to check the fix in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592633
You need to log in before you can comment on or make changes to this bug.