Closed Bug 556540 Opened 12 years ago Closed 3 months ago

Fullscreen video doesn't seem to be accelerated at all (doesn't perform any faster than with software rendering)

Categories

(Core :: Widget, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dao, Unassigned)

References

Details

See bug 555839 comment 9 and bug 555839 comment 10.

Radeon X1200 is on Windows 7, GMA 945 on XP.
The video is being drawn using hardware. I suspect our use of FBOs in the container weight quite heavily on a lot of systems though. We will optimize this to fix the issue, but right now bug 555727 is preventing me from running/profiling optimized builds. Meaning I need to get that out of the way before I can investigate further/attempt fixes.
It most likely is hardware accelerated, but hardware acceleration was probably performing poorly. With bug 556584 fixed you should be seeing great improvements! If this still doesn't work, we need to investigate further. Closing for now.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Well, if it's fixed we should mark it fixed or a duplicate of bug 556584 rather than invalid. I'll test with the next nightly.

Note that I didn't mean to say there was no hardware acceleration. It just appeared as if there was none, as there was no improvement in playback performance or CPU usage.
Status: RESOLVED → REOPENED
Depends on: 556584
Resolution: INVALID → ---
Summary: Fullscreen video doesn't seem to be accelerated at all → Fullscreen video doesn't seem to be accelerated at all (doesn't perform any faster than with software rendering)
Neither CPU usage nor the perceived performance seem better with the current nightly. I'm testing http://commons.wikimedia.org/wiki/File:Nikon_D300s_Test_Video_02.ogv with the Intel chip on XP. When going full screen, one CPU jumps from 40-50% to 80-90% workload.
FYI, Intel GMA 945 (the Onboard-Chip of many Netbooks) doesn't have any OpenGL 2.x driver for Windows, merely 1.4
So no Video nor WebGL Acceleration with this chip (blame Intel).
As for the ATI chip, attempting to play a video fullscreen just hangs Firefox as of April 2.
(In reply to comment #6)
> As for the ATI chip, attempting to play a video fullscreen just hangs Firefox
> as of April 2.

Meaning you're unable to get to the Error console to check specs? Could this actually just be drawing -very- slowly and never getting a single frame through?
When is the console output expected to appear?
The Error Console should show something like:

OpenGL LayerManager Initialized Succesfully.
Version: 3.0.0
Vendor: NVIDIA Corporation
Renderer: GeForce GT 230M/PCI/SSE2
When going fullscreen or when starting Firefox? Does it also output something if the initialization failed?
(In reply to comment #10)
> When going fullscreen or when starting Firefox? Does it also output something
> if the initialization failed?

When going fullscreen, it should show nothing if initialization failed.
FWIW I see: 

OpenGL LayerManager Initialized Succesfully.
Version: 3.2.9551 Compatibility Profile Context
Vendor: ATI Technologies Inc.
Renderer: ATI Radeon HD 3200 Graphics
(In reply to comment #7)
> (In reply to comment #6)
> > As for the ATI chip, attempting to play a video fullscreen just hangs Firefox
> > as of April 2.
> 
> Meaning you're unable to get to the Error console to check specs? Could this
> actually just be drawing -very- slowly and never getting a single frame
> through?

I'm not sure about that, I'll see if I can figure it out.

With the Intel chip I don't see any console message, but based on comment 5, that would be expected. I guess the D3D9 backend will help here.
I'm getting slow slow ogg videos even without fullscreen.

OpenGL LayerManager Initialized Succesfully.
Version: 3.2.9704 Compatibility Profile Context
Vendor: ATI Technologies Inc.
Renderer: ATI Radeon HD 5800 Series
(In reply to comment #14)
> I'm getting slow slow ogg videos even without fullscreen.
> 
> OpenGL LayerManager Initialized Succesfully.
> Version: 3.2.9704 Compatibility Profile Context
> Vendor: ATI Technologies Inc.
> Renderer: ATI Radeon HD 5800 Series

You're not getting that message without fullscreen correct?

If it's slow without fullscreen that should not be because of OpenGL layers.
I only get the messages with Fullscreen.  Here's a couple of videos.

Plays like 1 frame every 5 seconds in regular mode and fullscreen:
http://commons.wikimedia.org/wiki/File:Nikon_D300s_Test_Video_02.ogv

This plays as if slow motion but maybe it is:
http://www.elphel.com/3fhlo/samples/333_samples/j0011_5.ogg
Seems like it's taking way to long buffering.
It's writing the whole video into moz video cache in my temp folder.  After it's all in the cache the video plays smoothly. But it takes way too long to fill the cache.  I have a 100mb/s download pipe and my temp file is on a SSD.
(In reply to comment #13)
> > > As for the ATI chip, attempting to play a video fullscreen just hangs Firefox
> > > as of April 2.
> > 
> > Meaning you're unable to get to the Error console to check specs? Could this
> > actually just be drawing -very- slowly and never getting a single frame
> > through?
> 
> I'm not sure about that, I'll see if I can figure it out.

Firefox completely hogs one CPU core, but does Win7 have a generic way to tell if the GPU is busy? Should it be busy if your assumption is accurate?
Blocks: 556547
(In reply to comment #19)
> (In reply to comment #13)
> > > > As for the ATI chip, attempting to play a video fullscreen just hangs Firefox
> > > > as of April 2.
> > > 
> > > Meaning you're unable to get to the Error console to check specs? Could this
> > > actually just be drawing -very- slowly and never getting a single frame
> > > through?
> > 
> > I'm not sure about that, I'll see if I can figure it out.
> 
> Firefox completely hogs one CPU core, but does Win7 have a generic way to tell
> if the GPU is busy? Should it be busy if your assumption is accurate?
Not really a generic way, if my assumption is accurate. The CPU would be very busy since I suspect it's emulating certain functionality in software.
Status: REOPENED → RESOLVED
Closed: 12 years ago3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.