Last Comment Bug 556686 - [Debug Windows SeaMonkey 2.1] mochitest-chrome: the 3 layout/base/tests/chrome/test_printpreview*.xul time out
: [Debug Windows SeaMonkey 2.1] mochitest-chrome: the 3 layout/base/tests/chrom...
Status: VERIFIED FIXED
[fixed by bug 492476]
:
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: Trunk
: x86 Windows Server 2003
: -- major (vote)
: mozilla1.9.3a5
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 407080 492476 501100
Blocks: SmTestFail 396024 482976
  Show dependency treegraph
 
Reported: 2010-04-01 21:38 PDT by Serge Gautherie (:sgautherie)
Modified: 2010-05-02 07:29 PDT (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.5-fixed
.10-fixed


Attachments
(Av1) Bug 501100 follow-up: s/DIRS/PARALLEL_DIRS/, Clean up remnant comment, Rename them to test_printpreview*.xul [Checkin: Comment 7 & 12] (5.31 KB, patch)
2010-04-12 18:47 PDT, Serge Gautherie (:sgautherie)
roc: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2010-04-01 21:38:23 PDT
+++ This bug was initially created as a clone of Bug #492476 +++

Not sure when this started. (When SeaMonkey switched to packaged tests??)

{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1270171828.1270175140.31022.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2010/04/01 18:30:28

7125 INFO Running chrome://mochikit/content/chrome/layout/base/test/chrome/test_bug396024.xul...
JavaScript error: data:text/html;charset=utf-8,<body%20onload='window.parent.loadedChild()'>, line 1: window.parent.loadedChild is not a function
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/widget/src/xpwidgets/nsPrintOptionsImpl.cpp, line 1107
JavaScript error: chrome://mochikit/content/chrome/layout/base/test/chrome/bug396024_helper.xul, line 72: todo is not defined
7126 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/layout/base/test/chrome/test_bug396024.xul | Test timed out.

7134 INFO Running chrome://mochikit/content/chrome/layout/base/test/chrome/test_bug482976.xul...
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/content/base/src/nsContentUtils.cpp, line 2814
JavaScript error: data:text/html;charset=utf-8,<body%20onload='window.parent.loadedChild()'><q>, line 1: window.parent.loadedChild is not a function
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/widget/src/xpwidgets/nsPrintOptionsImpl.cpp, line 1107
JavaScript error: chrome://mochikit/content/chrome/layout/base/test/chrome/bug482976_helper.xul, line 71: todo is not defined
7135 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/layout/base/test/chrome/test_bug482976.xul | Test timed out.

7149 INFO Running chrome://mochikit/content/chrome/layout/base/test/chrome/test_printpreview.xul...
WARNING: getting z level of unregistered window: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/xpfe/appshell/src/nsWindowMediator.cpp, line 606
WARNING: getting z level of unregistered window: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/xpfe/appshell/src/nsWindowMediator.cpp, line 606
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x8000FFFF: file e:/builds/slave/comm-central-trunk-win32-debug/build/mozilla/widget/src/xpwidgets/nsPrintOptionsImpl.cpp, line 1107
JavaScript error: chrome://mochikit/content/chrome/layout/base/test/chrome/printpreview_helper.xul, line 68: todo is not defined
7150 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/layout/base/test/chrome/test_printpreview.xul | Test timed out.
}
Comment 1 Serge Gautherie (:sgautherie) 2010-04-10 16:44:27 PDT
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a5pre) Gecko/20100410 SeaMonkey/2.1a1pre] (comm-central-trunk-win32/1270896177)

The whole directory passes on my computer:
{
56 INFO Passed: 37
57 INFO Failed: 0
58 INFO Todo:   0
}

Either it's a Debug build issue or maybe a VM config issue?
Comment 2 Robert Kaiser 2010-04-11 03:24:54 PDT
Did you run this with the debug builds from the packages our VMs upload or with some other builds?
Comment 3 Serge Gautherie (:sgautherie) 2010-04-11 17:43:37 PDT
(In reply to comment #2)

'comm-central-trunk-win32/' are optimized builds.
I can't run current debug builds, due to bug 557060.
The older 2010.03.28 debug build I still have just dies during mochitest-* startup :-/
Comment 4 Robert Kaiser 2010-04-12 03:43:07 PDT
You can't run builds from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/tinderbox-builds/comm-central-trunk-win32-debug/ ? That's bad :(
But I thought this other bug says that you can build your own with that patch from there?
Comment 5 Serge Gautherie (:sgautherie) 2010-04-12 18:18:13 PDT
(In reply to comment #4)
> this other bug says that you can build your own with that patch from there?

I'm not doing local builds to workaround trunk issues.
Comment 6 Serge Gautherie (:sgautherie) 2010-04-12 18:47:08 PDT
Created attachment 438643 [details] [diff] [review]
(Av1) Bug 501100 follow-up: s/DIRS/PARALLEL_DIRS/, Clean up remnant comment, Rename them to test_printpreview*.xul
[Checkin: Comment 7 & 12]
Comment 7 Serge Gautherie (:sgautherie) 2010-04-12 21:09:53 PDT
Comment on attachment 438643 [details] [diff] [review]
(Av1) Bug 501100 follow-up: s/DIRS/PARALLEL_DIRS/, Clean up remnant comment, Rename them to test_printpreview*.xul
[Checkin: Comment 7 & 12]


http://hg.mozilla.org/mozilla-central/rev/d152d55d4a43
Comment 8 Serge Gautherie (:sgautherie) 2010-04-13 20:36:35 PDT
(In reply to comment #1)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a5pre) Gecko/20100410
> SeaMonkey/2.1a1pre] (comm-central-trunk-win32/1270896177)
> 
> The whole directory passes on my computer:

I ran the 3 tests separately; they pass but the Error Console has a log:
{
// printpreview_helper.xul
Error: document.body.firstChild.nextSibling is null
Source File: chrome://mochikit/content/chrome/layout/base/test/chrome/printpreview_helper.xul
Line: 104

// printpreview_bug396024_helper.xul
Error: window.parent.loadedChild is not a function
Source File: data:text/html;charset=utf-8,<body%20onload='window.parent.loadedChild()'>
Line: 1

// printpreview_bug482976_helper.xul
Error: window.parent.loadedChild is not a function
Source File: data:text/html;charset=utf-8,<body%20onload='window.parent.loadedChild()'><q>
Line: 1
}

See at least
http://mxr.mozilla.org/mozilla-central/search?string=loadedChild&case=1&find=%2Flayout%2Fbase%2Ftests%2Fchrome%2F

Flawed code and/or timing issue?
Comment 9 Serge Gautherie (:sgautherie) 2010-04-22 03:11:57 PDT
Eventually, this got fixed by bug 492476 patch Bv1 ;->
These tests were calling an undefined |todo()| :-/

V.Fixed per tinderboxes.

*****

(In reply to comment #8)
> Flawed code and/or timing issue?

I filed bug 561045.
Comment 10 Serge Gautherie (:sgautherie) 2010-04-22 03:23:15 PDT
Fwiw, I didn't check the Firefox boxes,
but, as they didn't fail, I would assume they have a printer set up somehow.
KaiRo, maybe Windows SeaMonkey boxes should have one too?
Comment 11 Robert Kaiser 2010-04-22 05:57:57 PDT
(In reply to comment #10)
> KaiRo, maybe Windows SeaMonkey boxes should have one too?

That's not in the refplatform instructions, and I don't care about "maybe it would be nice to have" unless someone pays a full-time build and release engineer for SeaMonkey.
Comment 12 Serge Gautherie (:sgautherie) 2010-05-02 05:29:43 PDT
Comment on attachment 438643 [details] [diff] [review]
(Av1) Bug 501100 follow-up: s/DIRS/PARALLEL_DIRS/, Clean up remnant comment, Rename them to test_printpreview*.xul
[Checkin: Comment 7 & 12]


http://hg.mozilla.org/releases/mozilla-1.9.2/rev/a721e2c43dd4
Comment 13 Serge Gautherie (:sgautherie) 2010-05-02 07:29:50 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/673cfcdf8da3
(Bv1-191) Bug 407080 follow-up: Clean up remnant comment, Rename them to test_printpreview*.html.

Note You need to log in before you can comment on or make changes to this bug.