[outline]-moz-outline color is invisible with a dark background colored web page. (link,focus,pr0n)

VERIFIED FIXED in mozilla0.9.5

Status

()

defect
P2
major
VERIFIED FIXED
19 years ago
4 months ago

People

(Reporter: jameslariviere, Assigned: attinasi)

Tracking

({access})

Trunk
mozilla0.9.5
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

DESCRIPTION:

-moz-outline color is nearly invisible with a dark background-color in back of a
:link.


STEPS TO REPRODUCE:

click a link in the test case.

ACTUAL RESULTS:

-moz-outline color is dark.  test page is dark.  So, you do not see the outline.

EXPECTED RESULTS:

I think that the -moz-outline color should match the :link:active text color or
at least the color of the :link or default text in the web page.

In IE5, the outline seems to always be white when there is a dark background.
Posted file test case
We should use the 'invert' colour, which we can do once 'outline' is implemented
properly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future
Adding depends on properly implementing css2 outlines.
Depends on: css2outline
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
Status: NEW → ASSIGNED
Summary: -moz-outline color is invisible with a dark background colored web page. → [outline]-moz-outline color is invisible with a dark background colored web page.
*** Bug 73886 has been marked as a duplicate of this bug. ***
Depends on: 73884
Adding fcc508 keyword. This is a crucial accessibility issue, outlined in FCC
Section 508 statutes. US Government agencies cannot legally purchase Mozilla
based products that contain this problem.
Severity: normal → major
Keywords: access, fcc508
Bug 73884 (support 'invert' color for -moz-outline) is fixed now.  Resetting 
target milestone from future: is this easy to fix now, or does it depend on bug 
6647 (full support for CSS2 outline property)?
Target Milestone: Future → ---
Bug 73884 was reopened.

Reassigning to attinasi.  When bug 73884 is fixed, the patch for this bug is very 
simple. In html.css, just change the focus declaration to:

   *|*:-moz-any-link:focus {
      -moz-outline: 1px dotted invert;
   }
Assignee: pierre → attinasi
Status: ASSIGNED → NEW
I had to include duplicate bugs in my query to find this bug.  I'd suggest
adding "focus" and maybe "link" to the summary before porn surfers discover
Mozilla (due to mentions of the dom.disable_open_during_load pref on Slashdot),
wonder why they can't keep their place while middle-clicking links on
http://www.erotica-toon.com/, and file dups.
uh, ok.
Summary: [outline]-moz-outline color is invisible with a dark background colored web page. → [outline]-moz-outline color is invisible with a dark background colored web page. (link,focus,pr0n)
setting this to m9.5, it looks like bug 73884 is getting in under 9.4 and 6647
may not need to be resolved to resolve this issue, see Pierre's patch suggestion
in htis bug.
Priority: P3 → P2
Target Milestone: --- → mozilla0.9.5
bug 73884 is FIXED (on trunk anyway). Marking this one fixed too.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
looks good :-) marking verified.
Status: RESOLVED → VERIFIED
Continuation:
bug 111526, "link focus outline (invert) invisible on gray backgrounds".
You need to log in before you can comment on or make changes to this bug.