If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 6647 (css2outline)

CSS2 'outline' property

VERIFIED DUPLICATE of bug 281972

Status

()

Core
CSS Parsing and Computation
P3
enhancement
VERIFIED DUPLICATE of bug 281972
19 years ago
4 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: roc)

Tracking

(Depends on: 2 bugs, Blocks: 2 bugs, {access, css2, testcase})

Trunk
Future
access, css2, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P0][Hixie-PF], URL)

(Reporter)

Description

19 years ago
The CSS2 outline property would allow widget focus to be drawn using
spec compliant methods.

There is a test page here:
   http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/outline.html

See bug 1859.
(Reporter)

Updated

19 years ago
Priority: P3 → P5

Updated

19 years ago
Assignee: peterl → karnaze
Component: Style System → Widget Set

Comment 1

19 years ago
The property data is ready for use in the style context.

Updated

19 years ago
Assignee: karnaze → pierre

Comment 2

19 years ago
Reassigning to Pierre.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 3

19 years ago
*** Bug 7291 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 1859

Comment 4

19 years ago
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.
This should be implemented for frames in general. It is not a form element
specific bug. The CSS border rendering code needs to be modified to include
support for rendering the outline border.

Updated

18 years ago
Target Milestone: M9 → M11

Comment 6

18 years ago
I'm leaving 3 weeks on vacation. Pushing M9 bugs to M11.
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

18 years ago
*** This bug has been marked as a duplicate of 9816 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Verified dup of #9816

Comment 9

17 years ago
Since bug 9816 turned into the 'remove CSS2 for FCS' bug, and is already 
littered with comments, I think we should make this the bug for FUTURE support 
of the 'outline' property.

Ian's comments from bug 9816 about remaining issues:

1. It appears that we don't support 'dotted' and 'dashed' outline-styles at all.
   This is wrong, IIRC we should treat them as 'solid' if we are not able to
   actually treat them as dotted or dashed styles (BUT I MAY BE WRONG THIS NEEDS
   TO BE CHECKED!!!).

2. We do not appear to support the 'invert' outline-color.

3. We have major drawing errors with inset and outset outline-styles.

4. We have some odd, annoying repaint problems (as I understand it, this is
   quite a major problem code-wise). This is bug 9809, marked Future, mostfreq.

5. We interpret 'groove' and 'ridge' the wrong way round.

6. We do not support outline on inline elements (the main use of outline!!!)

7. We draw the outline in the wrong place (as far as I can tell?).

8. According to bug 22892, we don't do 'outline' on XUL -- which I would 
   guess is one of the major uses of outline as far as we are concerned
Severity: enhancement → normal
Status: VERIFIED → REOPENED
Keywords: css2
Priority: P5 → P3
Resolution: DUPLICATE → ---
Target Milestone: M11 → Future
(Reporter)

Updated

17 years ago
Summary: CSS2 'outline' property → CSS2 'outline' property [outline]
(Reporter)

Comment 10

17 years ago
Taking QA per managerial policy.
(Reporter)

Updated

17 years ago
QA Contact: chrisd → py8ieh=bugzilla

Updated

17 years ago
Blocks: 57270

Updated

17 years ago
Blocks: 55676

Comment 11

17 years ago
*** Bug 67966 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: CSS2 'outline' property [outline] → [outline]CSS2 'outline' property

Updated

17 years ago
Status: REOPENED → ASSIGNED

Updated

17 years ago
Blocks: 53927

Updated

17 years ago
Blocks: 58456

Updated

17 years ago
Depends on: 9809
(Reporter)

Updated

17 years ago
Severity: normal → enhancement
(Reporter)

Comment 12

17 years ago
Nominating this bug for nsbeta1 on behalf of gerardok@netscape.com.
Keywords: nsbeta1
(Reporter)

Updated

17 years ago
Whiteboard: [Hixie-PF]

Comment 13

17 years ago
--> Style System (which may not be correct, but this sure ain't a Form Controls bug)
Component: HTML Form Controls → Style System

Updated

16 years ago
Keywords: access, fcc508

Updated

16 years ago
Blocks: 104166
(Reporter)

Updated

16 years ago
Whiteboard: [Hixie-PF] → [Hixie-P0][Hixie-PF]

Updated

16 years ago
Blocks: 113220
Keywords: nsbeta1
To implement we would need to be able to draw to the outside of the frame. This
would require some major modifications.
Marking nsbeta1-.
Keywords: nsbeta1 → nsbeta1-
Depends on: 133165

Updated

16 years ago
No longer blocks: 58456

Updated

16 years ago
Depends on: 110143

Updated

16 years ago
Depends on: 151375
Assigning pierre's remaining Style System-related bugs to myself.
Assignee: pierre → dbaron
Status: ASSIGNED → NEW
Blocks: 22892

Updated

15 years ago
Blocks: 92286

Comment 16

15 years ago
Just curious: why does -moz-outline work, but the standard outline does not?
They have the same effect as far as I can tell.

Comment 17

15 years ago
Jerry: The reasons are listed in comment #9. This feature is just not ready for
the prime time. 

Sorry for the spam.
9. We don't merge outlines for inline elements correctly (bug 133165)

Comment 19

15 years ago
*** Bug 189464 has been marked as a duplicate of this bug. ***
Depends on: 21354
Taking.
Assignee: dbaron → roc+moz
*** Bug 21354 has been marked as a duplicate of this bug. ***

Comment 22

14 years ago
seems like the current -moz-outline is rendered inside the border but the web
standards outline property should be rendered over the border.

Updated

14 years ago
Alias: outline
Keywords: testcase
Summary: [outline]CSS2 'outline' property → CSS2 'outline' property

Updated

14 years ago
Blocks: 110143
No longer depends on: 110143

Updated

14 years ago
Keywords: nsbeta1-

Comment 23

14 years ago
It's worth pointing out that this property is in the default HTML 4.0 stylesheet
(*:focus). Hence, Moz should support it at least enough that a designer can
manipulate the default setting or turn it off.

Updated

13 years ago
Blocks: 151375
No longer depends on: 151375
Depends on: 250269

Updated

13 years ago
No longer blocks: 151375
Depends on: 151375

Updated

13 years ago
Depends on: 111526

Updated

13 years ago
Keywords: sec508

Updated

13 years ago
Flags: blocking-aviary1.0?

Updated

13 years ago
Flags: blocking-aviary1.0?

Comment 24

13 years ago
*** Bug 22892 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Depends on: 266122

Comment 25

13 years ago
-moz-outline-offset is now implemented
Negative offsets are allowed

Updated

13 years ago
Depends on: 269212

Updated

13 years ago
Depends on: 269213

Updated

13 years ago
No longer depends on: 269213

Updated

13 years ago
No longer blocks: 110143
Depends on: 110143
I think we're ready to turn this on with the real 'outline' name. I will write a
style system patch to do that.
Status: NEW → ASSIGNED
See bug 93156 for the aliasing stuff I did for -moz-opacity, which you'll want
here as well, I suspect.
It looks like Mats did this in bug 281972.
Yep. Thanks mats!

*** This bug has been marked as a duplicate of 281972 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

8 years ago
Alias: outline → css2outline
You need to log in before you can comment on or make changes to this bug.