Closed Bug 557114 Opened 10 years ago Closed 10 years ago

enable crash reporting on Fennec builds on Maemo

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec1.1+)

VERIFIED FIXED
Tracking Status
fennec 1.1+ ---

People

(Reporter: ted, Assigned: ted)

References

Details

Attachments

(2 files)

There are just a few things remaining that would block enabling crash reporting on Maemo Fennec builds.
This patch should be all we need, when we're ready.
Assignee: nobody → ted.mielczarek
Status: NEW → ASSIGNED
Depends on: 416680
Depends on: 558335
Comment on attachment 437936 [details] [diff] [review]
enable crashreporter on Fennec builds

Once bug 557113 lands we should be able to do this. I don't know if you want to block on the branding bug or not. For trunk builds it won't matter, but for a release it will (we'll still say "Fennec" in the crash reporter).
Attachment #437936 - Flags: review?(mark.finkle)
Comment on attachment 437936 [details] [diff] [review]
enable crashreporter on Fennec builds

>diff --git a/app/application.ini b/app/application.ini

>+[Crash Reporter]
>+#if MOZILLA_OFFICIAL
>+Enabled=1
>+#endif
>+ServerURL=https://crash-reports.mozilla.com/submit

I'm not sure how MOZILLA_OFFICIAL gets set. We currently use #ifdef MOZ_OFFICIAL_BRANDING in a few places.

I guess we need to add:
export MOZILLA_OFFICIAL=1

to the mobile release mozconfig:
http://hg.mozilla.org/build/buildbot-configs/file/daec2af2f26b/mozilla2/linux/mobile-browser/release/mozconfig

like Firefox desktop does:
http://hg.mozilla.org/build/buildbot-configs/file/daec2af2f26b/mozilla2/linux/mozilla-1.9.2/release/mozconfig#l19

As Ted mentions, we should wait for bug 557113 before landing this.
Attachment #437936 - Flags: review?(mark.finkle) → review+
After thinking a bit, adding this the the nightly mozconfig is a good first step. Desktop Firefox does this too:
http://hg.mozilla.org/build/buildbot-configs/file/daec2af2f26b/mozilla2/linux/mozilla-1.9.2/nightly/mozconfig#l19
(In reply to comment #2)
> I don't know if you want to
> block on the branding bug or not. For trunk builds it won't matter, but for a
> release it will (we'll still say "Fennec" in the crash reporter).

If I had to pick, I would rather say "Firefox" all the time, rather than "Fennec". I don't know if this is a copyright problem though.
Desktop Firefox currently does that, because we use the value from application.ini. If you want to hardcode some strings in crashreporter-override.ini that's fine with me, then we won't be blocked on the branding bug.
Depends on: 562968
Shifting the branding dependency to bug 562969, we can get away with enabling it in nightlies for now without that.
No longer depends on: 416680
Doesn't make much sense to enable this without bug 557572, since we won't get useful crash reports without symbols.
Depends on: 557572
Blocks: 562969
tracking-fennec: --- → 1.1+
Pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/c49411e9715e
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Summary: enable crash reporting on Maemo builds → enable crash reporting on Fennec builds
Bah, this wasn't sufficient. Needs to be stuck in DEFINES as well:
http://mxr.mozilla.org/mozilla-central/source/browser/app/Makefile.in#275
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Add to DEFINESSplinter Review
Stupid.
Attachment #446501 - Flags: review?(mark.finkle)
Attachment #446501 - Flags: review?(mark.finkle) → review+
Pushed the second patch to m-b:
http://hg.mozilla.org/mobile-browser/rev/cb2ce50de901
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Can someone point me to a testcase where i can crash fennec to test this fix?  I've at least verified that about:crashes now exists.

This is on Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2.5) Gecko/20100603 Firefox/3.6.5pre Fennec/1.1
There's a "crash me now" that works, but you can't currently install it in Fennec branch builds. The easiest way to test this is to run Fennec, then find the PID using ps -ef | grep fennec, then kill -ABRT <pid>.
Thanks Ted.  crash reporting works on the client.  however, i didnt see the entry appear on crash-stats.mozilla.com.  is the web server side working?
Status: RESOLVED → VERIFIED
(In reply to comment #15)
> Thanks Ted.  crash reporting works on the client.  however, i didnt see the
> entry appear on crash-stats.mozilla.com.  is the web server side working?

Nevermind, it just appeared.  Just took an extra minute.
Flags: in-litmus?
Just tried this on trunk (after f10s merge), and it seems the crash reporter doesnt show up anymore. Used steps from comment 14 to kill it.

reopening until someone can confirm its still fixed?

Using: Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre)
Gecko/2010701 Namoroka/4.0b2pre Fennec/2.0a1pre
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Tony, this was verified and it was working. Since this is a regression, we should file a new bug. I'll get to it in a second.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
moving conversation over to bug 576325
Status: RESOLVED → VERIFIED
Assigning to self to create a litmus testcase.
Assignee: ted.mielczarek → tchung
(In reply to comment #20)
> Assigning to self to create a litmus testcase.

The assignee field is only for the developer who wrote the patch.
Assignee: tchung → ted.mielczarek
We talked about this on irc with blassey and ted. We're experimenting.
Flags: in-litmus? → in-litmus?(tchung)
Added litmus test: https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=12937.  changing title to reflect Maemo fix only.
Flags: in-litmus?(tchung) → in-litmus+
Summary: enable crash reporting on Fennec builds → enable crash reporting on Fennec builds on Maemo
You need to log in before you can comment on or make changes to this bug.