Latest Minefield bounces a second dock icon for several minutes

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre

Installed the latest Minefield build.  It launches a second dock icon (with no associated window) that bounces for several minutes.  Quitting from either dock icon quits the brower.  Only happens with the latest daily build.

Reproducible: Always

Steps to Reproduce:
1.  Update to latest Minefield build (works with both complete download or incremental)

2.  Launch Minefield (works
3.  A second Minefield dock icon appears and bounces constantly for several minutes.  Restarting Minefield does not help.
Actual Results:  
A second Minefield dock icon appears and bounces constantly.

Expected Results:  
One icon.  Only bounces on launch.
Not a core thing yet, we need more details to see if it is core.
Component: General → General
Product: Core → Firefox
QA Contact: general → general
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
What details do you need?
So, you currently have an icon pinned to the dock? Then you click on it, and a different icon comes up? Does it happen in firefox safe mode? http://support.mozilla.com/en-US/kb/Safe+mode
(Reporter)

Comment 5

9 years ago
Yes, it occurs in safe mode as well.

Yes, I have it pinned to the dock.  A second icon comes up and bounces for a very long time.

Comment 6

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre

Same problem here.

The existing icons remains and shows that Firefox is running, however, a second icon appears at the of the existing icon lists in the Dock and shows Firefox running as well. The latter icon shows the 'quit immediately' dialogue as if Firefox had crashed (although it is actually running smoothly, normal quitting is possible via the existing icon).

Comment 7

9 years ago
That second minefield icon comes from the first steps of the Out-of-Process-Plugins implementation.

Do you have dom.ipc.plugins.enabled set to true in about:config ? (default is false - weird that it shows up with the default settings)

bug 557225 should make the second icon go away.
(Reporter)

Comment 8

9 years ago
Nope.  dom.ipc.plugins.enabled is set to false.

Comment 9

9 years ago
dom.ipc.plugins.enabled is set to false.

Comment 10

9 years ago
(In reply to comment #7)
> That second minefield icon comes from the first steps of the
> Out-of-Process-Plugins implementation.
> 
> Do you have dom.ipc.plugins.enabled set to true in about:config ? (default is
> false - weird that it shows up with the default settings)

The pref doesn't have to be set on Mac OS X 10.6 for Flash running as OOPP since bug 556092 landed.

Comment 11

9 years ago
Please let me know if I can provide any information to fix this annonying problem.

Comment 12

9 years ago
If you run "ps -ax" in terminal while the second dock icon is visible do you see something like this, with a path to 'plugin-container'?

$ ps ax | grep Flash
22009   ??  S      0:00.11 /Applications/Minefield.app/Contents/MacOS/plugin-container /Library/Internet Plug-Ins/Flash Player.plugin 22007 plugin
22017 s000  U+     0:00.00 grep Flash

If you see that then this is a duplicate of bug 557225.

dom.ipc.plugin.enabled doesn't necessarily mean plugins won't run out of process.
(Reporter)

Comment 13

9 years ago
It shopped showing up after two or three new builds...

Comment 14

9 years ago
(In reply to comment #12)
> If you run "ps -ax" in terminal while the second dock icon is visible do you
> see something like this, with a path to 'plugin-container'?
> 
> $ ps ax | grep Flash
> 22009   ??  S      0:00.11
> /Applications/Minefield.app/Contents/MacOS/plugin-container /Library/Internet
> Plug-Ins/Flash Player.plugin 22007 plugin
> 22017 s000  U+     0:00.00 grep Flash
> 
> If you see that then this is a duplicate of bug 557225.
> 
> dom.ipc.plugin.enabled doesn't necessarily mean plugins won't run out of
> process.

ps ax | grep Flash
23061   ??  S      0:00.16 /Applications/Minefield.app/Contents/MacOS/plugin-container /Library/Internet Plug-Ins/Flash Player.plugin 23049 plugin
23162 s000  U+     0:00.00 grep Flash
moon:~ test$ 

OK, looks like a duplicate.

Updated

9 years ago
Duplicate of this bug: 562696

Comment 16

6 years ago
WFM per comment 13
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.