Last Comment Bug 557890 - Update Google search plugin suggestion URLs
: Update Google search plugin suggestion URLs
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Matthew N. [:MattN] (PTO Jun. 29-30)
:
Mentors:
Depends on:
Blocks: 1039003 1039004
  Show dependency treegraph
 
Reported: 2010-04-07 13:24 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2014-07-20 10:04 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.71 KB, patch)
2010-04-07 13:35 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Review
v.1 patch for suggest URL w/o dependency (2.73 KB, patch)
2012-03-01 17:09 PST, Matthew N. [:MattN] (PTO Jun. 29-30)
gavin.sharp: review+
Details | Diff | Review
v.1 patch for suggest params rebased with HTTPS (2.72 KB, patch)
2012-03-16 18:46 PDT, Matthew N. [:MattN] (PTO Jun. 29-30)
gavin.sharp: review+
Details | Diff | Review
mobile patch for removed suggest params (3.52 KB, patch)
2012-03-29 13:57 PDT, Matthew N. [:MattN] (PTO Jun. 29-30)
mark.finkle: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2010-04-07 13:24:04 PDT
See bug 511017 comment 17, and subsequent comments. These changes will depend on the patch in bug 557665.

There's no need to delay these changes on the changes in bug 511017, so I'm splitting it out.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-04-07 13:35:55 PDT
Created attachment 437651 [details] [diff] [review]
patch

This is a patch on top of the patch for bug 557665.

It makes the following changes:
- changes the suggest URL from suggestqueries.google.com to clients1.google.com
- removes the "hl" parameter from the suggest URL
- adds the "client" parameter to the <SearchForm> URL (the URL used for empty location bar searches). This URL behaves the same way as it does in the normal search URL (client="firefox-a" for builds that ship Google as the default selected engine, client="firefox" otherwise)
- adds the "rls" parameter to the <SearchForm> URL. It also behaves the same way as it does in the normal search URL.

This means that for official Firefox en-US builds (as shipped by MoCo), the URLs used will be:

Suggest:
http://clients1.google.com/complete/search?client=firefox&q={searchTerms}
SearchForm:
http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official
Search:
http://www.google.com/search?q={searchTerms}&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

(The normal search URL is unchanged by this patch, I just included it for completeness.)
Comment 2 mack 2010-06-10 11:25:09 PDT
+Trystan

Hey guys, any update on this bug? Let us know how we can help.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-06-10 15:49:51 PDT
It's currently blocked on bug 557665 - will try to get some movement there.
Comment 4 mack 2010-06-10 18:12:57 PDT
Thanks Gavin!
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-15 10:57:42 PDT
No progress on bug 557665 yet, but I just realized that that shouldn't actually stop us from making the first two changes:

- change the suggest URL from suggestqueries.google.com to clients1.google.com
- remove the "hl" parameter from the suggest URL

Is this something we should try to push into Firefox 4?
Comment 6 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-01 17:09:21 PST
Created attachment 602209 [details] [diff] [review]
v.1 patch for suggest URL w/o dependency

(Quoting Gavin Sharp (use gavin@gavinsharp.com for email) from comment #5)
> No progress on bug 557665 yet, but I just realized that that shouldn't
> actually stop us from making the first two changes:
> 
> - change the suggest URL from suggestqueries.google.com to
> clients1.google.com
> - remove the "hl" parameter from the suggest URL

I made the above two changes plus removed the "output" parameter since it "is deprecated in favor of just the client param" according to bug 511017 comment 17.
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-01 17:12:51 PST
Comment on attachment 602209 [details] [diff] [review]
v.1 patch for suggest URL w/o dependency

Looks good to me. We'll need to run this by kev for sign-off before landing it.
Comment 8 Mike Graboski 2012-03-14 16:05:10 PDT
For the suggest URL, you should use https://www.google.com instead of clients1.google.com.  It should be fine to use the same top-level domain for search suggest and actual search queries (with different query strings, of course).
Comment 9 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-15 13:31:16 PDT
Sid/Mike, should the hl and output parameters still be removed?
Comment 10 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-16 18:46:50 PDT
Created attachment 606817 [details] [diff] [review]
v.1 patch for suggest params rebased with HTTPS

Rebased on top of bug 633773 and incorporating comment 8.

Kev/Sid, it would be nice for localizers if we can do this change with bug 633773 if it's still wanted.
Comment 11 Mike Graboski 2012-03-29 11:36:10 PDT
Hey guys, the Google search team is ok with Firefox dropping the hl parameter from the suggest URL.  Let me know if you have any questions.
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-29 12:05:11 PDT
Comment on attachment 606817 [details] [diff] [review]
v.1 patch for suggest params rebased with HTTPS

Let's go ahead and land this.
Comment 13 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-29 13:35:23 PDT
(In reply to Mike Graboski from comment #11)
> Hey guys, the Google search team is ok with Firefox dropping the hl
> parameter from the suggest URL.  Let me know if you have any questions.

Note that this also removes the "output" parameter as requested before (see comment 6).

This patch was only for browser/ but I think this change is probably applicable to all Google search plugins so I'll make a patch including the others.
Comment 14 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-29 13:57:48 PDT
Created attachment 610671 [details] [diff] [review]
mobile patch for removed suggest params

Mobile equivalent
Comment 15 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-29 14:01:01 PDT
Comment on attachment 610671 [details] [diff] [review]
mobile patch for removed suggest params

thanks
Comment 16 Matthew N. [:MattN] (PTO Jun. 29-30) 2012-03-29 14:54:44 PDT
https://hg.mozilla.org/integration/fx-team/rev/a78d2f8055e7
Comment 17 Tim Taubert [:ttaubert] 2012-03-30 09:35:14 PDT
https://hg.mozilla.org/mozilla-central/rev/a78d2f8055e7

Note You need to log in before you can comment on or make changes to this bug.