Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 128284
8 years ago
8 years ago

People

(Reporter: Werner F. Bruhin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Request that TB is to support the extended MAPI standard to allow to send a message via TB from third party application.

E.g. a very simple Python script which would allow to send a message.

session = False 
try:
    session = win32com.client.gencache.EnsureDispatch ("MAPI.Session")
except:
    print 'Probably no extended MAPI client installed'
    raise
    return
    
try:
    session.Logon("")

    newMsg = session.Outbox.Messages.Add(subject, message)

    if tos:
        for to in tos:
            newMsg.Recipients.Add(to[0], to[1], mapi.MAPI_TO)
    if ccs:
        for cc in ccs:
            newMsg.Recipients.Add(cc[0], cc[1], mapi.MAPI_CC)
    if bccs:
        for bcc in bccs:
            newMsg.Recipients.Add(bcc[0], bcc[1], mapi.MAPI_BCC)
            
    if attachments:
        for attachment in attachments:
            newMsg.Attachments.Add(attachment)

    newMsg.Send()

    session.DeliverNow()
finally:
    if session:
        # Outlook really dislikes if session is not closed
        session.Logoff()

https://bugzilla.mozilla.org/show_bug.cgi?id=128284 is similar but only talks about connecting to Exchange.



Reproducible: Always
(In reply to comment #0)

> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=128284 is similar but only talks
> about connecting to Exchange.

In the end it's implementing the same thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 128284
You need to log in before you can comment on or make changes to this bug.