Last Comment Bug 559747 - a11y mochitest for <input type="search">
: a11y mochitest for <input type="search">
Status: RESOLVED FIXED
[good first bug][mentor=surkov.alexan...
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Mark Capella [:capella]
:
Mentors:
http://dev.w3.org/html5/spec/forms.ht...
Depends on: 558594 456229 559766
Blocks: html5a11y
  Show dependency treegraph
 
Reported: 2010-04-15 22:45 PDT by alexander :surkov
Modified: 2012-06-07 05:43 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (4.20 KB, patch)
2012-04-25 12:55 PDT, Mark Capella [:capella]
mzehe: review+
surkov.alexander: feedback+
Details | Diff | Splinter Review

Description alexander :surkov 2010-04-15 22:45:55 PDT
It's going to be autocomplete text field, we should expose it with COMBOBOX_ROLE.
Comment 1 alexander :surkov 2010-04-15 23:53:30 PDT
Autocomplete stuffs should be covered by bug 559766
Comment 2 alexander :surkov 2012-02-08 04:35:18 PST
It should be exposed as text entry with autocomplete state now. So all we should do is to add mochitest (add to states/test_inputs at autocomplete testing part and to tree/test_txtctrl.html).
Comment 3 Mark Capella [:capella] 2012-04-25 12:55:32 PDT
Created attachment 618404 [details] [diff] [review]
Patch (v1)

This patch looks like the one we just did for Bug 559759 ... let me know if there's something more to it that I'm missing and I'll address it ...
Comment 4 alexander :surkov 2012-04-25 22:34:42 PDT
Comment on attachment 618404 [details] [diff] [review]
Patch (v1)

Review of attachment 618404 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/tests/mochitest/states/test_inputs.html
@@ +164,5 @@
> +  <a target="_blank"
> +     href="https://bugzilla.mozilla.org/show_bug.cgi?id=559747"
> +     title="Add a11y mochitests for input type=search">
> +    Mozilla Bug 559747
> +  </a>

in general you don't need a bug reference when the bug is about adding a mochitest
Comment 5 Marco Zehe (:MarcoZ) 2012-04-25 23:39:06 PDT
Comment on attachment 618404 [details] [diff] [review]
Patch (v1)

r=me, thanks!

Note that in the long term, I'd like to see us use a new internal role for search inputs. Both mobile operating systems and Mac OS X know about this special input, and we should expose it correctly. But that should be done in a separate bug, since what we have now works on a basic level, and covering it with these tests here is perfect. Thanks for the patch!
Comment 6 alexander :surkov 2012-04-25 23:52:02 PDT
Marco, please file a bug on it. You can make it a good first bug.
Comment 8 Ed Morley [:emorley] 2012-04-27 06:54:56 PDT
https://hg.mozilla.org/mozilla-central/rev/543a22b27d8e

Note You need to log in before you can comment on or make changes to this bug.