Last Comment Bug 559759 - add a11y mochitests for <input type="email">
: add a11y mochitests for <input type="email">
Status: RESOLVED FIXED
[good first bug][mentor=surkov.alexan...
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Mark Capella [:capella]
:
Mentors:
http://dev.w3.org/html5/spec/forms.ht...
Depends on: 555559 559766
Blocks: html5a11y
  Show dependency treegraph
 
Reported: 2010-04-15 23:26 PDT by alexander :surkov
Modified: 2012-04-25 07:41 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (2.92 KB, patch)
2012-04-19 06:55 PDT, Mark Capella [:capella]
mzehe: review+
surkov.alexander: feedback+
Details | Diff | Splinter Review

Description alexander :surkov 2010-04-15 23:26:53 PDT
It's autocomplete text field, we should expose its accessible with COMBOBOX_ROLE and manage invalid state.
Comment 1 alexander :surkov 2010-04-15 23:53:46 PDT
Autocomplete stuffs should be covered by bug 559766
Comment 2 alexander :surkov 2012-02-08 04:34:32 PST
It should be exposed as text entry with autocomplete state now. So all we should do is to add mochitest (add to states/test_inputs at autocomplete testing part and to tree/test_txtctrl.html).
Comment 3 Mark Capella [:capella] 2012-04-19 06:55:29 PDT
Created attachment 616549 [details] [diff] [review]
Patch (v1)

Is that waht you're looking for in this patch?
Comment 4 Mark Capella [:capella] 2012-04-20 07:26:00 PDT
FYI
Bug 559747 - make <input type="search"> accessible mochitests 
affects the same tests as this, i could do them together here, but it looks like theres a depedency tree on that patch going back to Bug 562219 - Implement -moz-appearance: searchfield; for windows widget ...
Comment 5 alexander :surkov 2012-04-23 00:18:25 PDT
Comment on attachment 616549 [details] [diff] [review]
Patch (v1)

(In reply to Mark Capella [:capella] from comment #3)
> Created attachment 616549 [details] [diff] [review]
> Patch (v1)
> 
> Is that waht you're looking for in this patch?

yes

Note You need to log in before you can comment on or make changes to this bug.