[OOPP]Silverlight movie does not start at certain site

RESOLVED DUPLICATE of bug 564861

Status

()

Core
IPC
--
major
RESOLVED DUPLICATE of bug 564861
8 years ago
8 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
rv:1.9.3a5pre) Gecko/20100415 Minefield/3.7a5pre ID:20100415051417
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
rv:1.9.3a5pre) Gecko/20100415 Minefield/3.7a5pre ID:20100415051417

Silverlight4 movie does not start at certain site.
And this also happens on Namoroka/3.6.5pre ID:20100415050153.

If disabled OOPP, the Silverlight 4 start playing.

Silverlight Plug-In  File: npctrl.dll  Version: 4.0.50401.0

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile (enabled OOPP by default)
2. Open http://video.jp.msn.com/watch/video/%E4%B8%8A%E6%88%B8%E5%BD%A9-%E8%83%8C%E4%B8%AD%E3%81%8B%E3%82%89%E3%82%84%E3%81%95%E3%81%97%E3%81%8F%E3%82%AE%E3%83%A5%E3%83%83/af1mjayu
3. Restart browser and go url if necessary.

Actual Results:
 Silverlight 4 video does not start.

Expected Results:
 Silverlight 4 video shoud start.
(Reporter)

Comment 1

8 years ago
I forgot to mention an important thing.

You should set UA to Firefox/3.6.3.
user_pref("general.useragent.extra.firefox", "Firefox/3.6.3");
Confirming using the latest trunk nightly on Windows 7, using Silverlight 3 plugin. When I load the video in IE it works fine.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
I have the same problem since updating to 3.6.4. The videos on the German MSN video site won't play anymore. It works, however, without a problem in IE 8 and Firefox 3.6.3. So the new OOPP feature seems to cause this bug. Other Silverlight sites like Bing maps work, though. I'm using Silverlight 4. I hope this will be fixed. Please vote for it :).

Updated

8 years ago
Severity: normal → major
blocking1.9.2: --- → ?
Keywords: regression
(In reply to comment #3)
e.g. http://video.de.msn.com/watch/video/waka-waka-shakiras-wm-song-scheisse/5o2nnpqe

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100504 Minefield/3.7a5pre ID:20100504040059 + Silverlight 4.0.50401.0

presumably all video.%locale%.msn.com videos are broken.

Comment 5

8 years ago
WFM, mozilla-central, SL3, Win7. I'll try with SL4 in a sec.

Comment 6

8 years ago
Confirmed with SL4, though. An IPC message log doesn't show any obvious errors yet.

Comment 7

8 years ago
I have this in recording. I walked through it pretty carefully, and silverlight functions normally up through requesting http://img.widgets.video.s-msn.com/resource.aspx?resources=player&configCsId=&configName=&gmts=gmt&mkt=de-de&brand=v5&country=US

and successfully retrieving it. It appears that we deliver that data correctly. Then Silverlight stops doing anything. I don't know why.
I don't know if its any help, but I see Silverlight4 start to load, then a brief flicker of what appears to be Flash loading circle, as if the video did a 'fall-back' or something, then nothing...

Comment 9

8 years ago
There is definitely a flash object also on the page, which makes debugging a bit difficult, but it reproduces even if I flip flash to IPP and leave silverlight OOPP.

Comment 10

8 years ago
Yes, they offer a flash version of the videos, too, but it is only loaded in browsers which don't support Silverlight (like Opera). Otherwise the Silverlight version is loaded or, if it hasn't been installed yet, a popup for the installation appears.
We've reached out to Microsoft to see if they can help us understand what's going on here. Definitely a concern for 3.6.4, though, might require a build4 to address.
The Silverlight team is looking at this.

Comment 13

8 years ago
Good to hear. I hope they will find the cause of this.
3.6.3/silverlight 3 or 4 - works.
3.6.4/silverlight 3 or 4 - doesn't work.
Summary: [OOPP]Silverlight4 movie does not start at certain site → [OOPP]Silverlight movie does not start at certain site

Updated

8 years ago
Duplicate of this bug: 564440

Comment 17

8 years ago
Marking this as a blocker for now based on comment 14
blocking1.9.2: ? → .4+

Comment 18

8 years ago
Removing blocker flag based on email exchange. Looks like a bug in the MSN video player.
blocking1.9.2: .4+ → ---
I have an update from the Silverlight and MSN team's investigation. This turns out to be a bug in the video player on MSN. It boils down to a call to a JavaScript function made by the app over Silverlight's HTML DOM bridge. The caller wasn't tolerant to null. Further it seems running OOPP introduces a timing difference that didn't materialize in older Firefox versions. And this surfaced the behavior of media not playing back. 

The MSN team in fact had already fixed this in their futures branch. They're now looking at accelerating that fix in light of Firefox 3.6.4 release.

Comment 20

8 years ago
Great, thanks.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
blocking1.9.2: --- → .4+
Re-opening for now; there's some indication it might be more than just comment 19 (or so Ashish said in email)
Status: RESOLVED → REOPENED
blocking1.9.2: .4+ → ?
Resolution: WONTFIX → ---

Updated

8 years ago
blocking1.9.2: ? → .4+
status1.9.2: --- → wanted

Comment 22

8 years ago
The bug referenced in comment 21 is bug 564861

Comment 23

8 years ago
This ended up not being a problem in the MSN video player, it ended up being bug 564861. Though this bug is older, I'm going to dupe this to bug 564861 as it has the patch
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564861

Updated

8 years ago
blocking1.9.2: .4+ → ---
status1.9.2: wanted → ---
You need to log in before you can comment on or make changes to this bug.