File save/open dialogs should not be app modal.

VERIFIED FIXED in mozilla1.1alpha

Status

P3
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: braden, Assigned: bryner)

Tracking

Trunk
mozilla1.1alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
(not sure if this is the correct component)

The "Save file" dialog comes up modal. I don't see any reason why this should be
a modal dialog.

Comment 1

18 years ago
->future
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
Same for "file open" dialogs.
Summary: "Save file" dialog should not be modal. → File save/open dialogs should not be modal.
Target Milestone: Future → ---
(Reporter)

Updated

18 years ago
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
The real problem here is that these dialogs are app-modal rather than window-modal.
Summary: File save/open dialogs should not be modal. → File save/open dialogs should not be app modal.

Comment 4

18 years ago
That is unfortunate, but it still doesn't fit the profile for N6.
(Reporter)

Comment 5

18 years ago
I'm not sure what you're suggesting; this is a Mozilla bug.

Comment 6

18 years ago
I'm not suggesting anything, just saying that we, the assignees, will not fix
this in time for Netscape6.  ->bryner
Assignee: trudelle → bryner
Status: ASSIGNED → NEW
(Reporter)

Comment 7

18 years ago
Oh, of course. I knew that. :-)

Hm... Perhaps your comment arose from the fact that I goofed during a Bugzilla
collision and inadvertently overwrote some of the modifications you'd made. I
put the "Future" back (I thought), but perhaps I missed something else...

Comment 8

18 years ago
Braden, can you note your window manager, because these dialogs are window 
modal when running under gnome/enlightenment.
(Reporter)

Comment 9

18 years ago
I'm using Sawfish.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: Future → mozilla1.0

Comment 10

18 years ago
This is a dupe of 65521 or 65521 is a dupe of this.
(Reporter)

Comment 11

18 years ago
This bug is more specific than bug 65521. I'm making this bug depend on that one.
Depends on: 65521

Comment 12

18 years ago
*** Bug 85669 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 100537 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 101099 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
hmm i marked a Mac bug dup - is this one linux only?
->file handling. taking qa contact [for the nonce].
Component: XP Toolkit/Widgets → File Handling
QA Contact: jrgm → sairuh
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.1

Comment 17

17 years ago
*** Bug 112134 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Based on the bugs that have been marked as dups of this one, shouldn't OS be
changed to all?

I'm seeing the same thing on win2k with 2001112603

Comment 19

17 years ago
actually Bug 112134 isn't a dup of this one (reopening it). On windows, the 
File->Save, etc., dialog, while modal, is _window_ modal, not _app_ modal.
This bug is really Linux only, and is requesting that the dialog be (at least)
window modal.

(As for the Mac dup, I didn't read it, but on OS 9.0, convention is that all 
dialogs are app modal. mozilla's just bowing down to the Gods of the HIG in 
being app modal as well on OS 9).

Comment 20

17 years ago
should the dialog boxes be window modal or tab modal?  If I have multiple tabs
in the same window, I really want a file open/save as dialog box to affect only
that tab.

Comment 21

17 years ago
Found an inconsistancy in Open/Save.
Seems Open/Save - dialog is treated in another way than the "Select Filename"
dialog.

This is especially obvious on WindowMaker when setting "Open dialogs in same
workspace as their owners."

The first dialog does not honor this but the second "Select filename" does.

1. Open a file that will open the dialog for opening or saving the file.
2. Switch to another workspace before dialog has appeared
3. Choose the save option

Expected results:
The Select Filename - dialog should appear in the same workspace as the previous
dialog.

Acctual results:
The Select Filename - dialog appears in the workspace with the window with the
link that caused the first dialog to open.

This is really confusing and I think both dialogs should operate in a similar way.

However just a cosmetic+ issue AFAIAC.

Build: 2002021810
This bug is fixed now that modality on linux is non-broken (per clarification in
comment 3). It was fixed by bug 65521.  Comment 21 is actually referring to bug
135736
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
vrfy'd fixed using 2002.09.19.08 comm trunk build on linux rh7.2. per comment
21, the actual results i saw matched the expected results.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.