Closed Bug 560844 Opened 10 years ago Closed 10 years ago

Fennec maemo4 repacks bork on bookmarks.json

Categories

(Release Engineering :: General, defect, P1, blocker)

ARM
Maemo
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: aki)

References

Details

(Whiteboard: [fennec][l10n])

Attachments

(1 file, 2 obsolete files)

This isn't all of them -- just the locales outside of the 18 signed-off locales I believe.  Especially noticeable since a number of the multi-locales are included in this number.

Axel has an idea what's going on -- a bad file copy to the merge dir?

make[1]: Entering directory `/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/objdir/mobile/mobile/locales'
/usr/bin/python2.5 /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py \
	  -I /home/cltbld/build/maemo-1.9.2-nightly/releases/l10n-mozilla-1.9.2/cs/mobile/profile/bookmarks.inc \
	  -DAB_CD=cs \
	  /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/mobile/locales/generic/profile/bookmarks.json.in \
	  > bookmarks.json
Traceback (most recent call last):
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 477, in <module>
    main()
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 462, in main
    pp.handleCommandLine(None, True)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 168, in handleCommandLine
    self.do_include(f)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 447, in do_include
    self.handleLine(l)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 229, in handleLine
    self.write(aLine)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 150, in write
    aLine = f[1](aLine)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 409, in filter_substitution
    return self.varsubst.sub(repl, aLine)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/Preprocessor.py", line 407, in repl
    raise Preprocessor.Error(self, 'UNDEFINED_VAR', varname)
NEXT ERROR __main__.Error: ('/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/mobile/locales/generic/profile/bookmarks.json.in', 12, 'UNDEFINED_VAR', 'bookmarks_sync')
make[1]: *** [bookmarks.json] Error 1
make[1]: *** Deleting file `bookmarks.json'
make[1]: Leaving directory `/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/objdir/mobile/mobile/locales'
make: *** [chrome-cs] Error 2
Oh yikes, this is sooo not fennec's fault. It's apparently a regression in compare-locales from September, filed bug 560856 with the details.

I'm leaving this open and dependent so that we can check if a fix to compare-locales actually does fix this issue.
Depends on: 560856
Now that compare-locales is fixed (logs are fine), this is still broken.

I assume that the LOCALE_MERGEDIR=$PWD/merged doesn't survive the scratchbox magic, or otherwise points at the wrong path. With the right path, it works locally.

Moving this bug over to releng.
Component: General → Release Engineering
Product: Fennec → mozilla.org
QA Contact: general → release
Version: Trunk → other
Whiteboard: [fennec][l10n]
Priority: -- → P3
This seems to be breaking all Maemo5 repacks. Taking.
Assignee: nobody → aki
Blocks: 566428
Status: NEW → ASSIGNED
Attached patch this may fix it (obsolete) — Splinter Review
Needs staging, but this looks like the culprit.
Attached patch now with 100% more checkconfig (obsolete) — Splinter Review
since MaemoNightlyRepackFactory doesn't actually have a self.objdirRelPath.
Ugly, but scratchbox path fixes tend to be.
Attachment #445815 - Attachment is obsolete: true
Comment on attachment 445829 [details] [diff] [review]
now with 100% more checkconfig

Looks promising to me, didn't check the existing variables etc, but the concept is right. Thus feedback+ instead of r+
Attachment #445829 - Flags: feedback+
Attachment #445829 - Flags: review?(armenzg)
Comment on attachment 445829 [details] [diff] [review]
now with 100% more checkconfig

r+'ed in IRC
Attachment #445829 - Flags: review?(armenzg) → review+
Comment on attachment 445829 [details] [diff] [review]
now with 100% more checkconfig

(that was r=armenzg)

http://hg.mozilla.org/build/buildbotcustom/rev/cc6cd3854631
Attachment #445829 - Flags: checked-in+
Maemo4 still broken:

/usr/bin/python2.5 ../../config/Preprocessor.py \
	  -I /home/cltbld/build/maemo-trunk-l10n/l10n-central/zh-CN/mobile/profile/bookmarks.inc \
	  -DAB_CD=zh-CN \
	  ./generic/profile/bookmarks.json.in \
	  > bookmarks.json
Traceback (most recent call last):
  File "../../config/Preprocessor.py", line 477, in <module>
    main()
  File "../../config/Preprocessor.py", line 462, in main
    pp.handleCommandLine(None, True)
  File "../../config/Preprocessor.py", line 168, in handleCommandLine
    self.do_include(f)
  File "../../config/Preprocessor.py", line 447, in do_include
    self.handleLine(l)
  File "../../config/Preprocessor.py", line 229, in handleLine
    self.write(aLine)
  File "../../config/Preprocessor.py", line 150, in write
    aLine = f[1](aLine)
  File "../../config/Preprocessor.py", line 409, in filter_substitution
    return self.varsubst.sub(repl, aLine)
  File "../../config/Preprocessor.py", line 407, in repl
    raise Preprocessor.Error(self, 'UNDEFINED_VAR', varname)
__main__.Error: ('/home/cltbld/build/maemo-trunk-l10n/mozilla-central/mobile/locales/generic/profile/bookmarks.json.in', 12, 'UNDEFINED_VAR', 'bookmarks_sync')
Upping priority on myself; this is blocking 1.1rc1 (unless we decide to go to build w/out l10n debs).
Severity: normal → blocker
Priority: P3 → P1
Summary: Fennec repacks bork on bookmarks.json → Fennec maemo4 repacks bork on bookmarks.json
Was able to repack a deb on my vm running this command manually.
Attachment #445829 - Attachment is obsolete: true
Attachment #446304 - Flags: review?(armenzg)
Attachment #446304 - Flags: review?(armenzg) → review+
Comment on attachment 446304 [details] [diff] [review]
branchname/merged -> branchname/mobile/locales/merged

http://hg.mozilla.org/build/buildbotcustom/rev/9dd0794ec48d
Attachment #446304 - Flags: checked-in+
zh-CN just repacked successfully.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.