Startup issue: Rebuild profiles on major upgrades (or have manual option to do so)

RESOLVED DUPLICATE of bug 498181

Status

()

RESOLVED DUPLICATE of bug 498181
9 years ago
6 years ago

People

(Reporter: limi, Unassigned)

Tracking

(Blocks: 2 bugs, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Advo])

(Note: this is filed as a meta bug as part of the “Paper Cut” bugs since we assume that there are multiple existing bugs related to this behavior. Please make them block this bug.)

Some quotes from the Reddit “paper cuts” thread to illustrate this issue:

“Firefox takes 3 minutes and 12 seconds. Chrome is 7 seconds.”
“That’s insane. Make sure you are on Firefox 3.6.3 & try a fresh profile.”
“Well, shit. 5 seconds.”

“Many users on FX 3.6 have been upgrading since Firefox 2. This means they've been using the same profile for years which I'm sure is impacting performance. In my experience, creating a new profile is like reformatting and reinstalling Windows. Everything is fresh and quick. How about making it easier to do a "profile refresh" keeping only saved passwords and bookmarks?”

"Any upgraded installation older than two years runs very slowly. The most notable problem is typing in the location bar. The first time you do this in a new session it will lockup the UI for about 15 seconds. Subsequently you will get small lockups of about 1-5 seconds for the remainder of the session. I've noted this on two separate machines. Clearing the profile fixes it."


Recommendation:
WE HAVE THE TECHNOLOGY, WE CAN REBUILD THEM

Possibly export/import bookmarks and passwords? Think: “Local Weave” that puts the existing profile in a safe location, syncs to disk, then recreates a new profile. I'd prefer this to be part of the major upgrade, similar to how iTunes does a “updating your Music Library” on first start after upgrading.

People have old and corrupted profiles, we need to help them start fresh.
Vacuum in Places should have helped on 3.6. It was experimental to see if somebody was going to complain or suffer slowdowns. So far it was a pretty good experiment. We can add vacuum for all sqlite dbs in the profile, that is bug 541373.

I agree that the most common cause of issues i have solved talking to people in forums and in real life was the profile, and in many cases users thought they had to reinstall the app to solve their issues, they did not know at all they had a profile. I guess revising it is a large and complex task though, but making users aware of their profile could be a good step.
I was one of those users with a years-old profile. When I learned about how it could be slowing down Fx it took some searching to find which files should be nice to copy to a new profile in order to keep passwords, bookmarks and history. Having this process automated or semi-automated (a Wizard, for example) would reduce many cases of "Firefox is slooooow" complains, IMHO.

Comment 3

9 years ago
If [old, large] profiles are slow, doesn't that means that the default settings for the amount of data to store are too high? Or is it more of an issue of fragmentation and/or corruption? (what corrupts a profile anyway?)

Comment 4

9 years ago
(In reply to comment #3)
Antivirus programs can do it, as can just random bitrot, huge lists of preferences that extensions shoved into prefs.js and didn't remove...
Blocks: 565511
No longer blocks: 561125

Comment 5

9 years ago
"Rebuild profiles on major upgrades" sounds way too dangerous.  I don't see how an updater could determine which bits of the profile are "useful" and which are "cruft" if Firefox itself cannot.  It would cause more problems than it solves.

Instead, we should be more serious about fixing the kinds of bugs that we're currently telling users to work around by nuking their profiles.  Bug 541373 and bug 559505 will be large wins.  Are any of the dependencies of bug 123929 important?
Blocks: 123929

Comment 6

9 years ago
See also bug 552505, "'Restore to Factory Defaults' feature to remove customizations", and the corresponding m.d.a.firefox thread, http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/7db5cb38a5de0e41
Whiteboard: [Advo]

Comment 7

6 years ago
I believe this is basically covered by bug 498181. Please de-dupe if you strongly feel there is a reason to have separate bugs here. Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498181
You need to log in before you can comment on or make changes to this bug.