Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 561152 - Startup issue: Selectively be able to invoke session restore
: Startup issue: Selectively be able to invoke session restore
: meta
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal with 4 votes (vote)
: Firefox 4.0
Assigned To: Nobody; OK to take it and work on it
: Mike de Boer [:mikedeboer]
Depends on: 588482 593421
Blocks: cuts-startup 580046
  Show dependency treegraph
Reported: 2010-04-22 11:25 PDT by Alex Limi (:limi) — Firefox UX Team
Modified: 2012-01-18 06:19 PST (History)
20 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Alex Limi (:limi) — Firefox UX Team 2010-04-22 11:25:34 PDT
(Note: this is filed as a meta bug as part of the “Paper Cut” bugs since we assume that there are multiple existing bugs related to this behavior. Please make them block this bug.)

People like the ability to selectively invoke session restore. From Reddit thread: “I generally don’t want it, but sometimes it would be very useful, especially when restarting for updates”

With the new design, we could put “Restart” and “Restart & Save Session” in the “Exit” combomenu.

The other option would be to offer this whenever *we* ask to restart the browser, ie. “Save Session & Restart” being the default button text and behavior. I can't see why we'd need a button that didn't do a session restore on these forced restarts, though.
Comment 1 John Wayne Hill (UX Intern) 2010-07-14 17:01:22 PDT
Furthermore, we should now be able to "opt in" to a session restore using the new locally hosted home tab as well.
Comment 2 Mardeg 2011-03-05 20:15:09 PST
Should this be resolved FIXED?
Comment 3 Marcos Silvano 2012-01-10 10:16:07 PST
I'm using Firefox 9.0.1. If you set the Home Page to "Mozilla Firefox Start Page" on Preferences panel, a button to "Restore Previous Session" is shown at Firefox start. Furthermore, you have the same option at the History menu, called "Restore Previous Session". Is this you have in mind? If so, this issue could be closed.
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-01-10 12:12:11 PST
Yea, let's close this now. This was all in Firefox 4.
Comment 5 Siddhartha Dugar [:sdrocking] 2012-01-10 19:06:19 PST
Bug 664314 would be nice to have.

Note You need to log in before you can comment on or make changes to this bug.