Direct2D GPU drawing shows visual artifacts during tab switching, new tabs, etc

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: zapodlo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100421 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100421 Minefield/3.7a5pre (.NET CLR 3.5.30729)

I have enabled Direct 2D GPU acceleration, and when switching between various tabs, creating a new tab, and some other operations, the current tab's image switches to some background artifacts - flash videos from another tab, white boxes, or anything else that I had seen recently in one of the tabs, but usually not HTML content. Afterwards the image of the new tab is correctly rendered on top of it.

Installing the latest NVIDIA driver 197.54 did not help. My machine has two NVidia video cards - Quadro FX 570 and 1700. Minefield on all monitors have the same problem.

Reproducible: Always

Steps to Reproduce:
1. Set various tabs to different pages, preferably with one with Flash or some other plugin.
2. Enable Direct Drawing
3. Switch between tabs (ctrl+tab)
Actual Results:  
for a split second I can see dirty video memory buffer that I should not

Expected Results:  
direct switch to a new tab rendering
Could be a flavor of bug 532106.
Any chance the fixing of Bug 568719 in the latest builds brought any improvement?
I am still having this on Mozilla/5.0 (Windows; U; Windows NT 6.0; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100529 Minefield/3.7a5pre (.NET CLR 3.5.30729).

It is interesting that this doesn't happen if D2D is started within the session for me, but when the browser is restarted it happens on every tab.  Strangely as well, Bug 568495 and the Aero problem follows the same pattern, if I only turn on D2D manually in the session, I don't see either of these bugs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #3)
> I am still having this on Mozilla/5.0 (Windows; U; Windows NT 6.0; WOW64;
> en-US; rv:1.9.3a5pre) Gecko/20100529 Minefield/3.7a5pre (.NET CLR 3.5.30729).
> 
> It is interesting that this doesn't happen if D2D is started within the session
> for me, but when the browser is restarted it happens on every tab.  Strangely
> as well, Bug 568495 and the Aero problem follows the same pattern, if I only
> turn on D2D manually in the session, I don't see either of these bugs.

The pref is not live, you need to restart your browser for it to take effect.
Forgive my ignorance, but does gfx.font_rendering.directwrite.enabled = true go live immediately while mozilla.widget.render-mode = 6 does not?
(In reply to comment #5)
> Forgive my ignorance, but does gfx.font_rendering.directwrite.enabled = true go
> live immediately while mozilla.widget.render-mode = 6 does not?

Neither is live :).
Reporter

Comment 7

9 years ago
FF 4 Beta 1 still has this problem with the latest video drivers on all available monitors:

Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:2.0b1) Gecko/20100628 Firefox/4.0b1

NVidia Quadro FX 1700 & 570 (dual card triple monitor system), driver ver: 8.17.12.5849  date: 6/9/2010
Does this still occur after updating to the latest nVidia drivers and trying with the latest Fx nightly?
I cannot reproduce this. Please reopen if you can still reproduce.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.